none
FSRM volume quota over 150% RRS feed

  • Question

  • Hello,

    We have a soft quota configured on a data volume on our file server cluster running on server 2016.

    The volume is 3.63TB in size, so we have used the Monitor 3TB Volume template for the quota.

    Our usage on the volume is 2.74TB, so about 75% used.

    Our Quota is currently reporting quota usage of over 150%.

    Can anyone help me determine why the quota is currently sitting at that figure when we have not yet hit 100% of the 3TB volume limit?

    Many thanks

    James

    Wednesday, June 10, 2020 9:46 AM

All replies

  • Hi Eds,

    I found a thread has the similar issue with yours, please check if the solution in the thread below could be of help to you:

    https://social.technet.microsoft.com/Forums/lync/en-US/bdcdf491-c982-44b4-bb25-5ba468eb7aca/fsrm-and-quotas-showing-incorrect-values?forum=winserverfiles#a6e0af69-6b03-42f3-902b-48b16bcd8aaa

    Thanks for your time!

    Best Regards,

    Anne


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, June 11, 2020 8:00 AM
    Moderator
  • Hi Anne.

    Thanks for sharing that. We had already tried re-scanning the quota, without improvement.

    I am instead now recreating the quota using custom settings rather than and existing quota template, and will monitor once it has completed its initial scan.

    The only other thing I could think of that might effect this would be data dedupe.

    Will advise if the issue persists after quota recreation.

    Many thanks.
    Eds

    Thursday, June 11, 2020 9:32 AM
  • Hello,

    The quota rebuild has completed, but still shows a figure higher than we would expect.

    Here is volume usage:

    The quota reports over 95% usage:

    Alarmingly, rebuilding this quota seems to have removed all of our previous shadow copies, as the disk usage was over 75% and we only have the latest shadow copy from 12pm today.

    Any further thoughts please?

    Eds


    • Edited by Eds19891 Thursday, June 11, 2020 12:37 PM Add images
    Thursday, June 11, 2020 12:36 PM
  • Hi Eds,

    According to your description, the issue seems to be a little complex, after further research, I didn't find much more information about the issue. In order to do further troubleshooting, I would suggest open a case with MS, so that you may get better help about this issue.

    Below is the link to open case with MS:

    https://support.microsoft.com/en-us/gp/customer-service-phone-numbers

    Thanks for your understanding!

    Best Regards,

    Anne


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, June 15, 2020 7:24 AM
    Moderator
  • Hi Anne,

    Is there an email option instead of phone support?

    Many thanks.

    Eds

    Monday, June 15, 2020 8:20 AM
  • Hi Eds,

    As far as I know, when you call the phone number to open a case, you can tell the responder whether you would like to open a phone case or an email case. The number is a channel for us to open case with MS.

    Thanks for your time! If there's any other concerns or questions, please feel free to feedback. If there's not and you would like to end this thread, please mark the useful reply as answer to end it.

    Thanks for your time!

    Best Regards,

    Anne


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, June 16, 2020 2:14 AM
    Moderator
  • Hi Eds,

    I'd like to check if there's any additional assistance you needed in this thread, if yes, please feel free to feedback, if you would like to end this thread, please help to mark useful reply as answer.

    Thanks for your cooperation!

    Best Regards,

    Anne


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, June 19, 2020 8:45 AM
    Moderator
  • We do not have direct support contracts with Microsoft, so are unable to open a support case with them.

    We have opened a case with our third party consultant, asking them to raise with Microsoft directly, and will feedback here if we end up with an answer to this issue.

    Sunday, June 21, 2020 8:03 AM
  • Hi Eds,

    Thanks for your feedback. It will be appreciated if you can share the information with us once you get any progress on the issue. :)

    Best Regards,

    Anne


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, June 23, 2020 2:21 AM
    Moderator
  • We think we have determined the cause of this issue, to be data deduplication.

    The FSRM quota is using the size, rather than allocated space, attribute for files. As data dedupe replaces files with pointers for anything covered by data dedupe, the space taken is under 1KB but FSRM reports on the file size instead.

    Because data dedupe then stores all the deduped data within System Volume Information, the quota when set at volume level reports the size used by data dedupe PLUS the original files' size.

    This means you can be in a scenario where the quota usage is higher than available drive space. The resolution to which seems to be to move the quota off the volume root, and onto subfolder(s).

    Eds

    Thursday, July 9, 2020 4:41 PM