locked
Getting an error trying to create "My Organizational Forms Library" MAPI_E_NO_ACCESS

    Question

  • I am trying to create "My Organizational Forms Library" on my newly created Exchange Server 2007 64-bit on Windows 2003 Server.

    I followed all the steps from this Microsoft's article:
    http://technet.microsoft.com/en-us/library/cc540468.aspx

    But I am stuck at step # 15. When I double click on the "PR_EFORMS_LOCALE_ID" and edit the field "Unsigned Decimal" and type in 1033 for English and click OK. I get this error.

    Error: 
    Code: MAPI_E_NO_ACCESS == 0x80070005
    Function m_lpMAPIProp->SetProps( 1, m_lpsOutputValue, &lpProblemArray)
    File .\PropertyEditor.cpp
    Line 920
    


    Please Help!!!

    Thanks in advance.
    Thursday, July 23, 2009 6:44 PM

Answers

  • Do you have the correct permission and using the latest MFCMAPI.exe


    lasse at humandata dot se, http://anewmessagehasarrived.blogspot.com
    • Proposed as answer by Xiu Zhang Monday, July 27, 2009 6:35 AM
    • Marked as answer by Xiu Zhang Friday, July 31, 2009 10:03 AM
    Thursday, July 23, 2009 8:03 PM
  • Hi,

    I agree with Lasse. Permission to publish forms in the organizational forms library is typically reserved for Exchange administrators. Please use Exchange Admin to logon MFCmapi.exe You can run the cmdlt below to check if the account has ownership of the form library.

    Get-publicfolderclientpermission –identity “\non_ipm_subtree\eforms registry” | fl
    Get-publicfolderclientpermission –identity “\non_ipm_subtree\eforms registry\my organizational forms library” | fl


    Besides,please ensure that outlook 2007 has not been installed on Exchange Server 2007.

    Regards,
    Xiu
    • Proposed as answer by Xiu Zhang Tuesday, July 28, 2009 2:00 AM
    • Marked as answer by Xiu Zhang Friday, July 31, 2009 10:03 AM
    Monday, July 27, 2009 6:45 AM
  • Hi,

    Please run the cmdlt and then restart Microsoft System Attendant Service and then check the issue again.

    add-publicfolderAdministrativePermission -user xxxx -AccessRights Owner -identity “\NON_IPM_SUBTREE\eforms registry\my organizational forms library”

    Besides, please check the forms under Eforms registry using Mfcmapi.exe tool.

     

    There please check the value for msExchFolderAffinityCustom, msExchFolderAffinityList,it should be set to < Not set >

     

    Regards,

    Xiu

    • Marked as answer by Xiu Zhang Friday, July 31, 2009 10:03 AM
    Tuesday, July 28, 2009 2:13 AM

  • Okay, I finally was able to do it after I logged in as an "Administrator" instead of my own user name "RajP" - even though I am the member of the whole "Exchange Organization Admin", it still didn't work but I logged in as an Administrator and it finally worked.

    Now I am running into a NEW problem.

    I went to my Outlook and tried to create a new or design "Outlook Form" and when I try to publish by clicking "Publish", "Publish Form as..." and I tried to select "Organizational Forms Library", I got this error:

    "AN ERROR OCCURED WHILE GOING TO THIS FOLDER".

    Please help. Now what else is wrong???

    Thanks.
    Raj
    • Marked as answer by Xiu Zhang Friday, July 31, 2009 10:03 AM
    Tuesday, July 28, 2009 3:00 PM

All replies

  • Do you have the correct permission and using the latest MFCMAPI.exe


    lasse at humandata dot se, http://anewmessagehasarrived.blogspot.com
    • Proposed as answer by Xiu Zhang Monday, July 27, 2009 6:35 AM
    • Marked as answer by Xiu Zhang Friday, July 31, 2009 10:03 AM
    Thursday, July 23, 2009 8:03 PM
  • Hi,

    I agree with Lasse. Permission to publish forms in the organizational forms library is typically reserved for Exchange administrators. Please use Exchange Admin to logon MFCmapi.exe You can run the cmdlt below to check if the account has ownership of the form library.

    Get-publicfolderclientpermission –identity “\non_ipm_subtree\eforms registry” | fl
    Get-publicfolderclientpermission –identity “\non_ipm_subtree\eforms registry\my organizational forms library” | fl


    Besides,please ensure that outlook 2007 has not been installed on Exchange Server 2007.

    Regards,
    Xiu
    • Proposed as answer by Xiu Zhang Tuesday, July 28, 2009 2:00 AM
    • Marked as answer by Xiu Zhang Friday, July 31, 2009 10:03 AM
    Monday, July 27, 2009 6:45 AM
  • Hi,

    I agree with Lasse. Permission to publish forms in the organizational forms library is typically reserved for Exchange administrators. Please use Exchange Admin to logon MFCmapi.exe You can run the cmdlt below to check if the account has ownership of the form library.

    Get-publicfolderclientpermission –identity “\non_ipm_subtree\eforms registry” | fl
    Get-publicfolderclientpermission –identity “\non_ipm_subtree\eforms registry\my organizational forms library” | fl


    Besides,please ensure that outlook 2007 has not been installed on Exchange Server 2007.

    Regards,
    Xiu


    I am using Outlook 2007 on my own computer and Exchange 2007 sever is on a separate server. I am a member of "Exchange Organization Admin" group.

    I just ran it on the Exchange Management Shell and here are the results:

    [PS] C:\Documents and Settings\Administrator>Get-publicfolderclientpermission -identity "\non_i
    pm_subtree\eforms registry" | fl
    
    Identity     : \NON_IPM_SUBTREE\eforms registry
    User         : Default
    AccessRights : {Reviewer}
    Identity     : \NON_IPM_SUBTREE\eforms registry
    User         : Anonymous
    AccessRights : {None}
    [PS] C:\Documents and Settings\Administrator>Get-publicfolderclientpermission -identity "\non_i
    pm_subtree\eforms registry\my organizational forms library" | fl
    
    
    Identity     : \NON_IPM_SUBTREE\eforms registry\my organizational forms library
    User         : Default
    AccessRights : {Reviewer}
    
    Identity     : \NON_IPM_SUBTREE\eforms registry\my organizational forms library
    User         : sighomestyle.com/Users/Administrator
    AccessRights : {Owner}
    
    Identity     : \NON_IPM_SUBTREE\eforms registry\my organizational forms library
    User         : Anonymous
    AccessRights : {None}
    Now, how do I give myself Admin access to these???

    Please help!

    Thanks.
    Monday, July 27, 2009 4:19 PM
  • You can use below CMDLet for assign permission :

    Add-PublicFolderAdministrativePermission

    http://technet.microsoft.com/en-us/library/aa997986.aspx

    Anil
    • Proposed as answer by Anil K Singh Monday, July 27, 2009 4:41 PM
    Monday, July 27, 2009 4:40 PM
  • You can use below CMDLet for assign permission :

    Add-PublicFolderAdministrativePermission

    http://technet.microsoft.com/en-us/library/aa997986.aspx

    Anil

    Can you help me with the exact command that I should be typing in in my case please?

    I am total new to exchange and with so many conditions, it's hard for me to get it right for exactly what I am looking for.

    Thanks,
    Raj

    Edit:

    This is what I typed in Exchange management shell:

    [PS] C:\Documents and Settings\Administrator>Add-PublicFolderAdministrativePermission -User rajp -Identity "\non_ipm_subtree\eforms registry" -accessrights AllExtendedRights

    Then

    [PS] C:\Documents and Settings\Administrator>Add-PublicFolderAdministrativePermission -User rajp -Identity "\n
    on_ipm_subtree\eforms registry\my organizational forms library" -accessrights AllExtendedRights


    After that, I tried using Mapi Editor again and I still got the same error.

    Please help!!!

    Thanks,
    Raj

    Monday, July 27, 2009 6:33 PM
  • owner permission on the newly created folder should be enough. Verify with
    "Get-PublicFolderClientPermission -Identity '"\non_ipm_subtree\eforms registry\your new folder' "


    lasse at humandata dot se, http://anewmessagehasarrived.blogspot.com
    Monday, July 27, 2009 10:11 PM
  • Hi,

    Please run the cmdlt and then restart Microsoft System Attendant Service and then check the issue again.

    add-publicfolderAdministrativePermission -user xxxx -AccessRights Owner -identity “\NON_IPM_SUBTREE\eforms registry\my organizational forms library”

    Besides, please check the forms under Eforms registry using Mfcmapi.exe tool.

     

    There please check the value for msExchFolderAffinityCustom, msExchFolderAffinityList,it should be set to < Not set >

     

    Regards,

    Xiu

    • Marked as answer by Xiu Zhang Friday, July 31, 2009 10:03 AM
    Tuesday, July 28, 2009 2:13 AM
  • owner permission on the newly created folder should be enough. Verify with
    "Get-PublicFolderClientPermission -Identity '"\non_ipm_subtree\eforms registry\your new folder' "


    lasse at humandata dot se, http://anewmessagehasarrived.blogspot.com


    THis is what I got when I entered what you wrote above.

    [PS] C:\Documents and Settings\Administrator>Get-PublicFolderClientPermission -Identity "\non_ipm_subtree\efor
    ms registry\my organizational forms library"

    Identity                             User                                 AccessRights
    --------                             ----                                 ------------
    \NON_IPM_SUBTREE\eforms registry\... Default                              {Reviewer}
    \NON_IPM_SUBTREE\eforms registry\... sighomestyle.com/Users/Administrator {Owner}
    \NON_IPM_SUBTREE\eforms registry\... Anonymous                            {None}


    I don't see my user name in there - rajp

    Tuesday, July 28, 2009 1:46 PM

  • Okay, I finally was able to do it after I logged in as an "Administrator" instead of my own user name "RajP" - even though I am the member of the whole "Exchange Organization Admin", it still didn't work but I logged in as an Administrator and it finally worked.

    Now I am running into a NEW problem.

    I went to my Outlook and tried to create a new or design "Outlook Form" and when I try to publish by clicking "Publish", "Publish Form as..." and I tried to select "Organizational Forms Library", I got this error:

    "AN ERROR OCCURED WHILE GOING TO THIS FOLDER".

    Please help. Now what else is wrong???

    Thanks.
    Raj
    • Marked as answer by Xiu Zhang Friday, July 31, 2009 10:03 AM
    Tuesday, July 28, 2009 3:00 PM
  • Hi all,

    I also encounter this issue like Raj's case (step 15). Let take a look at my lab environment as follow:

    - Having Exchange 2010 server: contains normal user test and Exchange mail "test1@local.com"

    - Having non-domain PC which installed Outlook 2010 software, created profile for test1@aam1.com

    // Notes: all functions for "test1@local.com" work well.

    So,

    1. to solve this issue:

    Method 1:

    my PC should join domain that is same as Exchange  ?

    Method 2:

    Just grand right permission for tes1, or create Outlook profile for Administrator user of Exchange server

    Thanks,

    Kevin


    • Edited by cuocdoi Monday, October 21, 2013 2:09 PM
    Monday, October 21, 2013 2:08 PM