none
The WInRM client sent a request to an http server and got a response saying the requested http url was not availabe. RRS feed

  • Question

  • Hi,

     i have just installed a cas/ht roles of E2010, in a E2007 environment. I have a requirement where i have to configure the IIS -> default web site with a specific IP address ( the IP that is registered with the DNS). When i do that, the EMC / EMS fails with the following error.

     "The following error occured while attempting to connect to the specific exchange server . The attempt to connect to http /powershell using kerberos authentication failed: connecting to remote server failed with the following message: The WInRM client sent a request to an http server and got a response saying the requested http url was not availabe. This is usually returned by the http server that does not support the WS-Management protocol."

    When i set it back to all assigned, it works fine. I want to have additional web site for my another domain users. how do i achieve this?

     

     


    swamy
    Saturday, October 23, 2010 2:18 PM

Answers

  • Hi,

    I managed to get the EMC working by running the following commands

    winrm delete winrm/config/Listener?Address=*+Transport=HTTP

    winrm create winrm/config/Listener?Address=IP:192.168.2.1+Transport=HTTP

    Can someone please confirm this is the rightway of configuration??

     


    swamy
    • Proposed as answer by Xiu Zhang Monday, October 25, 2010 7:09 AM
    • Marked as answer by Xiu Zhang Monday, November 1, 2010 2:56 AM
    Saturday, October 23, 2010 3:18 PM

All replies

  • Hi,

    I managed to get the EMC working by running the following commands

    winrm delete winrm/config/Listener?Address=*+Transport=HTTP

    winrm create winrm/config/Listener?Address=IP:192.168.2.1+Transport=HTTP

    Can someone please confirm this is the rightway of configuration??

     


    swamy
    • Proposed as answer by Xiu Zhang Monday, October 25, 2010 7:09 AM
    • Marked as answer by Xiu Zhang Monday, November 1, 2010 2:56 AM
    Saturday, October 23, 2010 3:18 PM
    1. Open IIS Manager, and then navigate to Default Web Site.
    2. Right-click Default Web Site, and then click Edit Bindings.
    3. If a binding exists for HTTP, clear the host name value.
    4. If no binding exists for HTTP, create a new binding that has no host name and a value of All Unassigned for the IP address.
    5. Restart IIS.


    • Proposed as answer by Dario Bonini Thursday, April 7, 2016 7:40 AM
    Friday, June 28, 2013 3:01 PM
    1. Open IIS Manager, and then navigate to Default Web Site.
    2. Right-click Default Web Site, and then click Edit Bindings.
    3. If a binding exists for HTTP, clear the host name value.
    4. If no binding exists for HTTP, create a new binding that has no host name and a value of All Unassigned for the IP address.
    5. Restart IIS.


    Works well for me. Does this means that multiple apps can use port 80 if you choose All Unassigned ?
    Sunday, July 21, 2013 3:45 AM
  • Similar issue, thought I would add this to the search index since I couldn't find this error/answer elsewhere :)

      Was getting WinRM errors running the "Add File Share" in the Failover Cluster Manager.  Running Windows Server 2012 3 node failover cluster.  Domain is Windows Server 2008 R2 with Server 2008 R2 Functional Level. 

    There was a Group Policy Object (GPO) that had WinRM Client and WinRM Server settings applied to the file servers.  I removed them and ran GPUpdate /Force on all the server nodes in the cluster and closed all MMC's and tried again.  No errors.

    Looking back, I think the setting that caused the issue was

    Windows Components/Windows Remote Management (WinRM)/WinRM Client/  Trusted Hosts policy.

    I had specific subnets, although complete, that were set.  I believe that the local enumeration of the Failover Cluster Manager was being denied because 127.0.0.1 was not included or possibly the IPv6 IP network even though we don't use IPv6... that tends to be the resolved address locally.

    Removing these settings resolved not only the WinRM error symptoms, it also allowed me to see the "Share Location" values under "Select by Volume" in the Add File Share wizard when on the same server as the selected "server" which is the clustered file server resource.  Before, it would never show the volumes and not allow to Browse to select a folder when running the wizard on the host that owned the file server resource at the time.

    Here is an example error found in the Application log under >Microsoft>FileServices-ServerManager-EventProvider>Operational

    Exception: Caught exception Microsoft.Management.Infrastructure.CimException: The WinRM client sent a request to an HTTP server and got a response saying the requested HTTP URL was not available. This is usually returned by a HTTP server that does not support the WS-Management protocol.

       at Microsoft.Management.Infrastructure.Internal.Operations.CimSyncEnumeratorBase`1.MoveNext(Boolean discardResultsAndErrors)

       at Microsoft.Management.Infrastructure.Internal.Operations.CimSyncEnumeratorBase`1.MoveNext()

       at Microsoft.FileServer.Management.Plugin.Services.FSCimSession.PerformQuery(String cimNamespace, String queryString)

       at Microsoft.FileServer.Management.Plugin.Providers.WmiEnumerationTaskBase.QueryObjects(ICimSession session, String queryString)

       at Microsoft.FileServer.Management.Plugin.Providers.WmiStorageEnumerateTask.QueryObjects(ICimSession session, String queryString, String category, Exception& errorContext)

    Saturday, November 16, 2013 6:22 PM
  • In my case I was having issues remoting between workstations on domain. Looked at GPO and found WinRM settings that included IPV6=* filter and IPV4=10.x.x.x/8 ... if I turn this GPO off, remoting works per MS instructions.
    Wednesday, November 20, 2013 7:22 PM
  • Thanks SundarIndia. I did a change in the certificates and must have absentmindedly added the hostnames.  This resolved it!
    Thursday, July 2, 2015 8:17 PM
    1. Open IIS Manager, and then navigate to Default Web Site.
    2. Right-click Default Web Site, and then click Edit Bindings.
    3. If a binding exists for HTTP, clear the host name value.
    4. If no binding exists for HTTP, create a new binding that has no host name and a value of All Unassigned for the IP address.
    5. Restart IIS.


    This fixed my issue perfectly ! Thanks !!
    Saturday, July 16, 2016 3:05 AM
  • Thank you very much i really thought i had some deep issues without being able to get powershell working. I know this is an old post but feel you helped a guy out many years later. :) Dave
    Friday, May 26, 2017 3:19 AM
  • Hi Swamy,

    I have the same problem. is 192.168.2.1 the address of your server on the network or that of your Router?

    Marc

    Thursday, November 2, 2017 5:00 PM