Exchange 2010 Services don't start


  • Hi,


    I have 2 Exchange Server 2010 Running Client Access and Hub Transport in Load Balancing mode. There are running on Windows 2008 R2. There are all up-to-date. I'm running those server in a Vmware environement. Their have 4 processors and 8gb of racm each. We are running a big san under those vmware server and there is no performance issue.


    When I power on those server, the exchange service are starting and after some times stopping by them self. I don't have error in the even log. To start proprely my server, I have to restart the server up to 5 times.


    Somebody have an idea ?





    Tuesday, December 20, 2011 2:54 PM


All replies

  • Hi Marc,

    there is a problem with service delays / dependencies in some Exchange environments.

    This Article describes some of the issues.



    Tuesday, December 20, 2011 3:04 PM
  • Hi,

    Enable Exchange Diagnstic Logging & Set to High related Exchange Services.


    Tuesday, December 20, 2011 3:33 PM
  • What services isn't starting?

    Could you run Test-ServiceHealth and post the output?
    Martina Miskovic -
    Tuesday, December 20, 2011 5:12 PM
  • Hi,

    Can you start the service manually? If yes, then please try to follow the stepst below to set the service restart automatically.

    To configure a service to restart automatically, follow these steps:

    1. Open the properties of the Microsoft Exchange System Attendant in the Services MMC snap-in.
    2. Click Recovery.
    3. In the First failure box, click Restart the Service to restart the service on the first failure.
    4. In the Restart Service After box, type 3 so that the service restarts after three minutes.
    5. Repeat steps 1 to 4 for each Exchange Server service that does not start.

    Related article to share with you:

    Exchange Services May Not Start Automatically After a Reboot

    Xiu Zhang

    TechNet Community Support

    Thursday, December 22, 2011 8:44 AM
  • Set all the Exchange failing services to "Automatic (Delayed Start)" and reboot the server ,after reboot make sure all the service are starting normally

    In case if the issue is still persisit then ,

    1) Run DCDIAG to make sure there are no error releated to AD,make sure all the AD releated service "Netlogon" are running fine

    2) Also review the event viewer ,you will definatly find some cause for exchnage servies issue


    Please check and letus know the results .

    Viral Rathod Blog :
    Thursday, December 22, 2011 10:04 AM
  • OKay So I try to delay the services and nothing change.

    I run DCDIAG and there is no error. After activating the log, I found some error.



    Process MSEXCHANGEADTOPOLOGYSERVICE.EXE (PID=1628). Error ERROR_TIMEOUT (0x800705b4) occurred when DNS was queried for the service location (SRV) resource record used to locate a domain controller for domain

     The query was for the SRV record for

    . The DNS servers used by this computer for name resolution are not responding. This computer is configured to use DNS servers with the following IP addresses:


    . Verify that this computer is connected to the network, that these are the correct DNS server IP addresses, and that at least one of the DNS servers is running.

     For information about correcting this problem, Type in the command line:

    hh tcpip.chm::/sag_DNS_tro_dcLocator_messageB.htm


    Process MSEXCHANGEADTOPOLOGYSERVICE.EXE (PID=1628). Topology discovery failed due to LDAP_SERVER_DOWN error. This event can occur if one or more domain controllers in local or all domains become unreachable because of network problems. Use the Ping or PathPing command line tools to test network connectivity to local domain controllers. Run the Dcdiag command line tool to test domain controller health.






    This is strange. All my configuration is okay... all my domain controler are ok!


    After 3 reboot, the services are starting.


    Thursday, December 22, 2011 1:13 PM
  • Hi,

    Please try to increase the threshold for Exchange related services to 60000 or 90000

    By default, the timeout threshold is defined as 30 seconds. This default can be modified for the machine by changing the following registry setting:


    • Name: ServicesPipeTimeout
      Location: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control
      Type: DWORD

    Configuring Exchange Servers Without Internet Access

    By the way, how may NICs have been enabled for this computer? Please check the binding order of these Nics.




    Xiu Zhang

    TechNet Community Support

    Friday, December 23, 2011 6:58 AM
  • I try your regedit key and it'S still not working. I also try to disable IPv6. and it's still not working. I start to be desesoarete!


    Somebody have a other solution?



    Wednesday, December 28, 2011 2:41 AM
  • Hi,

    Please verify if you have Netlogon event 5719 logged in event viewer.

    Please try the method in article below:

    2601, 2604, and 2501 MSExchange ADAccess Event IDs when a Microsoft Exchange server restarts

    By the way, what is the NIC for your Exchange Server. Please change virtual nic from the vmware standard version

    Choosing a network adapter for your virtual machine

    Xiu Zhang

    TechNet Community Support

    Wednesday, December 28, 2011 7:01 AM
  • So I try to change all my drivers network card one by one and I'm having the same problem. I don't have netlogon event 5719. I have a lot of error message that saying that I can join the domain controler but I don't know why. All my network configuration is okay. When the server starts, I also made some network test (PING, TRACERT and RESOLV) everything is working fine. When the server won't start, I have to restart completly the server to make the services start.
    Thursday, January 05, 2012 1:24 PM
  • That is strange.

    Please try to run ExBPA to have a health scan.

    Besides, I'd like to know if you install these windows servers from images.


    Xiu Zhang

    TechNet Community Support

    Friday, January 06, 2012 6:47 AM
  • Few errors but I don't think that is related to my problem.

    Unknow shema extension version.  The Exchange schema extensions are from an unknown version. Schema version detected is 14726.

    Unknow Exchange signature. Active Directory domain 'BSDNAM' has an unrecognized Exchange signature. Current DomainPrep version: 13040.

    WMI service start-up account. The Windows Management Instrumentation (WMI) service on server is not configured to start-up as the computer account (LocalSystem). This configuration is not supported on Exchange servers. Current start-up account is localSystem.

    and VMware detected.

    Friday, January 06, 2012 6:17 PM
  • Hi,

    We can use NLtest to check if you can find Global Catalog from Exchange Server. Open a command prompt and then run command below and then post here.

    “nltest / /gc /force”

    “nltest / /gc /force”

    Xiu Zhang

    TechNet Community Support

    Monday, January 09, 2012 3:06 AM
  • C:\Windows\system32>nltest / /gc /force
               DC: \\
          Address: \\
         Dom Guid: d6843b21-c6c1-4794-bea7-123ae03ca06f
         Dom Name:
      Forest Name:
     Dc Site Name: Montreal
    Our Site Name: Montreal
    The command completed successfully
    C:\Windows\system32>nltest / /gc /force
    List of DCs in pseudo-random order taking into account SRV priorities and weight
    Non-Site specific:
    The command completed successfully
    Monday, January 09, 2012 12:47 PM