none
Exchange 2003/2007 Replication Error 0x80040107

    Question

  • When attempting to replicate data from our Exchange 2003 legacy server to our recently set up Exchange 2007 server. During the replication process however, I am receiving the following errors on the receiving (2007) server.

    Event 3035:

    Type 0x4

     

    followed by:

    Event 3089

    Error 0x80040107 occurred while processing an incoming replication message on Public Folder Store "Second Storage Group\Public Folder Database"

    which is followed by:

    Event 3079

    Unexpected replication thread error 0x80040107 on database "Second Storage Group\Public Folder Database"

    REPL::EcSeekReplid

    REPL::EcSeek

    EcGetSenderDN

    REPL::EcSeekRmq

    EcSeekReplState

    EcReplMessageUnpack

    FReplRcvAgent

    I have used message tracker from both the sending and receiving server, and see that the message is flowing properly.

    I am at a loss as to how to fix this issue.

     

    Thank you in advanced.

    Thursday, September 23, 2010 12:19 AM

Answers

All replies

  • Hi

    Is there anything in queue viewer?

    Are you trying to replicate or move the items?

     

    Start the replication and let it go for 24-48h

     


    Jonas Andersson MCTS: Microsoft Exchange Server 2007/2010 | MCITP: EMA 2007/2010 | MCSE/MCSA Blog: http://www.testlabs.se/blog
    Thursday, September 23, 2010 7:36 AM
  • There is nothing in queue viewer.

     

    We are attempting to replicate. I have pushed the replication by doing a synchronize heirarchy, as well as a resend changes to clear the backfill.

     

    It's after I attempt these two moves that I start seeing these errors.

    Thursday, September 23, 2010 12:02 PM
  • I will note however, that every once in a while I do see some things in the queue viewer, and the public folder database did double in size (from 1.5 gb to 3 gb) though it is nowhere near the 17-20 gb that it should be.

    Thursday, September 23, 2010 12:43 PM
  • Hi,

     

    Please refer to the following steps to troubleshoot the issue.

     

    1. Temporarily disable firewall and antivirus program on each machine, and then replicate the Public Folders again.

     

    2. Please refer to the following article to increase Diagnostics Logging level for Replication to expert.

     

    http://support.microsoft.com/kb/842273

     

    If the error message persists, please also try the suggestions from the link below:

     

    http://msexchangeteam.com/archive/2006/01/17/417611.aspx

     

    Thanks.


    Novak Wu-MSFT
    Friday, September 24, 2010 8:10 AM