none
Exceeded the maximum of 500 objects of type "objtFolder" error on mailbox server

    Question

  • I am receiving the following errors in the event log on our mailbox server:

    "Mapi session "/o=First Organization/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Recipients/cn=cvmailconnectlnds" exceeded the maximum of 500 objects of type "objtFolder". "
    This is the only account reporting the error. We use Commvault for mailbox archiving and 

    cvmailconnectlnds is the account that Commvault uses for recovery of emails from archive. Any idea what can be done to fix these errors??
    Our Exchange environemnt is as follows:

    Windows 2003 Active Directory domain
    Exchange 2007 sp1 with latest roll-up installed: 2 CAS servers, 2 Mailbox servers with CCR, 2 HT servers

    Monday, January 25, 2010 3:37 AM

All replies

  • Hi,

    The MAPI connection for this mailbox is exceeding the default value for objtFolder in Exchange 2007.

    Read here: http://technet.microsoft.com/en-us/library/aa996193(EXCHG.80).aspx

    The value can be upped, but I would recommend speaking to Commvault to see what their recommendations are.

    Oliver
    Oliver Moazzezi | Exchange MVP, MCSA:M, MCTS:Exchange 2010, BA (Hons) Anim | http://www.exchange2007.com | http://www.exchange2010.com | http://www.cobweb.com |
    Monday, January 25, 2010 12:49 PM
  • Hi,

    The MAPI connection for this mailbox is exceeding the default value for objtFolder in Exchange 2007.

    Read here: http://technet.microsoft.com/en-us/library/aa996193(EXCHG.80).aspx

    The value can be upped, but I would recommend speaking to Commvault to see what their recommendations are.

    Oliver
    Oliver Moazzezi | Exchange MVP, MCSA:M, MCTS:Exchange 2010, BA (Hons) Anim | http://www.exchange2007.com | http://www.exchange2010.com | http://www.cobweb.com |

    I'm getting this error in the event viewer on exchange 2010, on our mailbox server.. but this registry key doesnt exist..

    Any thoughts?
    Monday, March 15, 2010 4:40 PM
  • Hi,

    The MAPI connection for this mailbox is exceeding the default value for objtFolder in Exchange 2007.

    Read here: http://technet.microsoft.com/en-us/library/aa996193(EXCHG.80).aspx

    The value can be upped, but I would recommend speaking to Commvault to see what their recommendations are.

    Oliver
    Oliver Moazzezi | Exchange MVP, MCSA:M, MCTS:Exchange 2010, BA (Hons) Anim | http://www.exchange2007.com | http://www.exchange2010.com | http://www.cobweb.com |

    I'm getting this error in the event viewer on exchange 2010, on our mailbox server.. but this registry key doesnt exist..

    Any thoughts?
    typically we see this when users have a large shared mailbox attached in their outlook...or several shared mailboxes attached to their outlook.
    Monday, April 12, 2010 2:47 AM
  • Hi,

    I have a very similar issue, but is for a specific user who accesses multiple mailbox's in her profile. I cant find the reg key to increase the connections value as running Exchange 2010.

    Can anyone help?

    Wednesday, April 21, 2010 11:48 AM
  • same problem here. anyone an idea?

    best regards,
    Joerg

     

    Wednesday, June 02, 2010 7:26 AM
  • The account I had was used for Commvault archiving. Commvault could'nt shed any light on the error so we created a new account whcih fixed it (for now anyway).
    Thursday, June 10, 2010 6:22 AM
  • still no location for that reg key? Hello MSFT?!?!?!
    http://exchangedeepthoughts.blogspot.com
    Tuesday, August 10, 2010 9:08 PM
  • Hello Guys,

     

    For Exchange 2003 and Exchange 2007, please refer to the below KB :

    http://support.microsoft.com/default.aspx?scid=kb;EN-US;842022

     

    As for Exchange 2010, I would suggest checking the default throttling policy that will determine how many mapi sessions i can use to access the info store.

    or

    Create

    store.exe.config file in folder C:\Program Files\Microsoft\Exchange Server\V14\Bin

    with content

    <?xml version="1.0" encoding="utf-8" ?>
    <configuration>
        <runtime>
            <gcServer enabled="true" />
            <generatePublisherEvidence enabled="false"/>
        </runtime>
        <appSettings>
            <!-- Specifies the maximum number of sessions permitted per user. -->
            <add key="MaxSessionsPerUser" value="5000 " />
        </appSettings>
    </configuration>

    Restart MSexchangeIS service and try

     


     

    my two cents....

    • Proposed as answer by MTwaishi Tuesday, August 10, 2010 9:30 PM
    Tuesday, August 10, 2010 9:21 PM
  • I don't see a store.exe.config in that location; all the other expected config files are there...
    http://exchangedeepthoughts.blogspot.com
    Wednesday, August 11, 2010 3:47 PM
  • Create the file...
    Wednesday, August 11, 2010 8:28 PM
  • Hello Guys,

     

    For Exchange 2003 and Exchange 2007, please refer to the below KB :

    http://support.microsoft.com/default.aspx?scid=kb;EN-US;842022

     

    As for Exchange 2010, I would suggest checking the default throttling policy that will determine how many mapi sessions i can use to access the info store.

    or

    Create

    store.exe.config file in folder C:\Program Files\Microsoft\Exchange Server\V14\Bin

    with content

    <?xml version="1.0" encoding="utf-8" ?>
    <configuration>
        <runtime>
            <gcServer enabled="true" />
            <generatePublisherEvidence enabled="false"/>
        </runtime>
        <appSettings>
            <!-- Specifies the maximum number of sessions permitted per user. -->
            <add key="MaxSessionsPerUser" value="5000 " />
        </appSettings>
    </configuration>

    Restart MSexchangeIS service and try

     


     

    my two cents....

    I created the file and store.exe wouldn't start with the following error:

    Activation context generation failed for "C:\Program Files\Microsoft\Exchange Server\V14\bin\store.exe".Error in manifest or policy file "C:\Program Files\Microsoft\Exchange Server\V14\bin\store.exe.Config" on line 9. Invalid Xml syntax.

     

    Anyone see what the syntax issue is? I tried removing the xtra space in "5000 " to "5000", but no luck.


    http://exchangedeepthoughts.blogspot.com
    Saturday, August 14, 2010 5:16 PM
  • this seems to have done it:

    • Outlook client doesn’t update folders automatically. On the status bar instead of “All folders are up to date” message “This folder was last updated on …” is displayed.

      Your Microsoft Exchange 2010 server logs the following error:

      Event ID: 9646
      Type: Error
      Source: MSExchangeIS
      Description:
      Mapi session "/o=First Organization/ou=Administrative Group/cn=Recipients/cn=user"
      exceeded the maximum of 500 objects of type "objtFolder".
      

      The number of server-side objects that are allowed by clients is limited to prevent a single client from the exhausting resources on the Exchange server.

      To resolve this problem:

      1. Open Registry Editor and navigate to:

      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\MSExchangeIS
      

      2. Right click ParametersSystem and create New -> Key

      3. Enter MaxObjsPerMapiSession and confirm creation of the new sub-key

      4. Right click newly created key, create new DWORD value called objtFolder and give it a decimal value bigger than default 500.

      5. Create another DWORD value called objtFolderView and give it the same value.

      There’s no need to restart Exchange server or even MSExchangeIS service. Give it some time and things will settle down. You might need to restart Outlook client to start synchronising folders again.

      Filed under - KB No Comments so far. Add yours now

      <ins style="display: inline-table; height: 60px; position: relative; visibility: visible; width: 468px; padding: 0px; margin: 0px; border: initial none initial;"><ins id="google_ads_frame3_anchor" style="display: block; height: 60px; position: relative; visibility: visible; width: 468px; padding: 0px; margin: 0px; border: initial none initial;"></ins></ins>

    PREVIOUS POSTS

    • Aug 08, 2010

      No Comments

      Data Protection Manager 2010 offsite backup to USB drives using Firestreamer VTL

      Firestreamer is a software utility that enables the existing tape backup software to access a wide range of non-tape storage media, making possible long-term and off-site retention of data without the need for tape drives. It has an impressive list of media it supports and works really well with Microsoft Data Protection Manager 2010. For...

    • Aug 07, 2010

      No Comments

      Synchronize time with external NTP server on a Domain Controller

      On a domain network, computers synchronize time with Domain Controller that holds the PDC Emulator role. This Domain Controller takes it’s time from BIOS. It’s generally good practice to synchronize time with Internet time source like pool.ntp.org. To configure PDC Emulator to synchronize with external time source, execute following from elevated Command Prompt: w32tm /config...

    • Aug 07, 2010

      No Comments

      AD CS and Subject Alternative Names on SSL certificates

      If you want to use Subject Alternative Names on internal SSL certificates issued by Active Directory Certificate Services you have to configure CA (Certificate Authority) to accept SAN attribute from a certificate request. By default CA does not issue certificates with SAN attribute. Ability to connect without certificate issues (warning) to internal web server using...

    • Aug 06, 2010

      No Comments

      Allow users to install local printers on Windows 7 using Group Policy

      In addition to: http://theintegrity.co.uk/2010/08/how-to-allow-users-to-install-printers-using-group-policy/ which allows users to install printers shared on the network without Administrator credentials, below are the instructions on how to allow users install local printers on their machines. This comes handy if you want to allow laptop users to install printers at home. In Group Policy Management Editor go to: Computer...


    Page 1 of 41234»

    RSS FEED

    Subscribe to feed 
    get the latest updates!

    <form id="ksearchform" style="margin-top: 20px; margin-right: 0px; margin-bottom: 20px; margin-left: 0px; padding: 0px;" action="http://theintegrity.co.uk/" method="get">
    <input id="s" style="padding-top: 8px; padding-right: 0px; padding-bottom: 8px; padding-left: 4px; height: 14px; width: 215px; float: left; margin: 0px; border: 1px solid #cccccc;" name="s" size="18" type="text" /><input id="ksearchsubmit" class="btn" style="float: left; height: 32px; width: 70px; background-image: initial; background-attachment: initial; background-origin: initial; background-clip: initial; background-color: #cccccc; color: #333333; text-transform: uppercase; background-position: initial initial; background-repeat: initial initial; padding: 0px; margin: 0px; border: 1px solid #cccccc;" type="submit" value="Search" />

    </form>


    http://exchangedeepthoughts.blogspot.com
    • Proposed as answer by Andy Rusch Wednesday, December 12, 2012 6:18 PM
    Saturday, August 14, 2010 5:24 PM
  • Had the same problem with Commvault as well, RSS feeds that got auto subscribed when an admin had the account open were the culprit.  Logged in as the user, removed the feeds and everyone is fixed.
    Friday, October 29, 2010 10:43 PM
  • Knightly - Thank you, that did the trick.  I have one user who has around 1000 folders in his mailbox, and it was causing all of the Admins to have trouble updating.  Thank you again!
    Monday, February 14, 2011 6:02 PM
  • Outlook client doesn’t update folders automatically. On the status bar instead of “All folders are up to date” message “This folder was last updated on …” is displayed.

    Your Microsoft Exchange 2010 server logs the following error:

    Event ID: 9646
    Type: Error
    Source: MSExchangeIS
    Description:
    Mapi session "/o=First Organization/ou=Administrative Group/cn=Recipients/cn=user"
    exceeded the maximum of 500 objects of type "objtFolder".
    

    The number of server-side objects that are allowed by clients is limited to prevent a single client from the exhausting resources on the Exchange server.

    To resolve this problem:

    1. Open Registry Editor and navigate to:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\MSExchangeIS
    

    2. Right click ParametersSystem and create New -> Key

    3. Enter MaxObjsPerMapiSession and confirm creation of the new sub-key

    4. Right click newly created key, create new DWORD value called objtFolder and give it a decimal value bigger than default 500.

    5. Create another DWORD value called objtFolderView and give it the same value.

    There’s no need to restart Exchange server or even MSExchangeIS service. Give it some time and things will settle down. You might need to restart Outlook client to start synchronising folders again

     

    Semih SOYKAL

    • Proposed as answer by Andy Rusch Wednesday, December 12, 2012 6:18 PM
    Thursday, November 10, 2011 12:14 PM
  • Dear Semih SOYKAL, I found this solution you posted months ago and I wanted to ask you about it if you don´t mind. This is what happening in my Exchange 2003 - Outlook 2010 scenario where I started a couple of months ago with this event IDs and client issues:

     *I gave it a decimal value of 900, 1000 and 1500 and the error keeps appearing in the event log. (with the new number configured, eg : " Exceeded the maximum of 900 objects of type "objFolder" and the name of the user accessing the server )

    *This only happens to one account. (but happens to be the managers!)

    *This Outlook client opens 3 more accounts apart from the user´s.  When Outlooks is launched : Starts updating slowly and then crashes (freezes) and sometimes a "Not enough virtual memory" error pops up. The hardware specs:  intel i5-4gb RAM ddr3- HDD 1 tb.

    *Can´t change the email working philosophy : manager must have access to all the additional accounts and can´t delete more messages. (theres is a huge amount of folders, subfolders and emails, almost 10 gbs of them in his own account...)

    Thank you for all the help! Im eagerly looking for a solution for this.

    Regards,

    Antonio

    Monday, October 07, 2013 6:35 PM