none
Unable to track least recently accessed files in FSRM RRS feed

  • Question

  • Hi,

    Thinking I've missed something here. We're running Windows Server 2019 (latest update, but it was not working on previous updates). I try to run the Least Recently Accessed files report in FSRM like I've done on previous servers and I hit the same error each time:

    This File Server is currently configured to not track last access time for files, therefore the last access time might be inaccurate for some or all the files on NTFS volumes

    I've checked the registry and NtfsDisableLastAccessUpdate is set to 80000000 (I've tried 80000003 as well). I've also run the query - fsutil behavior query disablelastaccess and as expected, it is set to 0 (User Managed, Disabled) (as it's set to 3 (System Managed, Disabled) when I change the registry entry to 80000003).

    I'm really not sure what else I've missed but nothing seems to get it working.

    Any ideas?

    Thanks,

    Steve.

    Tuesday, July 9, 2019 9:34 AM

All replies

  • Hi,

    Thanks for your question.

    Please check the following thread which talked about a similar situation as yours, hope it helps.

    https://social.technet.microsoft.com/Forums/en-US/89e4ad8f-c4cd-4d8c-b3b4-fa3da0bf877d/unable-to-get-least-accessed-files-from-fsrm-report?forum=winserverfiles

    Highly appreciate your effort and time. If you have any question or concern, please feel free to let me know.

    Best regards,

    Michael


    Please remember to mark the replies as an answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com


    Wednesday, July 10, 2019 8:11 AM
    Moderator
  • No that does not help. As explained in my original post, I have set the registry as recommended in that link you posted and it does not work.
    Wednesday, July 10, 2019 12:45 PM
  • Hi,

    Thanks for your update.

    This value determines whether NTFS updates the last-access timestamp on each directory when it lists the directories on an NTFS volume.

    There’re two values of REG_DWORD type, 0 and 1. If it's not there or the value is anything but 0, then your server is not tracking last access time and FSRM prints the warning you are seeing. So, this value should be set to 0.

    Details,

    https://docs.microsoft.com/en-us/previous-versions/windows/it-pro/windows-2000-server/cc959914(v=technet.10)

    Hope above information can help you.

    Highly appreciate your effort and time. If you have any question or concern, please feel free to let me know.

    Best regards,

    Michael


    Please remember to mark the replies as an answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Thursday, July 11, 2019 9:37 AM
    Moderator
  • Hi,

    How are things going on?

    Please feel free to let me know if you need further assistance.

    Best regards,

    Michael


    Please remember to mark the replies as an answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Saturday, July 13, 2019 11:04 AM
    Moderator
  • Hi,

    Just checking in to see if the information provided was helpful. Please let us know if you would like further assistance.

    Best Regards,

    Michael


    Please remember to mark the replies as an answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Wednesday, July 17, 2019 10:59 AM
    Moderator
  • Hi,

    Was your issue resolved?

    If you resolved it using our solution, please "mark it as answer" to help other community members find the helpful reply quickly.

    If you resolve it using your own solution, please share your experience and solution here. It will be very beneficial for other community members who have similar questions.

    If no, please reply and tell us the current situation in order to provide further help.

    Best Regards,

    Michael


    Please remember to mark the replies as an answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Wednesday, July 24, 2019 10:02 AM
    Moderator
  • Hi,

    Sorry for the delay in replying. No this is still not fixed. In my original post, I explained the setting that I have. In Server 2019, there are now 4 options you can use, not 2, and as I've already previously said, it's set to the correct setting yet I am still getting the same error. The 4 options now are:

    • 0x80000000: User Managed, the “Last Access” updates are enabled, (this is set when you set it to 0)
    • 0x80000001: User Managed, the “Last Access” updates are disabled,
    • 0x80000002: System Managed, the “Last Access” updates are enabled,
    • 0x80000003: System Managed, the “Last Access” updates are disabled

    I know this is a big issue that many people have had on previous versions of the OS, so I made sure to put all the relevant information in my original post to prevent being linked to the same pages I've already looked at.

    Kind Regards,

    Steve

    Thursday, September 19, 2019 7:55 AM