none
Always ask before opening this type of file - IE11 RRS feed

  • Question

  • Hi,

    I'm trying to troubleshoot an issue with Internet Explorer and they way it handles opening file from the Internet. Sometimes it gives a prompt like this:

    Which is great, I want to turn this on for all common document types (e.g. PDF, Word Docs, Zips). What I've found is you have to either untick the option 'Always ask before opening this type of file', or delete a registry key in

    HKEY_CURRENT_USER\Software\Microsoft\Windows\Shell\AttachmentExecute

    When I check my PC I find I don't have that option and the registry keys aren't present.

    Could someone clarify this for me? I'm running IE11 and Windows 7. 

    Thanks

    Dave


    • Edited by I.T. Dave Monday, September 29, 2014 3:15 PM
    Monday, September 29, 2014 3:07 PM

Answers

  • Hi,

    In Windows 7, there is no the key AttachmentExecute by default. For this reason, Checkbox for "always ask before opening this type of file" is missing in the Download prompt window.

    Actually, you can choose to add this key in your Registry by following txt, Copy them to notepad, then renamed as .reg file. After that, import to Registry.

    Windows Registry Editor Version 5.00

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\Shell\AttachmentExecute\{0002DF01-0000-0000-C000-000000000046}] 
    " AcroPDF.PDF.1"=hex(0): 


    Roger Lu
    TechNet Community Support

    Tuesday, September 30, 2014 8:39 AM
    Moderator

All replies

  • Hello,

    This appears usually in every IE for common files like PDF, WORD, etc if settings are not changed.  If this is not appearing for you for common files then check:

    http://247support.custhelp.com/app/answers/detail/a_id/8892/~/internet-explorer%3A-no-download-prompt-appears

    Otherwise;

    Please seeWhat to do when Internet Explorer isn't working.

    See: "How to Reset Internet Explorer settings".


    If the issue persists...

    1. Please download and run the Microsoft Safety Scanner tool (freeware).
    2. Reboot your PC.
    3. Please download and update Malwarebytes Anti-Malware Free
    4. Reboot Windows in Safe Mode and run a Full Scan with Malwarebytes Anti-Malware.

    If still no joy...

    5. Download and Run AdwCleanerRogueKiller and Junkware Removal Tool (Freeware)
    6
    . Reboot and Test.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Monday, September 29, 2014 8:50 PM
  • Hi,

    In Windows 7, there is no the key AttachmentExecute by default. For this reason, Checkbox for "always ask before opening this type of file" is missing in the Download prompt window.

    Actually, you can choose to add this key in your Registry by following txt, Copy them to notepad, then renamed as .reg file. After that, import to Registry.

    Windows Registry Editor Version 5.00

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\Shell\AttachmentExecute\{0002DF01-0000-0000-C000-000000000046}] 
    " AcroPDF.PDF.1"=hex(0): 


    Roger Lu
    TechNet Community Support

    Tuesday, September 30, 2014 8:39 AM
    Moderator
  • Hello Roger Lu!

    Many thx! we also had this problems and this registrykey was the solution!

    Thx


    Wednesday, October 1, 2014 2:32 PM
  • What about on Win 8 and Win10?
    Thursday, January 28, 2016 4:56 PM
  • This didn't work after I upgraded to Win10?
    Thursday, January 28, 2016 4:58 PM
  • This works. Just remove the space between the " and AcroPDF.PDF.1
    Thursday, June 30, 2016 3:14 PM
  • I have performed these processes and a few others from various articles, and none seem to have added the "Always ask before opening this type of file" option from the View Downloads menu.  Therefore, it cannot be unchecked and continues to prompt the user to "Open" before opening pdf's from some websites.  Most sites just open the PDF in another tab, but not all sites. 

    Any suggestions?

    Thursday, July 21, 2016 2:39 PM