none
ECP Issues "Sorry! We're having trouble processing your request right now" RRS feed

  • Question

  • I'm getting the following Alert Box popup in ECP for many of the features very frequently

    Sorry! We're having trouble processing your request right now. Please try again in a few minutes.

    This is a new installation of ES2010SP1 /HOSTED on a single server

    The error occurs on USER ecp access and Administrator Access to different features. It may happen on 70% of the features and then all of a sudden all the features suddenly work. the Server only has two domains with 4 accounts per domain. 4 cores and 16GB and not suffering any resource issues?

     

     


    Mark Masiak Infologic.uk.com
    Saturday, August 14, 2010 9:11 PM

Answers

  • 1. Do you have a proxy in between?

    2. Do you somehow configure host header on the server?

    The error "There can be at most one address per scheme in this collection. " seems to indicate that it is not able to perform multiple binding. Did you change anything on the IIS on the CAS?


    Regards, Kip Ng - http://blogs.technet.com/b/provtest/
    • Marked as answer by Mark-Masiak Tuesday, August 17, 2010 3:37 PM
    Tuesday, August 17, 2010 3:11 PM
    Answerer

All replies

  • noticed the following errors in the Application log example spelling but it's basically the same for others such as MobileDevices.svc

    WebHost failed to process a request.
     Sender Information: System.ServiceModel.ServiceHostingEnvironment+HostingManager/35583289
     Exception: System.ServiceModel.ServiceActivationException: The service '/ecp/Customize/SpellingOptions.svc' cannot be activated due to an exception during compilation.  The exception message is: This collection already contains an address with scheme http.  There can be at most one address per scheme in this collection.
    Parameter name: item. ---> System.ArgumentException: This collection already contains an address with scheme http.  There can be at most one address per scheme in this collection.
    Parameter name: item
       at System.ServiceModel.UriSchemeKeyedCollection.InsertItem(Int32 index, Uri item)
       at System.Collections.Generic.SynchronizedCollection`1.Add(T item)
       at System.ServiceModel.UriSchemeKeyedCollection..ctor(Uri[] addresses)
       at System.ServiceModel.ServiceHost..ctor(Type serviceType, Uri[] baseAddresses)
       at Microsoft.Exchange.Management.ControlPanel.EcpServiceHostBase..ctor(Type serviceType, Uri[] baseAddresses)
       at Microsoft.Exchange.Management.ControlPanel.ServiceHostFactory.CreateServiceHost(Type serviceType, Uri[] baseAddresses)
       at System.ServiceModel.Activation.ServiceHostFactory.CreateServiceHost(String constructorString, Uri[] baseAddresses)
       at System.ServiceModel.ServiceHostingEnvironment.HostingManager.CreateService(String normalizedVirtualPath)
       at System.ServiceModel.ServiceHostingEnvironment.HostingManager.ActivateService(String normalizedVirtualPath)
       at System.ServiceModel.ServiceHostingEnvironment.HostingManager.EnsureServiceAvailable(String normalizedVirtualPath)
       --- End of inner exception stack trace ---
       at System.ServiceModel.ServiceHostingEnvironment.HostingManager.EnsureServiceAvailable(String normalizedVirtualPath)
       at System.ServiceModel.ServiceHostingEnvironment.EnsureServiceAvailableFast(String relativeVirtualPath)
     Process Name: w3wp
     Process ID: 6364

     

     


    Mark Masiak Infologic.uk.com
    Saturday, August 14, 2010 10:14 PM
  • Hmm... that's really weird. How many CAS do you have in your environment?


    Regards, Kip Ng - http://blogs.technet.com/b/provtest/
    Tuesday, August 17, 2010 2:54 PM
    Answerer
  • just the one
    Mark Masiak Infologic.uk.com
    Tuesday, August 17, 2010 2:57 PM
  • 1. Do you have a proxy in between?

    2. Do you somehow configure host header on the server?

    The error "There can be at most one address per scheme in this collection. " seems to indicate that it is not able to perform multiple binding. Did you change anything on the IIS on the CAS?


    Regards, Kip Ng - http://blogs.technet.com/b/provtest/
    • Marked as answer by Mark-Masiak Tuesday, August 17, 2010 3:37 PM
    Tuesday, August 17, 2010 3:11 PM
    Answerer
  • 1. No Proxy

    2. a single host header had been created for http port 80 access.

    HEADER/IP/PORT

    /*/80 (http)

    /*/443 (https)

    /127.0.0.1/80 (http)

    /127.0.0.1/443 (https)

    mail.domain.com/*/80 (http)

    have since removed "mail.domain.com/*/80 (http)" and everything is functioning now (probably).

     


    Mark Masiak Infologic.uk.com
    • Proposed as answer by Mark Masiak Monday, May 11, 2015 9:57 AM
    Tuesday, August 17, 2010 3:37 PM
  • Hi Guys,

     

    I'm with the same problem here.

     

    I'm running a SingleBox - Exchange 2010 Sp1 - with the latest rollout update 1. Everything working fine, but Rbac panel gives me the same error.

    Only one domain www.rewar.com.br - 1 exchange server running - and i have TMG 2010 as Firewall to publish my exchange to outside.

     

    I've double and tripple checked for everything. and also post another request for help here. http://forums.msexchange.org/Problem_with_Exchange_2010_SP1_%2f_Rollout_1_-_ECP/m_1800540127/tm.htm

     

    So for i cannot fix this myself. Can someone help me out.

     

    Sunday, October 17, 2010 5:26 PM
  • Firstly, does it work on the box itself? If not, then we need to look at the box. If yes, then we need to look at the publishing instead.

    Regards, Kip Ng - http://blogs.technet.com/b/provtest/
    Tuesday, October 19, 2010 5:23 AM
    Answerer
  • Hello all,

    I am facing the same issue on my ESXi box with single box Exchange 2010 SP1. I am not able to access RBAC web gui from server itself.

    Regards, Ilkin

    I had a second http hostheader. Removed it and installed RPC over HTTP. Not sure which step resolved the issue.

    It works fine now.

    • Proposed as answer by Ilkin Jamalli Tuesday, January 11, 2011 10:55 AM
    Tuesday, January 11, 2011 9:00 AM
  • I was experiencing this issue; 3 CAS servers.

    I had changed the host headers on the default website to listen specifically to the server's internal DNS name as I had configured an additional site to perform the HTTP-HTTPS /owa rewrite.

    I removed the internal hostname from the HTTP header on the default website & added the external domain-name to the host header of the 'redirect' website (eg mail.mycompany.com)

     

    IISrestart and all working!

     

    Cheers.

    Wednesday, June 29, 2011 2:21 AM
  • The issue is with double binding!

    I removed our external FQDN binding (remote.company.com) and left only the local FQDN binding (server1.domain.local).

    Fixed the issue.

    Now... I have to log on to https://remote.company.com to get access from out of the network to any of our ecp or owa, etc. websites. Regular http site stopped working since the external FQDN binding was removed.

    Will keep monitoring to see if anything else stops working or breaks!


    dbanyong
    Saturday, July 2, 2011 1:50 PM
  • Same issue happen to me with no result ,,, ( Sorry we "re having trouble processing your request right now please try again in few minutes.) and some times appear another message ( The web pages isn't loading properly please reload the page by refreshing your browser .)

    Kindly i cannot fix this issue

    Monday, August 1, 2011 12:49 PM
  • For me, what worked was deleting both the ecp and owa virtual directories, then recreating them:

    Get-EcpVirtualDirectory | Remove-EcpVirtualDirectory
    New-EcpVirtualDirectory

    Get-OwaVirtualDirectory | Remove-OwaVirtualDirectory

    New-OwaVirtualDirectory

     

    If you don't do both, it will fail.

     

    Monday, January 30, 2012 3:18 AM
  • If you go into EMC>Server Config>Client Access  you wil see Outlook Web App, Exchange Control Panel, these need to match your Bindings in IIS, once I changed them I was able to make changes ECP and also delete messages that I was unable to delete before.


    Wednesday, February 1, 2012 9:14 AM
  • We had this issue as well.  Check the IIS Manager -> Application Pool settings, and change the MSExchangeECPAppPool to .NET V2.  We were getting application exceptions, and we saw "Error (500) Internal Server Error" when running test-ecpconnectivity; after a call with Microsoft, we found that .NET version 4 was causing the issue.

    Hope this helps

    JP Babiera
    Wednesday, October 16, 2013 8:36 PM
  • Hi guys,

    Same here - .NET V4 issue - please check all virtual folders - should be .NET v2

    NGrigoras

    Monday, November 11, 2013 6:51 PM
  • This worked for me.
    Saturday, January 25, 2014 4:26 AM
  • Thanks, JP. After much research, your solution resolved my issue.
    Tuesday, April 22, 2014 2:47 PM
  • Another cause can be authentication settings on the ECP virtual folder. You should have Anonymous enable, that fixed the issue for us. Check the EventLog.
    Wednesday, June 11, 2014 6:24 PM
  • This worked for me. Thanks :)

    Wednesday, August 27, 2014 8:36 AM
  • Great, worked for me, many thanks
    Monday, September 8, 2014 11:41 AM
  • Thank you. This fixed the issue on our Exchange server.
    Sunday, May 10, 2015 9:23 PM
  • Thanks for this post. My out of office in outlook and web access are working again after removing this 'external' binding.

    I had multiple bindings on my default website and removed the one with the FQDN. Without creating a new local binding and a iisreset is everything fine now!

    Thursday, May 28, 2015 8:07 AM
  • Changing the MSExchangeECPAppPool to .NET V2 worked for me. Thanks

    Carlos F. Márquez


    • Edited by cmr3082 Monday, August 17, 2015 6:11 PM
    Monday, August 17, 2015 6:10 PM
  • Excellent! change to v2 work for me...

    But not problem to downgrade and use 2.0?

    Thanks!!

    Wednesday, September 2, 2015 2:45 AM
  • For me  change from v4 to v2 worked .. thanks a lot
    Wednesday, October 28, 2015 8:40 AM
  • Hi JP,

    although it's a few years ago your sollution was spot-on!! I changed MSExchangeECPAppPool and MSExchangeOWACalendarAppPool from .Net4 to .Net2 and restarted IIS.

    Thanks for your help!

    Gtz, Jelle

    Thursday, March 24, 2016 8:05 PM
  • Changing MSExchangeECPAppPool to .NET V2 worked for me. 

    I had trouble using Exchange2010 SP3 on Server2016 for testing. 

          

    C







    • Edited by 1.FreddyD Tuesday, September 19, 2017 12:49 PM
    Tuesday, September 19, 2017 12:43 PM
  • .NET 4 was the issue for me. Changing to .NET v2 fixed it. THANKS!
    Thursday, February 21, 2019 5:44 PM