Unable to download and view Attachments with Chinese characters.


  • Hi Technet experts,


    I got one computer who can't download attachments with filenames in chinese characters.

    Details as follows:


    -once email with attachment in chinese is on inbox, you can see the filename properly and the size shows like 26 KB or any.

    -but if the email was saved on the disk, the filename goes like this 24?79?345?34?787?844?87?.PDF and worse, the saved file shows 0KB as file size.

    -If the email was forwarded, the recieving party shows no issues. The attachment was forwarded fine.

    -But if the attachment was viewed or saved on the disk, it was not showing anything. Can't open the file.


    Things done:

    -re-installed outlook, test - no go.. applied microsoft office updates, test no go..

    -copied OLE32.dll from a working computer then over-written the existing one, regsvr32 ole32.dll, test no go...


    Please advise.  Machne is running on win XP with SP2.


    Thanks so much.

    Monday, September 29, 2008 7:28 AM


  • If you have Symantec Endpoint Protection installed disable it and try opening your attachment again. The same issue happening here and that fixes it. Where we go go from here though.....


    Friday, November 07, 2008 5:12 PM

All replies

  • Does this workstation have the East Asian Language support pack installed?


    Monday, September 29, 2008 12:06 PM

    Hi Jeff,


    Yeah. We have the East Asian Support pack installed on the machine.


    Thanks for your response.

    Tuesday, September 30, 2008 4:21 AM
  • Hi,


    In order to narrow down our issue, I suggest you configure this user on another PC and test the issue again.


    Please also make sure there is no third party add-in in Outlook and you can try to start Windows in Clean boot to test the issue. Could please let us know if the attachment can be open directly in inbox?


    Meanwhile, you can compare the language settings with other computers to see if there is any difference.






    Tuesday, September 30, 2008 9:55 AM
  • Hi Elvis,


    We have tried to ask the user to try a different computer. She didn'y had issues on it.


    There's no add-on on the Outlook/Office cuz we have also tried re-installing the application. We've also run MS Office updates and no go.


    We have also re-installed the Supplemental language support but no help.


    Clean boot also showed the same results.


    Please advise. Thanks.


    Friday, October 03, 2008 1:37 AM
  • Hi,


    Please also install all necessary Windows updates. Meanwhile, you can try to rename the attachment to a shorter name when saving it to your desktop to see if the issue persists.






    Friday, October 03, 2008 8:16 AM
  • Hi Elvis,


    We've got all neccesary MS Offcie and Windows updates installed on the machines.

    Doing "Save As" or renaming the attachment didn't change anything.




    Friday, October 03, 2008 9:04 AM
  • Hi Guys,


    Any updates on this?


    Thank so much.

    Thursday, October 09, 2008 5:45 AM
  • Hi Guys,


    Im still getting the same issue on board. However, I am attaching a sample email header which is having the problem.

    See below:


    Microsoft Mail Internet Headers Version 2.0
    Content-class: urn:content-classes:message
    MIME-Version: 1.0
    Content-Type: application/ms-tnef;
    Content-Transfer-Encoding: binary
    X-MimeOLE: Produced By Microsoft Exchange V6.5
    Subject: FW: copies of invoices
    Date: Tue, 2 Sep 2008 15:22:16 +0800
    Message-ID: <>
    X-MS-Has-Attach: yes
    X-MS-TNEF-Correlator: <>
    Thread-Topic: copies of invoices
    Thread-Index: AckMucD74MkMFwDdRGmn5Chsx+gsvwAEto0A
    From: "Nancy Lim" <>
    To: "Peter Li" <>


    I do suspect that it's got something to do with the winmail.dat that's found on the header.

    We have tested to resend the attachment in plain text format and still the attachment was being shown with alphanumeric filename and 0KB.


    Hope that's this would help you come up with something.



    Monday, November 03, 2008 5:47 AM
  • Using WinMail and sending attachments, whether pictures or documents, will place Chinese characters in my email body.  People who receive my emails frequently ask, "What are those character symbols in your emails?"  Not a good thing and is not related to the header as far as I can determine.  MS, no solutions?

    Friday, November 07, 2008 9:55 AM
  • If you have Symantec Endpoint Protection installed disable it and try opening your attachment again. The same issue happening here and that fixes it. Where we go go from here though.....


    Friday, November 07, 2008 5:12 PM

    Hi Wisp,


    Disabling Endpoint really work, I am now trying to put exception on the Outlook OLK folder, we'll see if it would work.

    If not, try re-install the endpoint client itself.


    You really made the rest of my day! Thanks!!







    MS guys! what happened to you?!?!?!?! Thought you were the experts around here??????

    -You've just demonstrated how you abandon your customers.

    Tuesday, November 11, 2008 10:12 AM
  • Hi Potzkie15,


    Sorry for the late update. Actually, I suggested to start Windows in Clean Boot in order to eliminate the third party affection in my first post. If it didn’t work, I need more time to investigate the root cause.


    As the limitation of forum, it’s not convenient for us to collecting information or a deeply research for tough issue. In the future, if you meet some urgent issue on Outlook, I suggest contacting our Support Professional directly which can help the issue to be fixed in a timely manner.


    Outlook support link


    Thank you for your understanding.






    Wednesday, November 12, 2008 2:00 AM
  • I think we have two users with two different problems.  Maybe I simply am on the wrong forum or whatever.  My problem is that, though I write in English, those people who receive my emails see Chinese language characters in addition to my English language characters (letters of the alphabet).  This seems to be particular to those people who have gmail or a private firm's email address.  Is this the correct forum or what forum should I be reading?  Thanks.


    Wednesday, November 12, 2008 3:19 AM
  • Hi Elvis,


    I believed i have done what you have told before.


    Anyways, still I thank you for acknowledging. Hopefully, you guys would reply to any further follow  up or what. It makes an impression to all that you don't care at all after providing few solutions to inquiries such as this.



    Wednesday, November 12, 2008 3:05 PM