none
NIC Teaming - Host unmanageable RRS feed

  • Question

  • I have just installed Server 2012 Datacenter edition with 4 NICs. I setup HyperV and was thinking of setting up NIC teaming for the VMs, but whenever I launch the NIC teaming option from Server Manager I get the right server listed, but it is listed as Host Unmanageable.

    Am I missing a feature or something like NLB? I tried installing that and it also didnt work after that.


    ...

    Tuesday, November 6, 2012 10:58 AM

Answers

All replies

  • Are you doing this from Server Manager of the host on which you are trying to create the teams, or are you doing this from a central system running RSAT Server Manager?

    Please tell us a little more about the configuration.


    tim

    Tuesday, November 6, 2012 3:41 PM
  • Hi,

    Please check whether NIC teaming is enabled in your server:

    Open Server Manager --> in the console tree, click Local Serer --> in the details pane, in the Properties section, check NIC Teaming status.

    To configure NIC Teaming on a server

    1. Click the server name in the list of servers (even if there is only a single server).
    2. From the Tasks drop-down menu in the Teams section, click New Team.
    3. In the Add Team dialog box, type a team name and select the network adapters in the team.
    4. If you are using VLANs, clear the Default check box and specify the VLAN ID. By default, the team will deliver up all traffic received regardless of VLAN ID (though the VLAN ID is passed with the packet so that other components in the stack can sort them appropriately).
    5. If you want to use a mode other than the default, click Advanced and specify the teaming mode (Switch Independent, Static Teaming, or LACP) and load distribution mode (Address Hash) as needed.
    6. Click OK to create the team.

      

    The Address Hash option for the load distribution mode is the 4-tuple   hash previously described. PowerShell cmdlets for NIC Teaming allow you to   configure other address hashing modes.

    1. To modify the settings of a network adapter team, click the team name in the list of teams, and then click Modify team in the list of tasks.

    For more information please refer to following MS articles:

    NIC Teaming Overview
    http://technet.microsoft.com/en-us/library/hh831648.aspx
    NIC Teaming in Windows Server 2012
    http://blogs.technet.com/b/privatecloud/archive/2012/06/19/nic-teaming-in-windows-server-2012-brings-simple-affordable-traffic-reliability-and-load-balancing-to-your-cloud-workloads.aspx

    Hope this helps!

    TechNet Subscriber Support

    If you are TechNet Subscription user and have any feedback on our support quality, please send your feedback here.

     


    Lawrence

    TechNet Community Support

    Wednesday, November 7, 2012 5:37 AM
    Moderator
  • Hi Tim,

    Did them from from Server Manager and lbfoadmin.exe. Configuration is completely default as it is a clean OS install and added HyperV role.


    ...

    Thursday, November 8, 2012 7:54 AM
  • Hi,

    It is known bus in Windows Server 8 Beta (name changed to Windows Server 2012) version of NIC Teaming:

    The UI will start from a command prompt without administrator privileges.  It will show the local host as Host Unmanageable.  Work around: cancel the UI and restart with administrator privileges or start the UI from Server Manager.

    For more information please refer to following MS articles:

    NIC Teaming (LBFO) in Windows Server "8" Beta‎
    http://download.microsoft.com/download/E/1/3/E13C9AD6-B4D6-4041-97E0-6BDC48273BC7/Windows%20Server%208%20Beta%20NIC%20Teaming%20(LBFO)%20Deployment%20and%20Management.docx

    Hope this helps!

    TechNet Subscriber Support

    If you are TechNet Subscription user and have any feedback on our support quality, please send your feedback here.


    Lawrence

    TechNet Community Support

    Friday, November 9, 2012 3:36 AM
    Moderator
  • Hi,

    I would like to confirm what is the current situation? Have you resolved the problem or do you have any further progress?

    If there is anything that we can do for you, please do not hesitate to let us know, and we will be happy to help.


    Lawrence

    TechNet Community Support

    Tuesday, November 13, 2012 6:59 AM
    Moderator
  • Hi,

    As this thread has been quiet for a while, we assume that the issue has been resolved. At this time, we will mark it as 'Answered' as the previous steps should be helpful for many similar scenarios.

    If the issue still persists and you want to return to this question, please reply this post directly so we will be notified to follow it up. You can also choose to unmark the answer as you wish.

    In addition, we'd love to hear your feedback about the solution. By sharing your experience you can help other community members facing similar problems.

    Thanks!


    Lawrence

    TechNet Community Support

    Friday, November 16, 2012 6:12 AM
    Moderator
  • Hello Lawrence (or college of course),

    Although this seems to be a very old issue I'm stuck with it now in a recent SERVER2012 installation. I have installed NIC teaming with <name>, and in local server this <name> appears indeed, but 'NIC teaming' shows 'Disabled'. Clicking on 'Disabled' shows the the following information about SERVERS in the NIC Teaming interface:

    Servername is displayed as it is.
    Status is 'Host unmanageable'
    Servertype is 'Physical'

    Other boxes show no information (no TEAMS and no ADAPTERS AND INTERFACES

    Can you help me with this issue? Thanks a lot in advance.

    Best regards,
    Leo Hendriks

    Thursday, January 29, 2015 7:15 PM
  • Hello Lawrence (or college of course),

    Although this seems to be a very old issue I'm stuck with it now in a recent SERVER2012 installation. I have installed NIC teaming with <name>, and in local server this <name> appears indeed, but 'NIC teaming' shows 'Disabled'. Clicking on 'Disabled' shows the the following information about SERVERS in the NIC Teaming interface:

    Servername is displayed as it is.
    Status is 'Host unmanageable'
    Servertype is 'Physical'

    Other boxes show no information (no TEAMS and no ADAPTERS AND INTERFACES

    Can you help me with this issue? Thanks a lot in advance.

    Best regards,
    Leo Hendriks

    Adding to this: in the TASKS dropdown, 'Enable Administration' is checked, but is greyed out.
    Thursday, January 29, 2015 7:19 PM
  • The "solution" is not to edit wmi or registry, apparently the lbfoadmin tool caches only the last session opened.

    To open it correctly use the server manager under local server section or run "lbfoadmin /servers ." which is what the server manager does.

    Have a nice day.

    Wednesday, February 4, 2015 9:59 AM
  • I know this was a long time ago but I just resolved this issue myself. I had set one of my NIC's to have a static IP...once I set the IP's back to DHCP it showed all of my NIC's and allowed me to team them together.

    Thursday, January 25, 2018 3:10 AM
  • Hi, I have the same problem. I configured the network cards by DHCP, but I still have the same problem. Do you have any other solution? Thank you.

    Sunday, June 24, 2018 2:46 PM
  • I just ran into this issue, and you'll never guess what caused it: the server name was longer than 15 characters. Yes, NetBIOS rears its ugly, obsolete head yet again! In my case, changing the server's name to something shorter and rebooting it fixed the problem completely.

    Friday, August 24, 2018 8:28 PM
  • I just ran into this issue, and you'll never guess what caused it: the server name was longer than 15 characters. Yes, NetBIOS rears its ugly, obsolete head yet again! In my case, changing the server's name to something shorter and rebooting it fixed the problem completely.

    You sir, have saved the day.

    My hosts were "unmanageable" until I reduced the hostname length to <=15 characters.

    Monday, March 25, 2019 11:02 AM
  • I was having the same issue with Server 2016.  I made the computer name less than 15 and everything works great.
    Wednesday, December 4, 2019 11:05 PM