locked
Public Folder Replication issue RRS feed

  • Question

  • Where does one set the timeout for replicating public folder content between servers?  I've got three global sites that aren't getting the updates and i suspect it's because it's timing out.. The public folders contain applications that are about 180 megs in total.  I can see the message in the HUB queues, but eventually it fails and i get "451 4.4.0 Primary target IP address responded with: "421 4.4.2 Connection Dropped."  Occassionally one will replicate successfully, but not often enough to be reliable.  Replicating to local sites (with a much faster connection) happens no problem are configured identically to the global sites.

    It seems like all the settings available are for retry intervals and not the connection timeouts themselves.

    Ex2k7 SP1, latest rollups installed on all servers.

    Tuesday, September 29, 2009 8:48 PM

Answers

  • HI,
    You can resolve this problem by increasing the receive connector timeout settings. By default it is 10 minutes but if messages are as large as you describe, they will timeout.
    You can increase to an hour by using the exchange command shell

    Set-receiveconnector –identity “default servername” –connectiontimeout 01:00:00

    Where "default servername" is the name of the default receive connector on each server (this can be found in exchange management console > server configuration > hub transport)

    You can copy and paste the above command but change "servername" to the name of your server.

    Hope this helps

    • Marked as answer by blinkyjesus Friday, October 2, 2009 3:24 PM
    Friday, October 2, 2009 3:11 PM

All replies

  • Alternatively, is there some way to manually move the public folder contents to the other MBX servers?
    Wednesday, September 30, 2009 1:50 PM
  • Only way would be to export it to PST and then import the same to another server
    Vinod |CCNA|MCSE 2003 +Messaging|MCTS|ITIL V3|
    Friday, October 2, 2009 1:51 PM
  • I ended up moving the posting mailbox to each global site and then uploading it from a system local to the MBX server.  After that i killed replication altogether.  It was slow and ugly, but it worked.
    Friday, October 2, 2009 2:56 PM
  • HI,
    You can resolve this problem by increasing the receive connector timeout settings. By default it is 10 minutes but if messages are as large as you describe, they will timeout.
    You can increase to an hour by using the exchange command shell

    Set-receiveconnector –identity “default servername” –connectiontimeout 01:00:00

    Where "default servername" is the name of the default receive connector on each server (this can be found in exchange management console > server configuration > hub transport)

    You can copy and paste the above command but change "servername" to the name of your server.

    Hope this helps

    • Marked as answer by blinkyjesus Friday, October 2, 2009 3:24 PM
    Friday, October 2, 2009 3:11 PM
  • Thanks!
    Friday, October 2, 2009 3:24 PM