none
Outlook disable rpc over https

    Question

  • Hi

    I have a customer with and Small Business Server 2011, and he is connecting with Outlook 2013.

    Regularly get rpc over http disabled on clients outside the office.

    I have tryed following:

    To disallow MAPI/HTTP and force RPC/HTTP to be used.
    HKEY_CURRENT_USER\Software\Microsoft\Exchange]
    “MapiHttpDisabled”=dword:00000001
    To allow MAPI/HTTP simply delete the
    MapiHttpDisabled DWORD, or set it to a value of 0 as below.

    without any luck.

    A hint would be nice

    Best Regards

    John B

    Thursday, March 16, 2017 1:40 PM

All replies

  • Hello John,

    As we know, it's an Exchange server 2010 in SBS 2011. And, we cannot disable RPC/HTTP in Outlook side.

    If you want to disable RPC/HTTP in Exchange side, you can choose to not publish Outlook Anywhere (RPC/HTTP) to external.

    If you want to disable RPC/HTTP for special account, run below command to disable:
    Set-CASMailbox <UserName> -MAPIBlockOutlookRpcHttp $true

    Best Regards,

    Allen Wang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, March 17, 2017 7:09 AM
    Moderator
  • hi allen
    thanks for your reply.

    I do not want to disable "rpc over http" I want that to be enabled.

    For some reason it is deactivated on a regular basis which is frustrating when users are away from the office.

    A hint would be nice

    Best Regards

    John B


    • Edited by ms-support Saturday, March 18, 2017 5:06 AM
    Friday, March 17, 2017 7:29 AM
  • HTTP over RDP?  That's not a thing.

    Outlook Anywhere in Exchange 2010 is RPC over HTTPS.  If you want Outlook to connect without a VPN, then you need this.

    If user machines' registries are being changed, then you might look for a GPO that might be doing it.  Exchange doesn't change that.


    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."
    Celebrating 20 years of providing Exchange peer support!


    Saturday, March 18, 2017 2:47 AM
  • hi Ed
    thanks for your reply.

    Sorry that I made a "typo". I have now corrected it :-)

    I do not want to disable "rpc over http" I want that to be enabled.

    For some reason it is deactivated on a regular basis which is frustrating when users are away from the office.

    A hint would be nice

    Best Regards

    John B

    Saturday, March 18, 2017 5:08 AM
  • I gave you one.  Look for a GPO.

    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."
    Celebrating 20 years of providing Exchange peer support!

    Saturday, March 18, 2017 6:21 AM
  • Hi Ed

    thanks for your reply

    I already saw it :-)

    This case only regards 1 person out of 20 and it is only happening outside of the office and not on a regular basis.

    You still think I should look at a GPO ??

    Best Regards

    John B

    Saturday, March 18, 2017 7:50 AM
  • All of that would have been useful to know in your original post.  Now I'd say that you have some kind of an Outlook or network problem specific to that user's Outlook, PC or network.

    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."
    Celebrating 20 years of providing Exchange peer support!

    Sunday, March 19, 2017 4:28 AM
  • @John, do you publish Outlook Anywhere to internet?
    If so, you can use ExRCA to test its connectivity (select Outlook Connectivity).
    If you get any error message, please post here for analyzing.

    Best Regards,

    Allen Wang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, March 20, 2017 5:41 AM
    Moderator
  • Hi Allen

    thanks for your reply

    This case only regards 1 person out of 20 and it is only happening outside of the office and not on a regular basis.

    Do you think it may have something to do with the connection to the Exchange server? It is only 1 person that has the problem.

    This person has a update Windows 7 to Windows 10 and is using Outlook 2013 (other persons has the same)

    A hint would be nice:-)

    Best Regards

    John B

    Monday, March 20, 2017 7:23 AM
  • @John, would you please post the detail errors when configure this problematic account in Outlook?

    Best Regards,

    Allen Wang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, March 22, 2017 5:10 AM
    Moderator