none
Exchange 2010 and MAPI sessions exceeded the maximum of 16 objects of type "session".

    Question

  • Hi,

    We just received problem with the maximum numbers of MAPI sessions.

    The user that gets this problem is an migration user that open numerous of IMAP sessions. But i Guess as it's 2010 this converts to MAPI sessions from the CAS to the MBX...

    We think this came with rollup 1 but even an uninstall of rollup 1 did not solve the issue. This has worked fine before..

    We have  tried the 2003/2007 reg keys for highering the values with the MaxObjsPerMapiSession keys and the Maximum Allowed Sessions Per User key.
    http://support.microsoft.com/default.aspx?scid=kb;EN-US;842022
    http://support.microsoft.com/kb/830829

    We also tried the View information store status permission but nothing helps...

    How does you increase the number of mapi sessions in 2010?? Any help is appreciated..... Al old articles for 2003 AND 2007 seems to have an default value of 32. but the error here says 16??

    Log Name:      Application
    Source:        MSExchangeIS
    Date:          2010-01-18 14:54:22
    Event ID:      9646
    Task Category: General
    Level:         Error
    Keywords:      Classic
    User:          N/A
    Computer:      XXXXX
    Description:
    Mapi session "/o=XXXX/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Recipients/cn=GU MIG" exceeded the maximum of 16 objects of type "session".
    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="MSExchangeIS" />
        <EventID Qualifiers="49158">9646</EventID>
        <Level>2</Level>
        <Task>6</Task>
        <Keywords>0x80000000000000</Keywords>
        <TimeCreated SystemTime="2010-01-18T13:54:22.000000000Z" />
        <EventRecordID>370761</EventRecordID>
        <Channel>Application</Channel>
        <Computer>XXXXX</Computer>
        <Security />
      </System>
      <EventData>
        <Data>/o=XXXX/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Recipients/cn=GU MIG</Data>
        <Data>16</Data>
        <Data>session</Data>
        <Binary>080000005B444941475F4354585D000016000000FF381500000000000002080000003A67F01FFE000000</Binary>
      </EventData>
    </Event>

    Monday, January 18, 2010 2:41 PM

All replies

  • Hi Carl,

    Create

    store.exe.config file in folder C:\Program Files\Microsoft\Exchange Server\V14\Bin

    with content

    <?xml version="1.0" encoding="utf-8" ?>
    <configuration>
        <runtime>
            <gcServer enabled="true" />
            <generatePublisherEvidence enabled="false"/>
        </runtime>
        <appSettings>
            <!-- Specifies the maximum number of sessions permitted per user. -->
            <add key="MaxSessionsPerUser" value="5000" />
        </appSettings>
    </configuration>

    Restart MSexchangeIS service and try

    Best regards,

    Vitaliy
    Monday, January 18, 2010 8:32 PM
  • Tried to create the config file but it did not work..... Even tried to do a complete reboot but with no luck. Also tried to lower the value to 32 but still the error says 16.....
    Wednesday, January 20, 2010 10:01 AM
  • Did you get this to work???
    Wednesday, January 20, 2010 10:02 AM
  • Before make it on my exchange I got error with 32 objects.

    After make it I can now make changes for few hundred public folders in one command (Add-PublicFolderClientPermission)

    Rollup 1 has installed on my server.

    try to add in microsoft.exchange.addressbook.service.exe.config

      <!-- Specifies the maximum number of sessions permitted per user. -->
            <add key="MaxSessionsPerUser" value="5000" />

    I have only changes in those files.

    The 2003/2007 reg keys for highering the values with the MaxObjsPerMapiSession keys and the Maximum Allowed Sessions Per User key  not help me too.
    Wednesday, January 20, 2010 3:29 PM
  • it can't be that value in the addressbook.service.exe.config as that value is currently set to 50 and we get warnings at 16....

    Wednesday, January 20, 2010 3:51 PM
  • <!-- Specifies the maximum number of sessions permitted per user. -->
            <add key="MaxSessionsPerUser" value="50" />
        </appSettings>
    Wednesday, January 20, 2010 3:52 PM
  • Check file "C:\Program Files\Microsoft\Exchange Server\V14\ClientAccess\PopImap\Microsoft.Exchange.Imap4.exe.config"
    Wednesday, January 20, 2010 8:03 PM
  • Hi All,

     

    For me, it was the solution to create these registry keys:

    HKLM\SYSTEM\Current Control Session\Services\MSExchangeIS\ParameterSystem\MaxObjsPerMAPISession

    ObjtFolder, ObjtMessage, ObjtFolderview, both are DWORD, and I set it to at least 700, then restart the Information store service. Then the Event ID 9646 error messages disappeared.

     

    Best,

     

    Tamas

    Thursday, August 12, 2010 2:01 PM
  • Try http://support.microsoft.com/kb/980049/en-us

    1. On the server that is running the Exchange Server 2010 Mailbox role, click Start, click Run, type regedit, and then click OK.
    2. Locate and then click the following key in the registry:
      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem
    3. On the Edit menu, point to New, and then click DWORD Value.
    4. Type Maximum Allowed Service Sessions Per User, and then press ENTER.
    5. On the Edit menu, click Modify.
    6. Type the decimal value that specifies the number of sessions that you want to use, and then click OK.
    7. Exit Registry Editor.

    After you do this, reboot the Information Store Service

    • Proposed as answer by AlanByrneIT Monday, August 20, 2012 8:26 AM
    Wednesday, December 07, 2011 8:53 AM
  • Hi All,

    After i Add the registry key and restart the server. I still got the following error.

    Mapi session "2d5019a7-c6b7-47b4-b9f7-212a4cabf8f4: /o=First Organization/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Recipients/cn=073604" exceeded the maximum of 16 objects of type "session".

    Any idea?

    many thanks.

    Jason

    Monday, December 03, 2012 3:06 AM
  • Hi All,

    I am getting the same kind of logs in my  all servers (Runnin with HCM Role) so i though to implement the solution suggested as "Registery DWORD Creation" but I stoped becasue of Jason's Comments above :(

    If same issue come after making che registery changes than no meaning of the Change...

    Please suggest if any other solution?

    We have USers who has mapped up to 20 Calendar or multiple mailboxes in their Outlook profile so is it a cause of such error.Events?

    Thanks,

    Kanta Prasad

    Tuesday, February 04, 2014 7:39 AM