none
Outlook 2003/2007 cannot see attachments, but OWA can

    Question

  • Hi i have a strange problem. There are some emails from a particular vendor, which contains PDF attachments. When it arrives in Outlook inbox, there is no paper clip icon, but from the size we can see there is something. If we use OWA to view the message we can see an attachment. If we forward to external web emails like hotmail, yahoo, the attachments are there.

    I have tried to Save Attachments, Forward, but i still do not see the emails.

    Any help is greatly appreciated.
    Tuesday, September 16, 2008 8:35 AM

Answers

  • Hi i found a workaround for this problem. It seems Outlook cannot show the attachment because the header was badly formed. I used a transport rule to intercept the message and update the message header to content-type multipart/mixed. It was previously multipart/related

     

    Thanks for the reply.

    Friday, September 19, 2008 8:05 AM
  • Hi,

     

    Thanks for your response and information.

     

    I think that the root of the problem in this case is with malformed MIME. The content type of the email is not correct; it is multipart/related, and should be multipart/mixed.

     

    RFC 2387 describes the intended use of multipart/related:

     

    http://www.ietf.org/rfc/rfc2387.txt

     

    "The Multipart/Related media type is intended for compound objects consisting of several inter-related body parts. For a Multipart/Related object, proper display cannot be achieved by individually displaying the constituent body parts."


    In this scenario, the recipient is expected to view the attachments individually, so multipart/mixed should be used instead.


    Exchange handles multipart/related specially - i.e. it considers all attachment parts inside multipart/related as “inline”. Such attachments are normally hidden from the attachment list and supposed to be accessible from the body itself, like inline images. Some clients, like OWA, can determine whether attachments are really “inline” by analyzing a message body - if they don’t find any reference to such attachment in a body they fix it by displaying it in attachment list. Other clients like Outlook will trust how attachments are marked by Exchange and hide them.

    A “correct” way to structure message would look like this:


    Multipart/mixed
    Multipart/related
    Text/html - message body
    Any inline attachments referenced from the body
    Any normal attachments, like application/msword

    Normal attachments should appear outside of multipart/related.

     

    Mike

     

    Monday, September 22, 2008 2:39 AM

All replies

  • Hi,

     

    Several questions:

     

    1.      Whether only the message from the particular vendor and with PDF attachments encountered the problem? Whether the issue also occurs if received other attachments from the same sender.

    2.      Please let me know your Exchange and Outlook build version.

    3.      Whether all the users encountered the problem or only on some users/computers? Whether the issue can always be reproduced?

    4.      When did the issue start to occur?

     

    Please also help me gather the following information:

     

    On a problem client, please add following registry key:

     

    HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Outlook\Options\Mail

     

    Note: For Outlook 2003, this will be 11.0


    Value name: SaveAllMIMENotJustHeaders
    Value type: REG_DWORD
    Value data: 1

     

    After that, please restart the Outlook and have the particular vendor send a message with PDF attachment to you. Then, please post Message Header here.

     

    Mike

     

    Thursday, September 18, 2008 12:24 PM
  • Hi i found a workaround for this problem. It seems Outlook cannot show the attachment because the header was badly formed. I used a transport rule to intercept the message and update the message header to content-type multipart/mixed. It was previously multipart/related

     

    Thanks for the reply.

    Friday, September 19, 2008 8:05 AM
  • Hi,

     

    Thanks for your response and information.

     

    I think that the root of the problem in this case is with malformed MIME. The content type of the email is not correct; it is multipart/related, and should be multipart/mixed.

     

    RFC 2387 describes the intended use of multipart/related:

     

    http://www.ietf.org/rfc/rfc2387.txt

     

    "The Multipart/Related media type is intended for compound objects consisting of several inter-related body parts. For a Multipart/Related object, proper display cannot be achieved by individually displaying the constituent body parts."


    In this scenario, the recipient is expected to view the attachments individually, so multipart/mixed should be used instead.


    Exchange handles multipart/related specially - i.e. it considers all attachment parts inside multipart/related as “inline”. Such attachments are normally hidden from the attachment list and supposed to be accessible from the body itself, like inline images. Some clients, like OWA, can determine whether attachments are really “inline” by analyzing a message body - if they don’t find any reference to such attachment in a body they fix it by displaying it in attachment list. Other clients like Outlook will trust how attachments are marked by Exchange and hide them.

    A “correct” way to structure message would look like this:


    Multipart/mixed
    Multipart/related
    Text/html - message body
    Any inline attachments referenced from the body
    Any normal attachments, like application/msword

    Normal attachments should appear outside of multipart/related.

     

    Mike

     

    Monday, September 22, 2008 2:39 AM
  • Hi,

    I think I Have the same problem here, I tried using the transport rule to change the header, but it made the email being sent as an attachment like AT000001 without any file type, I can open the attachment if I saved it to Hard Drive and rename it to eml, but that's not really usable, can anyone elaborate more on what rule to use ?

    I'm current using the "When Message Header Contains text patterns" and then "Set  Header with Value" as the action.
    Saturday, January 17, 2009 4:12 AM
  • Anyone ? 
    Monday, February 16, 2009 2:24 AM
  • Hi,

    I've got exactly this issue.  I currently have Exchange 2007 SP1 rollup 7 and I can't receive attachments in outlook 2003 or 2007 where the message body is in multipart/related content type.

    The paperclip icon doesn't show in outlook but if you look at the size of the email you can guess it's got attachments.  Also the files are accessible in OWA but the email still doesn't show an attachment.  If you open the email in OWA you can then see the attachments listed.

    Does anyone know the configuration for the transport rule to change the headers during delivery and hence allow the attachments to be seen in Outlook ?  Or does anyone know if this problem will be fixed in future rollups.  I thought rollup 6 would fix the problem but installing that and rollup 7 hasn't fixed it.

    Thanks,

    Chris 
    • Proposed as answer by Tamir Fahima Thursday, December 24, 2009 9:01 AM
    Wednesday, May 13, 2009 10:02 AM
  • someone have a solution for that?

    Thursday, December 24, 2009 9:01 AM
  • Hi,

          Even i tried creating a HT rule, but the rule does not seems to work as the Content-Type:Multipart/Related is not getting converted to Multipart/mixed. I checked through pipeline tracing as well. The rule is skipped. How do i go ahead?

    Thanks
    Suhas
    Monday, January 25, 2010 8:02 AM
  • Has anyone come up with an answer for this? I am running into the same issue with outlook 2010. We have a few people trying to send MMS messages to there email with photos and outlook will not display the images. This only appears to be an issue with AT&T phones.
    Monday, January 17, 2011 11:43 PM
  • I have the same problem too with exchange 2010 and outlook 2003. And the rule didn't help indeed. There is no consistency in it. Most attachments arrive. But some don't. In OWA they are visible. When I look at the email properties it shows the attachments and when I forward that mail to myself I can see the attachments like there are no problems. It's also with random extentions. PDF, DOC, Ppt, it doesn't matter.

    Someone has a concrete solution?

    Tuesday, March 01, 2011 12:50 PM
  • Hi

     

    Just to add really, we are also having this problem from one sender who uses outlook 2007 (we use outlook 2003 and exchange 2010)

    Exactly the same for us, the email size indicates an attachment, not visable in our outlook 2003's but is visable in OWA, so i can get round it but need it fixed really.

     

    Any one any ideas?


    Thursday, March 24, 2011 3:20 PM
  • Hi all,

    We have been troubleshooting this for some time with out Exchange 2010 environment using Outlook 2003 and 2010. Today we managed to fix it once and for all. If you want to try this fix please ensure you make a backup of the config file before changing.

    On the HUB servers browse to the your Exchange installation location e.g. C:\Program Files\Microsoft\Exchange Server\V14\Bin

    Edit file EdgeTransport.exe.config using notepad

    At the end of the 'add key' list add:     <add key="TreatInlineDispositionAsAttachment" value="true" />

    Save the file

    Restart the 'Microsoft Exchange Transport' service

    Repeat the above steps for all HUB servers in your environment

    Issue resolved.

    • Proposed as answer by Bazrah99 Thursday, April 14, 2011 11:21 AM
    Thursday, April 14, 2011 11:14 AM
  • For Exchange 2007 SP2 or later:

    1. Make sure that Exchange Server 2007 Service Pack 2 is installed.
    2. Run the following command:
      set-OrganizationConfig -ShowInlineAttachments:$true
    3. run this command on all Edge and Hub servers so you don't have to wait for replication.

     

    • Proposed as answer by MG-Rover fan Wednesday, July 13, 2011 11:45 AM
    Friday, April 15, 2011 1:52 PM
  • thanks for the suggestion exadmin818 but when i tried set-OrganizationConfig -ShowInlineAttachments:$true i received a warning stating:

    WARNING: Rus failed to stamp on some properties for the Microsoft Exchange Recipient object. Reported error: "The Exchange server address list service failed to respond. This could be because of an address list or email address policy configuration error.". Please fix the problem and run Set-OrganizationConfig task again.

    any suggestions?

    Wednesday, June 08, 2011 6:58 PM
  • It does work, but probably your service Microsoft Exchange System Attendent has stopped. When you start it, the command should complete succesfully :-)

     

    • Proposed as answer by MG-Rover fan Wednesday, July 13, 2011 11:45 AM
    Wednesday, July 13, 2011 11:33 AM
  • Hi Kuay5,

     

    I had the same problem and this had me dancing for a good two days. Here is what I did:

     

     

    Exchange Server 2010

    1. Stop the Exchange Transport service.
    2. Locate the EdgeTransport.exe.config file. This file is located in the following path: 
      <Drive where Exchange is installed> :\Program Files\Microsoft\Exchange Server\Bin\
    3. In the EdgeTransport.exe.config file, add the following entry between the <appSettings> element and the </appSettings> element:
      <add key="TreatInlineDispositionAsAttachment" value="true" />
    4. Restart the Transport service.
    Notes
    • If the TreatInlineDispositionAsAttachment option does not exist or if the option is set to "false," the behavior is the same as the behavior that is mentioned in the "Symptoms" section.
    • If the TreatInlineDispositionAsAttachment option is set to "true," the inline attachment that is not referenced is available for download.

    Exchange Server 2007

    1. Make sure that Exchange Server 2007 Service Pack 2 is installed.
    2. Run the following command:
      set-OrganizationConfig -ShowInlineAttachments:$true
    Reference: http://support.microsoft.com/kb/954684

     

     

     


    Thursday, December 15, 2011 3:10 PM
  • Hi Mike,

    i have same issue and tired with HT rule as well. but when i create a HT rule that particular user issue was fine and he can receive attachments, but after i applied HT rule all the users can’t see the body or attachments which are receive from internal users. Please help me on this.

     

    Thank you.

    Thursday, January 26, 2012 5:06 AM
  • Hi,

    I am facing same problem but what a resolution, is it possible to change content type from exchange 2010

    regards,

    Pradip

    Tuesday, May 21, 2013 6:42 AM