none
Exchange 2010 SP2 Database filling up RRS feed

  • Question

  • Hello,

    Currently i have two databases on an exchange server. One that hosts most mailboxes and another that only has about 20 users on it. The drive that hosts the smaller user count is filling up. It does not host any logs or anything else other than just the database. The total mailbox size of all the users is only about 40 GB but the database is almost 117 GB! I have an online archive folder that points to another drive, and circular logging is turned on even though it is on a different drive. I run maintenance at 1am and the 24/7 maintenance is turned on as well...what else could be taking up almost 60GB?!

    Monday, August 13, 2012 3:55 PM

Answers

All replies

  • Scenario 1

    • You deploy a mailbox database store or a public folder database store in a Microsoft Exchange Server 2010 environment.
    • You enable journaling in the Exchange organization.
    • You create a journaling mailbox.
    • You set the deleted item retention period to one day.


    Scenario 2

    • You deploy a mailbox database store in an Exchange Server 2010 environment.
    • You use archival software to delete email messages from the mailboxes.

    http://support.microsoft.com/kb/2621266

    If this is not the Case

    Upgrade to Sp2 RU3


    Satheshwaran Manoharan | Exchange 2003/2007/2010 | Blog:http://www.careexchange.in | Please mark it as an answer if it really helps you

    Monday, August 13, 2012 4:03 PM
  • This is completely a white space which is occupying more space in the database.

    1. Calculate the white space in the database

    2. You can defrag the database or use the Move-Mailbox cmdlet, or the Move Mailbox management shell facility to move ALL the mailboxes from the original oversized database to the new database.

    3. Create a new database and move all those users in the old database to newly created database.

    4. Remove the oversized database and associated logs. Rename the newly created database with the old database name, restart the Microsoft System Attendant to ensure the system mailboxes get recreated.

    The above procedure will ensure the database without white space.


    Never giveup till you get what to want.

    Monday, August 13, 2012 4:27 PM
  • This is completely a white space which is occupying more space in the database.

    1. Calculate the white space in the database

    2. You can defrag the database or use the Move-Mailbox cmdlet, or the Move Mailbox management shell facility to move ALL the mailboxes from the original oversized database to the new database.

    3. Create a new database and move all those users in the old database to newly created database.

    4. Remove the oversized database and associated logs. Rename the newly created database with the old database name, restart the Microsoft System Attendant to ensure the system mailboxes get recreated.

    The above procedure will ensure the database without white space.


    Never giveup till you get what to want.

    Hey Ranji--

    We should not do Defrag on Exchange 2010 Sp1 or later Databases

    thank you

    ==

    To find whitespace

    Get-MailboxDatabase -Status | Select-Object Server,Name,AvailableNewMailboxSpace


    Satheshwaran Manoharan | Exchange 2003/2007/2010 | Blog:http://www.careexchange.in | Please mark it as an answer if it really helps you

    Monday, August 13, 2012 5:52 PM
  • Hi Zindel

    check this link 

    http://blogs.technet.com/b/exchange/archive/2012/06/01/holy-cow-changes-to-recoverable-items-versioning-in-exchange-2010-sp2-ru3.aspx

    maybe you have problem with recoverable items versioning

    also check database for disabled or soft-deleted mailboxes like in this post:

    Deleted disconnected mailboxes

    Exchange 2010 reduce mailbox database size

     

     You can also check what is summary size of recoverable items for all mailboxes in this database, what size is for whitespace (Available new mailbox space).

     

    Regards

    Remigiusz

    ExchangeBlog



    • Edited by Remigiusz_Sz Monday, August 13, 2012 7:02 PM
    • Proposed as answer by wendy_liu Wednesday, August 15, 2012 8:40 AM
    • Marked as answer by wendy_liu Tuesday, August 21, 2012 3:32 AM
    Monday, August 13, 2012 6:59 PM