none
Exchaneg 2010 SP1 Possible Bug, Cannot create move to archive retention tag on inbox, but can create a new one and edit and assign inbox to it RRS feed

  • Question

  • Hi,

    I am playing with Exchange 2010 SP1 Beta, I can see a strange issue with the retention tags, to re-produce it follow the steps:

    1- Create a retention tag and select inbox as a folder, assign any date and action move to archive.

    you get the error

    Summary: 1 item(s). 0 succeeded, 1 failed.
    Elapsed time: 00:00:00


    3434
    Failed

    Error:
    Unable to execute the task, reason: MoveToArchive can only be applied to tags of type default ('All'), Personal or RecoverableItems.
    Click here for help... http://technet.microsoft.com/en-US/library/ms.exch.err.default(EXCHG.140).aspx?v=14.1.180.2&t=exchgf1&e=ms.exch.err.14844

    Exchange Management Shell command attempted:
    New-RetentionPolicyTag -Name '3434' -Type 'Inbox' -Comment '' -AgeLimitForRetention '33.00:00:00' -RetentionAction 'MoveToArchive' -RetentionEnabled $true

    Elapsed Time: 00:00:00

    now try this:

    2_ create another policy that deletes the items, assign it to inbox.

    3- now go edit the action and change it to move to archive, it completes with now errors

    what I can see that there is a bug with the EMC and creating a new retention tag, I think that I should have the ability to create a renetion tag to inbox, personal folder or any folder, so why it gives the error.

    Windows 2008 R2 and Exhcange 2010 SP1 Beta


    Regards, Mahmoud Magdy Watch Arabic Level 300 Videos about Exchange 2010 here: http://vimeo.com/user3271816 Read pretty advanced Exchange stuff I and other MVPs post here: http://www.enowconsulting.com/ese/blog.asp Or follow my blog: http://busbar.blogspot.com or our corp blog: http://ingazat.wordpress.com and if you Liked my post please mark it as helpful and accept it as an asnwer
    Thursday, June 10, 2010 6:29 AM

All replies

  • Hi Busbar,

    The Move To Archive action is only supported for Default Policy Tag  (Type = 'All') or Personal Tags. The former apply to entire mailbox. The latter can be used by Outlook 2010/OWA users to tag individual folders or items.

    You can't create Retention Policy Tags (RPTs - for default folders such as Inbox and Deleted Items) with the Move to Archive action.

    Thanks for reporting this issue - we're investigating it.

     


    Bharat Suneja
    Microsoft Corporation
    blog: Exchangepedia.com
    This posting is provided "AS IS" with no warranties, and confers no rights. Please do not send email directly to this alias. This alias is for newsgroup purposes only.
    ----------------------------

    Saturday, July 10, 2010 2:15 AM
    Moderator
  • Hi there,

    I'm running into the issue stated by Busbar on Exchange 2010 RTM (NOT the beta SP1), and I can confirm that creating the tag with another action such as "MarkAsPastRetentionLimit" and then changing it to "MoveToArchive" works, which is inconsistent.

    The documentation is pretty unclear - what is the expected behavior? Like Busbar I think this should be allowed on default folders, but maybe there's something I'm not seeing. Either way there's inconsistency between the new and set cmdlets.

    Also, in Exchange 2010 RTM I can report that I cannot create a Default Policy Tag (Type = 'All) with a retention action of of MoveToArchive if I also try to set it to "IsPrimary $true", it errors out as well on either a New-RetentionPolicyTag or a Set-RetentionPolicyTag.

    Can we get some clarity in the docs on what exactly should be expected and how this is supposed to work? Would also be nice to get some info around Default Policy Tags and if they apply to the Archive Mailbox of an account - it seems they do but I can't find any documentation stating how this is supposed to work.


    Thanks,

    Rick Reuling

     

    Thursday, August 5, 2010 9:18 PM
  • MY Execs REALLY want to know if it will be possible in SP1 to setup Policy tags on default folders like Notes and Tasks to NEVER archive or delete.  PSS says its not possible with RTM U4 code so wondering if this will be fixed in SP1.

    Thursday, August 19, 2010 6:20 PM
  • Because this RPT applies to both the regular mailbox and the archive mailbox they are causing the ManagedFolderAssistant to make copies of emails from the online archive, to the online archive that already exist and thus causing the database bloat.

    http://social.technet.microsoft.com/Forums/en-US/exchange2010/thread/768a473e-389a-49ba-a855-d435dfce076c


    MCSE:M 2003, MCITP:EA, SA, EMA, EMA:2010

    Monday, April 23, 2012 7:57 AM