none
Exchange Auto Mapping

    Question

  • We run Exchange 2010 SP3 on prem (with Outlook 2010 and 2013), we have started experiencing auto mapping problems since we applied Rollup 6. It is affecting an increasing number of clients as well.

    The main issue is that some users who had previous access to Shared Mailboxes working just fine have now "lost" access to the shared account folders. Outlook simply displays the client's personal folder structure instead of the folders belonging to the Shared mailbox. Properties of the Shared account Inbox actually point to the person's email address, not the shared mailbox one.

    All attempts at remedying the situation failed, including recreating the profile, setting up on a new computer, cache vs non-cache mode. Even giving access to the Sahred mailbox to a new user will result with the same problem. The auto mapping attributes (msExchDelegateListLink and msExchDelegateListBL) check out fine as well. At a loss with this one. Note that the shared accounts are fine, accessing them via OWA for instance works just fine.

    Finally, I noticed that auto mapping for our Outlook 2013 clients has stopped working altogether. Can this be related?

    Help!


    • Edited by jdduff99 Tuesday, June 17, 2014 5:53 PM
    Tuesday, June 17, 2014 5:53 PM

All replies

  • Hi,

    I suggest we can remove all users who have full access permission to this shared mailbox in EMC:

    Right-click Shared mailbox > Manage Full  Access permission, and remove all added users.

    Please make sure the msExchDelegateListLink value for this shared mailbox in ADUC is <not set> and the shared mailbox is removed from all users’ Outlook clients.

    Now, we can try to give the full access permission back to these users by using the following command:

    Add-MailboxPermission -Identity SharedMailbox -User UserA -AccessRights:FullAccess -AutoMapping $True

    Then check whether all users are listed in the msExchDelegateListLink value and the shared mailbox is auto-mapped to all added users.

    Thanks,


    Winnie Liang
    TechNet Community Support

    Wednesday, June 18, 2014 9:49 AM
    Moderator
  • Thanks fro the suggestion. I did as you suggested with the same result. When I add the permissions back, the user only sees her own folders instead of the shared mailbox's. Was worth a shot.
    Wednesday, June 18, 2014 6:43 PM
  • Any update from Microsoft on this issue? We are about to install Exchange 2010 SP3 UR6 in our environment as well, and we also have lots of users with access to shared mailboxes. 
    Thursday, June 19, 2014 3:12 PM
  • Note that the appearance of this issue may just be coincidental with the Rollup install. I haven't found any definitive link between the two events outside of the timing. I did manage to dig up an older thread (http://community.office365.com/en-us/f/148/t/169225.aspx) about the same problem for an Office 365 environment.

    Thursday, June 19, 2014 4:04 PM
  • Hi,

    Please check whether users can add additional mailbox in Account Settings > More Settings > Advanced for shared mailbox. If there is any error logs, please collect some for further troubleshooting.

    Thanks,


    Winnie Liang
    TechNet Community Support

    Friday, June 20, 2014 8:07 AM
    Moderator
  • Yes, users are able to add other mailboxes that way. You can even add the mailbox in question (the one that shows the users' folders) and it will work! The Mailbox shows twice in the Navigation pane, one of them displays the user's folders and the other displays the correct mailbox folder structure. Weird.
    Thursday, June 26, 2014 5:16 PM
  • I just installed Exchange 2010 SP3, Rollup 6 yesterday and I know have this exact same issue. Did you ever find a fix? (other than manually adding the mailbox and having it appears twice) Have you discussed it with Microsoft? Users that have "full access" to shared mailboxes can no longer expand the shared mailbox in their Outlook client.
    Thursday, July 31, 2014 7:19 PM
  • No, the issue still exists and although we have not contacted MS directly, some other posts by MS Techies only suggest the workaround. Someone else suggested that re-creating the shared mailbox fixed the issue but that is drastic.
    Tuesday, August 26, 2014 4:01 PM
  • FYI, we found that we were missing Service Pack 2 on our Outlook clients that were having the issue. Installing SP 2 appears to have resolved it.
    Tuesday, August 26, 2014 4:15 PM
  • Thanks for the suggestion. I tried installing Office 2010 SP2 on the client desktop but it didn't fix it. Did you do any additional steps?
    Wednesday, September 3, 2014 10:27 PM
  • Sorry, no. In our case just installing the service pack resolved the issue.
    Thursday, September 4, 2014 11:20 AM