locked
Warning 1040- ActiveSync and Direct Push technology RRS feed

  • Question

  • Is it possible to find out which mobile device is creating this error?  I have followed the help in previous postings and I am still receiving these.  My director would like to know if I can pin it down as to who is creating these.

    Event Type: Warning
    Event Source: MSExchange ActiveSync
    Event Category: Requests
    Event ID: 1040
    Date:  3/10/2010
    Time:  12:54:22 PM
    The average of the most recent [513] heartbeat intervals used by clients is less than or equal to [540].
    Make sure that your firewall configuration is set to work correctly with Exchange ActiveSync and Direct Push technology. Specifically, make sure that your firewall is configured so that requests to Exchange ActiveSync do not expire before they have the opportunity to be processed.

    Win2k3 Server/Ex2k7 Server/Mobile6/MotorolaQ, Droid/OWA/Outlook2k3 & 2k7
    Wednesday, March 10, 2010 9:57 PM

All replies

  • Hi Penny,

     

    Based on my research, the warning may not mean a ActiveSync problem on the Server. For this alarm, it just indicate that average of the most recent [513 second] heartbeat intervals used by clients is less than or equal to 9 minutes[540 seconds].  As we could see it’s an average value used by clients, so it’s not triggered by a specific user.

     

    This issue may occur if the firewall has not been configured to let HTTP(S) requests live longer than the minimum heartbeat interval that is configured on the server. By default, the minimum heartbeat interval at which the Exchange server triggers this event is 9 minutes. For instance, if the HTTP(S) connections time is not configured as longer than 9 minutes on your firewall, Once a ActiveSync http request is timeout, Mobile client will sent another Http request which may server connection overload. Therefore Exchange set a trigger value (9 minutes) to ask you to check if the firewall is normal configured. However, that’s not means that there is a problem on the ActiveSync. I appreciate your understanding to this warning. For more details, please check the article: http://support.microsoft.com/kb/905013

     

    If ActiveSync is working properly and you just don’t want the application log to be generated on the server, please Set MinHeartbeatInterval and MaxHeartbeatInterval key to a value of 0. Here are the steps:

     

    Open Registry on the Exchange server, and locate to the registry key:

     

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MasSync\Parameters

     

    Please set the values (MinHeartbeatInterval and MaxHeartbeatInterval) to zero.

     

    After doing the change, Restart IIS admin service.

     

    Hope this helps. Thanks,

     

    Elvis

    Tuesday, March 16, 2010 3:08 AM
  • Hi Penny,

     

    How things are going? Any update on the issue? If so, please let me know.

    Monday, March 22, 2010 3:16 AM
  • I am having the same event log notices on Windows 2008 SBS. My firewall is set for a 15 minute timeout on tcp connections. My users don't seem to have a problem with ActiveSync on their iPhones so I was going to do the registry change you suggested previously. However, I don't have the MasSync hive. So, should I modify the web.config file as suggested in KB905013 but set the parameters to "0" instead of the "60" and "3540"?

    Release version of Exchange 2007

    1. In Notepad, open the Sync web.config file on the Client Access Server. By default, that location is under \Program Files\Microsoft\Exchange Server\ClientAccess\Sync.
    2. Search for and modify the following values as needed:
      <add key="MinHeartbeatInterval" value="60"></add> <add key="MaxHeartbeatInterval" value="3540"></add>

    How shall I proceed as I want to eliminate this "noise" from my event logs...

    Wednesday, May 5, 2010 5:49 PM
  • Elvis, if we want to solve the problem I need to address the issue with my firewall settings?
    Thursday, May 27, 2010 7:43 PM
  • Hello guys,

    The MSExchange ActiveSync 1040 warning is been shown repeatedly with interval 15 min, along with it MSExchange RPC Over HTTP Autoconfig error event id 2007. am facing problems in configuring Active sync for windows mobile and mail for exchange for mobile users. I checked the ISA server timeout values and its been set to normal.

    Did anyone get the solution for this issue.

    sreejith

    Thanks in advance 

     

     

     

     

    Friday, May 28, 2010 11:38 AM
  • Unfortunately, I haven't got this error fixed yet (only because it wasn't debilitating to our system I had to move to a different fire).  

    I did just look at the registry setting that Elvis recommended and like BobalooBrew I don't have the \MasSync hive either.  Not sure how to add it either???

    Tuesday, June 1, 2010 4:34 PM
  • Did anyone raised this issue to microsoft.

    Thursday, June 3, 2010 5:52 AM
  • Hello,

    I'm also encoutring this alert message on the event log.

    It is logged sometimes around 30 times a day !

    I read the kb http://support.microsoft.com/kb/905013 instructions but I don't have the MasSync hive on the firewall ISA server.

    Can anyone give feedback on this KB before I proceed with registry modifications ?


    MCTS Windows Server Virtualization, Configuration
    Friday, June 4, 2010 4:21 PM
  • I haven't yet.  I was hoping to find a resolution here so I didn't have to pay MS.
    Monday, June 7, 2010 4:10 PM
  • Is there a resolution yet?
    Wednesday, August 18, 2010 8:22 AM
  • Hi all,

    I'm also getting this on my EX2010 CAS Server (SP1)... no end users are informing us of issues, so it may be informational, or just a config required on the server end...?

    Did anyone get a solution/workaround for these logs?

    Monday, January 17, 2011 10:56 PM
  • Late response but what the hell some one may use it ;)You need  to change Mini and MaxHeartbeatInterval on your Exchange 2007/2010 server to "0"

      • In Notepad, open the Sync web.config file on the Client Access Server. By default, that location is under \Program Files\Microsoft\Exchange Server\ClientAccess\Sync.
      • Search for and modify the following values as needed:
        <add key="MinHeartbeatInterval" value="60"></add> <add key="MaxHeartbeatInterval" value="3540"></add>

    cheer's Enjoy

    Friday, September 7, 2012 7:22 AM
  • Hi Penny,

     

    Based on my research, the warning may not mean a ActiveSync problem on the Server. For this alarm, it just indicate that average of the most recent [513 second] heartbeat intervals used by clients is less than or equal to 9 minutes[540 seconds].  As we could see it’s an average value used by clients, so it’s not triggered by a specific user.

     

    This issue may occur if the firewall has not been configured to let HTTP(S) requests live longer than the minimum heartbeat interval that is configured on the server. By default, the minimum heartbeat interval at which the Exchange server triggers this event is 9 minutes. For instance, if the HTTP(S) connections time is not configured as longer than 9 minutes on your firewall, Once a ActiveSync http request is timeout, Mobile client will sent another Http request which may server connection overload. Therefore Exchange set a trigger value (9 minutes) to ask you to check if the firewall is normal configured. However, that’s not means that there is a problem on the ActiveSync. I appreciate your understanding to this warning. For more details, please check the article: http://support.microsoft.com/kb/905013

     

    If ActiveSync is working properly and you just don’t want the application log to be generated on the server, please Set MinHeartbeatInterval and MaxHeartbeatInterval key to a value of 0. Here are the steps:

     

    Open Registry on the Exchange server, and locate to the registry key:

     

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MasSync\Parameters

     

    Please set the values (MinHeartbeatInterval and MaxHeartbeatInterval) to zero.

     

    After doing the change, Restart IIS admin service.

     

    Hope this helps. Thanks,

     

    Elvis

    Elvis but when you tell about firewall it doesn't mean ISA configuration,right?
    Monday, May 20, 2013 3:34 PM
  • Nothing to do I've verify with Networks colleague and the settings on the firewall is more then 9 minutes.
    Friday, May 31, 2013 3:11 PM