none
The WinRM client received an HTTP server error status (500)

    Question

  • Hi All,

    I have installed the Exchange 2010 Management Tools and a few roles on our DC (Windows Server 2008 R2) but i cannot even connect to it to configure anything.

    If i use the management tools GUI i get an error message saying:
    "Connecting to remote server failied with the following error message: The WinRM client received an HTTP server error status (500), but the remove service did not include any other informaition about the cause of the failure. For more information, see the about_Remote_Troubleshooting Help topic. It was running the command 'Discover-ExchangeServer -UseWIA $true -SuppressError $true'."

    Using the Exchange Management Shell is get a similar error:
    "Connecting to remote server failied with the following error message: The WinRM client received an HTTP server error status (500), but the remove service did not include any other informaition about the cause of the failure. For more information, see the about_Remote_Troubleshooting Help topic.
    + CategoryInfo : OpenError: (System.Manageme....RemoteRunspace:RemoteRunspace) [], PSRemotingTransportException
    + FullyQualifiedErrorId: PSSessionOpenFailed"

    This comes up 3 times and then said it failed to connect and to enter the Server FQDN i want to connect to.

    I have seen other posts where they have said to disable anonymous access for PowerShell in IIS which i have done and to also run the set-user yourusername -remotepowershellenabled:$true which i cannot run because i cannot even connect into it via PowerShell.

    Tried to see if there was a way to reinstall the management tools because i have a feeling they didnt install properly but cant find a way to do that.

    Tried to uninstall everything but i cannot because it says there are already mailboxes created (presume some default ones) but i cannot connect to remove them to uninstall.

    I seem to have reached a wall and cannot see how to proceed.

    Please help. Thanks.
    Monday, December 14, 2009 12:30 AM

Answers

  • Hi All,

    I ended up having to denote the server back to a member server then recover it from a very old backup and go through the whole process of promoting it to a DC again. Once i did all that and got it back to how it was prior to the exchange install i ran setup with the recoverserver switch (setup /m:RecoverServer) as all the AD changes where still in place and setup would not run normally.

    Once the recover finished i had all the roles and management tools installed again and i was able to connect. 
    • Marked as answer by Rodney Almeida Tuesday, January 12, 2010 1:07 AM
    Tuesday, January 12, 2010 1:07 AM

All replies

  • Hi Pirry,

    Check out in Server Manager if "WinRM IIS Extensions" are installed. If not install it. If its already there :

    1. Uninstall it and Install it again.

    2. Run "WinRM Quickconfig".

     

    • Proposed as answer by Nair.SS Wednesday, January 13, 2010 2:49 PM
    Monday, December 14, 2009 5:28 AM
  • Hi Nair.SS

    Thanks for your reply. I did see another post to install that which i had done already. I ran the WinRM Quickconfig and it did make some changes so now;
    WinRM already is set up to receive requests on this machine.
    WinRM already is set up for remote management on this machine.

    I rebooted and tried again but still nothing :(

    Same error messages.
    • Proposed as answer by CNIT Monday, December 15, 2014 12:15 AM
    Monday, December 14, 2009 11:59 PM
  • Have you tried loading EMS via Admin Tools > Windows Powershell Modules? Amazingly, that will probably work fine for you.
    Assuming that loads, or that you can run EMS on another machine:
    • Check Powershell directory in IIS on the problem server. Make sure SSL is not required. Allow only Anonymous access - no basic/IWA auth etc.
    • If you can get into Windows Powershell Modules, run the set-user command suggested above from there.
    • Remove-powershellvirtualdirectory, and then New-powershellvirtualdirectory (either remotely or using Windows Powershell Modules.
    • Re-check SSL/authentication once this is done.
    -Max
    Tuesday, December 15, 2009 1:29 PM
  • The remote server actually uses port 80 to get connected. Probably you can check if any other software's installed on this server which uses that.

    Tuesday, December 15, 2009 4:06 PM
  • Have you tried loading EMS via Admin Tools > Windows Powershell Modules? Amazingly, that will probably work fine for you.
    Assuming that loads, or that you can run EMS on another machine:
    • Check Powershell directory in IIS on the problem server. Make sure SSL is not required. Allow only Anonymous access - no basic/IWA auth etc.
    • If you can get into Windows Powershell Modules, run the set-user command suggested above from there.
    • Remove-powershellvirtualdirectory, and then New-powershellvirtualdirectory (either remotely or using Windows Powershell Modules.
    • Re-check SSL/authentication once this is done.
    -Max

    Hi Max,
    Tried loading EMS via Admin Tools > Windows Powershell Modules but didnt work. Got the following error:
    Import-Module : There were errors in loading the format data file:
    Microsoft.Exchange.Management.PowerShell.Setup, C:\Program Files\Microsoft\Exchange Server\V14\bin\Exchange.format.ps1x
    ml : File skipped because it was already present from "Microsoft.Exchange.Management.PowerShell.E2010".
    At line:24 char:34
    +                     Import-Module <<<<  $_.Name -ErrorAction SilentlyContinue
        + CategoryInfo          : InvalidOperation: (:) [Import-Module], RuntimeException
        + FullyQualifiedErrorId : FormatXmlUpateException,Microsoft.PowerShell.Commands.ImportModuleCommand

    I think it is a problem with the PowerShell IIS VirtualDirectory because when i browse any other virtual directory i get a response of some sort but when i browse the PowerShell virtual directory i get the same 500 error message.
    This error (HTTP 500 Internal Server Error) means that the website you are visiting had a server problem which prevented the webpage from displaying.

    Now i think i have made things worse. I was looking at the remove and new point you made an accidently deleted the whole PowerShell virtual directory in IIS using the IIS GUI. I didnt use the Remove-powershellvirtualdirectory command. Now i dont know how to get it back :(

    When i try to run New-powershellvirtualdirectory and specify to call it PowerShell it says it is already
    New-PowerShellVirtualDirectory : The virtual directory 'PowerShell' already exists under 'DC01.mainserver/Default Web S
    ite'.
    Parameter name: VirtualDirectoryName
    At line:1 char:31
    + New-PowerShellVirtualDirectory <<<<
        + CategoryInfo          : InvalidArgument: (DC01\PowerShell (Default Web Site):ADObjectId) [New-PowerShellVirtualD
       irectory], ArgumentException
        + FullyQualifiedErrorId : 7833EE63,Microsoft.Exchange.Management.SystemConfigurationTasks.NewPowerShellVirtualDire
       ctory

    I have tried to use the remove command but it doesnt find it no matter what i put in the identify parameter. It should be "Default Web Site" right?

    Anyways, i have created a new PowerShell virtual directory called ExchPowerShell (still would like to find a way have it called PowerShell) and removed SSL and enabled only Anonymous access. Now get a different error message:

    VERBOSE: Connecting to DC01.mainserver
    [dc01.mainserver] Connecting to remote server failed with the following error message : The WinRM client sent a request
     to an HTTP server and got a response saying the requested HTTP URL was not available. This is usually returned by a HT
    TP server that does not support the WS-Management protocol. For more information, see the about_Remote_Troubleshooting
    Help topic.
        + CategoryInfo          : OpenError: (System.Manageme....RemoteRunspace:RemoteRunspace) [], PSRemotingTransportExc
       eption
        + FullyQualifiedErrorId : PSSessionOpenFailed

    Did a search and i think this is because i now had a different PowerShell virtual directory so if i try to connect and specify the new virtual directory name i get the same error i was getting.

    Failed to connect to any Exchange Server in the current site.
    Please enter the Server FQDN where you want to connect: DC01.mainserver/ExchPowerShell
    VERBOSE: Connecting to DC01.mainserver/ExchPowerShell
    [dc01.mainserver] Connecting to remote server failed with the following error message : The WinRM client received an HT
    TP server error status (500), but the remote service did not include any other information about the cause of the failu
    re. For more information, see the about_Remote_Troubleshooting Help topic.
        + CategoryInfo          : OpenError: (System.Manageme....RemoteRunspace:RemoteRunspace) [], PSRemotingTransportExc
       eption
        + FullyQualifiedErrorId : PSSessionOpenFailed

    Thank for all you help so far.
    Wednesday, December 16, 2009 12:44 AM
  • All i have on the server is DNS, DHCP, AD, IIS and AV software. I tried to disable the AV and still nothing.

    Wednesday, December 16, 2009 12:45 AM
  • try to run Winrm quickconfig
    Tamer Sherif Mahmoud
    Wednesday, December 16, 2009 11:00 PM
  • Thanks for the suggestion Tamer but if you see above Nair.SS had already adviced to try that which i did but still nothing.
    Thursday, December 17, 2009 2:32 AM
  • My post from this thread with the same issue

    http://social.technet.microsoft.com/Forums/en-US/exchange2010/thread/8ee2bc8a-4400-4d1c-9e0d-0986e9aad007/

    So I worked with MS' escalation team today on this and his mentors and they ran through a 1.5GB time trace and my install logs. There weren't any errors that stood out other than a cert issue I was aware of. Since it was the end of their day I took things into my own hands.

    Ended up re-running the upgrade. Please not that I did get a debug error as soon as it tried to load the pre-reqs screen related to perms accessing an XML. I stopped there and did some research. Went back and got to the same point and hit continue instead of stop,etc. Ran through the 'upgrade' again and as soon as it was complete I now had access to me EMS and EMC

    Very strange through indeed
    • Proposed as answer by TrevorHughes Tuesday, January 15, 2013 8:21 PM
    Thursday, December 17, 2009 5:27 AM
  • Hi,

        I was also having this error when I was trying to run EMS but get it working by just a reboot of Ex2010 server :) .

        Regards,
        

    Laeeq Qazi|Snr Software Engineer(Exchange + Sharepoint + BES + DynamicsCRM) www.HostingController.com
    Wednesday, January 06, 2010 11:11 AM
  • Hi All,

    I ended up having to denote the server back to a member server then recover it from a very old backup and go through the whole process of promoting it to a DC again. Once i did all that and got it back to how it was prior to the exchange install i ran setup with the recoverserver switch (setup /m:RecoverServer) as all the AD changes where still in place and setup would not run normally.

    Once the recover finished i had all the roles and management tools installed again and i was able to connect. 
    • Marked as answer by Rodney Almeida Tuesday, January 12, 2010 1:07 AM
    Tuesday, January 12, 2010 1:07 AM
  • I had the same problem in my test environment. After upgrading from Win 2008 Server Standard R2 to Enterprise, the Exchange console starting throwing the "The WinRM client received an HTTP server error status (500)" error.

    My test env consists of a Windows Std R2 DC and 2x Windows Ent R2 2008 with Exch 2010 Enterprise.

    This is what fixed it;

         Server Manager -> Features -> Selected WinRM IIS Extension (found this ticked off i.e not installed)

    In my case there was no need to iisreset or run the WinRM Quickconfig command.

    I ran this successfully on the two Exchange 2010 Enterprise servers I'm using.

    Hope this helps.

    Wednesday, January 13, 2010 9:25 AM
  • After breaking my head for whole day with this error and trying all possible steps given from begining of this port. Finally i got this RESOLVED :-)
    Just Reinstall ( remove and install again)    WinRM IIS Extension in Server Manager . Exchange managment console is working fine now.
    • Proposed as answer by Steve Nuesch Sunday, January 31, 2010 6:15 PM
    Wednesday, January 13, 2010 2:30 PM
  • THANK YOU !THANK YOU !THANK YOU !THANK YOU !THANK YOU !THANK YOU !THANK YOU !THANK YOU !THANK YOU !THANK YOU !THANK YOU !THANK YOU !THANK YOU !THANK YOU !THANK YOU !THANK YOU !THANK YOU !THANK YOU !THANK YOU !

    I just upgrade last night to enterpise and created a DAG then upgraded a second server to enterprise and lost all management.

    Connecting to remote server failed with the following error message : The WinRM client received an HTTP server error status (500), but the remote service did not include any other information about the cause of the failure. For more information, see the about_Remote_Troubleshooting Help topic.    + CategoryInfo          : OpenError: (System.Manageme....RemoteRunspace:RemoteRunspace) [], PSRemotingTransportException
        + FullyQualifiedErrorId : PSSessionOpenFailed

    My WinRM IIS Extension in Server Manager was not installed some how. but I installed and I'm back in business.
    Sunday, January 31, 2010 6:17 PM
  • Hi,

    I have very similar issue. EMS comes up with "HTTP server error status (500)" error message along with the corresponding error message in the Application log:

    Log Name:      System
    Source:        Microsoft-Windows-WinRM
    Date:          11/28/2009 2:26:07 PM
    Event ID:      10113
    Task Category: None
    Level:         Warning
    Keywords:      Classic
    User:          N/A
    Computer:      ExchangeComputerName
    Description:
    Request processing failed because the WinRM service cannot load data or event source: DLL="%ExchangeInstallPath%Bin\Microsoft.Exchange.AuthorizationPlugin.dll"

     User Action
     Please check if "%ExchangeInstallPath%Bin\Microsoft.Exchange.AuthorizationPlugin.dll" exists.

     Additional Data
     Loading %ExchangeInstallPath%Bin\Microsoft.Exchange.AuthorizationPlugin.dll failed with error="126" (%%126).


    I have checked and can confirm the dll mentioned above exists. Any attempts to get it manually registered have failed.

    In addition I have tried EVERY single suggestion from this and similar posts. Still no luck.

    Has anybody seen this before? Any ideas?

    Thanks.
    Tuesday, February 02, 2010 10:53 AM
  • Hi,

    I have very similar issue. EMS comes up with "HTTP server error status (500)" error message along with the corresponding error message in the Application log:

    Log Name:      System
    Source:        Microsoft-Windows-WinRM
    Date:          11/28/2009 2:26:07 PM
    Event ID:      10113
    Task Category: None
    Level:         Warning
    Keywords:      Classic
    User:          N/A
    Computer:      ExchangeComputerName
    Description:
    Request processing failed because the WinRM service cannot load data or event source: DLL="%ExchangeInstallPath%Bin\Microsoft.Exchange.AuthorizationPlugin.dll"

     User Action
     Please check if "%ExchangeInstallPath%Bin\Microsoft.Exchange.AuthorizationPlugin.dll" exists.

     Additional Data
     Loading %ExchangeInstallPath%Bin\Microsoft.Exchange.AuthorizationPlugin.dll failed with error="126" (%%126).


    I have checked and can confirm the dll mentioned above exists. Any attempts to get it manually registered have failed.

    In addition I have tried EVERY single suggestion from this and similar posts. Still no luck.

    Has anybody seen this before? Any ideas?

    Thanks.

    Wow!  I'm in the exact same situation as posted above.  I have installed Exchange 2010 RTM on Windows 2008R2.  This server is a member server in the domain.  Exchange 2010 installed fine, but I cannot connect via EMC or EMS.  I've tried every possible solution out there, but cannot get passed the Microsoft.Exchange.AuthorizationPlugin.dll failed error.  I've been fighting with this for weeks.  There must be a simple solution.  All of the Exchange services are running.  All admin users have proper permissions, Exchange Roles, Organization Management group, etc.  Someone must have a solution for this...  PLEASE HELP!
    Thursday, February 04, 2010 2:56 AM
  • Hi,

    I have very similar issue. EMS comes up with "HTTP server error status (500)" error message along with the corresponding error message in the Application log:

    Log Name:      System
    Source:        Microsoft-Windows-WinRM
    Date:          11/28/2009 2:26:07 PM
    Event ID:      10113
    Task Category: None
    Level:         Warning
    Keywords:      Classic
    User:          N/A
    Computer:      ExchangeComputerName
    Description:
    Request processing failed because the WinRM service cannot load data or event source: DLL="%ExchangeInstallPath%Bin\Microsoft.Exchange.AuthorizationPlugin.dll"

     User Action
     Please check if "%ExchangeInstallPath%Bin\Microsoft.Exchange.AuthorizationPlugin.dll" exists.

     Additional Data
     Loading %ExchangeInstallPath%Bin\Microsoft.Exchange.AuthorizationPlugin.dll failed with error="126" (%%126).


    I have checked and can confirm the dll mentioned above exists. Any attempts to get it manually registered have failed.

    In addition I have tried EVERY single suggestion from this and similar posts. Still no luck.

    Has anybody seen this before? Any ideas?

    Thanks.

    Wow!  I'm in the exact same situation as posted above.  I have installed Exchange 2010 RTM on Windows 2008R2.  This server is a member server in the domain.  Exchange 2010 installed fine, but I cannot connect via EMC or EMS.  I've tried every possible solution out there, but cannot get passed the Microsoft.Exchange.AuthorizationPlugin.dll failed error.  I've been fighting with this for weeks.  There must be a simple solution.  All of the Exchange services are running.  All admin users have proper permissions, Exchange Roles, Organization Management group, etc.  Someone must have a solution for this...  PLEASE HELP!


    Good news! I have found a solution!

    Check if there is ExchangeInstallPath environment variable  defined in your system. For some reason this variable has not been created during Exchange installation process. I have compared with all other Exchange servers and have found this variable exists everywhere except affected machine.

    So I went to Advanced System Settings-> Environment variables and under the System Variables section add ExchangeInstallPath as Variable Name and C:\Program Files\Microsoft\Exchange Server\V14\ as Variable Value (please do not forget the trailing slash - that is important). Reboot.

    And voilà!!! Now I have EMS and EMC working perfectly.

    You can check if environment variable has been set up correctly by executing SET command from command prompt.

    Regards.
    • Proposed as answer by ZhelR Thursday, February 04, 2010 11:44 AM
    Thursday, February 04, 2010 11:43 AM
  • Hi,

    I have very similar issue. EMS comes up with "HTTP server error status (500)" error message along with the corresponding error message in the Application log:

    Log Name:      System
    Source:        Microsoft-Windows-WinRM
    Date:          11/28/2009 2:26:07 PM
    Event ID:      10113
    Task Category: None
    Level:         Warning
    Keywords:      Classic
    User:          N/A
    Computer:      ExchangeComputerName
    Description:
    Request processing failed because the WinRM service cannot load data or event source: DLL="%ExchangeInstallPath%Bin\Microsoft.Exchange.AuthorizationPlugin.dll"

     User Action
     Please check if "%ExchangeInstallPath%Bin\Microsoft.Exchange.AuthorizationPlugin.dll" exists.

     Additional Data
     Loading %ExchangeInstallPath%Bin\Microsoft.Exchange.AuthorizationPlugin.dll failed with error="126" (%%126).


    I have checked and can confirm the dll mentioned above exists. Any attempts to get it manually registered have failed.

    In addition I have tried EVERY single suggestion from this and similar posts. Still no luck.

    Has anybody seen this before? Any ideas?

    Thanks.

    Wow!  I'm in the exact same situation as posted above.  I have installed Exchange 2010 RTM on Windows 2008R2.  This server is a member server in the domain.  Exchange 2010 installed fine, but I cannot connect via EMC or EMS.  I've tried every possible solution out there, but cannot get passed the Microsoft.Exchange.AuthorizationPlugin.dll failed error.  I've been fighting with this for weeks.  There must be a simple solution.  All of the Exchange services are running.  All admin users have proper permissions, Exchange Roles, Organization Management group, etc.  Someone must have a solution for this...  PLEASE HELP!


    Good news! I have found a solution!

    Check if there is ExchangeInstallPath environment variable  defined in your system. For some reason this variable has not been created during Exchange installation process. I have compared with all other Exchange servers and have found this variable exists everywhere except affected machine.

    So I went to Advanced System Settings-> Environment variables and under the System Variables section add ExchangeInstallPath as Variable Name and C:\Program Files\Microsoft\Exchange Server\V14\ as Variable Value (please do not forget the trailing slash - that is important). Reboot.

    And voilà!!! Now I have EMS and EMC working perfectly.

    You can check if environment variable has been set up correctly by executing SET command from command prompt.

    Regards.

    I was doing the same thing trying to compare the problem 2010 server with a working one.  Certainly didn't think to look at environment variables!  Thank you so much for finding the solution for this and posting it!  Works like a charm now.  I like 2010 but it sure seems aweful fragile.    
    Thursday, February 04, 2010 3:26 PM
  • Hi

     I have solved this by,

    1. Disable anonymous authentication for powershell virtual directory on IIS 7.0
    2. Install winrm iis extenstion in ServerManager

    Clement Rosario
    Wednesday, March 03, 2010 4:11 PM
  • I am also having this wonderful issue. My nightmare started when I tried to use Windows Server 2008 to backup up the data on the Ex2010 server. The process hung during the Running Consistency Check. In addition I noticed the Windows Rollup #3 had been installed. None of my services were enabled or running. I have uninstalled the rollup and canceled any subsequent backups. I have followed all of the steps above w/ no success.

    I need more ideas.

    Thanks,

    gymmbo

    • Proposed as answer by gymmbo Tuesday, April 20, 2010 9:58 PM
    Tuesday, April 20, 2010 8:09 PM
  • I may have finally fixed my own issue.

    in Powershell I ran get-service *in

    Showed the IISADMIN service was stopped. Tried to restart (restart-service iisadmin) with no success. Checked the interface and noticed the service was disabled. Set to Automatic, started, closed and reopend the EMC. Phew! Now just need to finish fixing OWA.

     - gymmbo

    • Proposed as answer by gymmbo Tuesday, April 20, 2010 10:01 PM
    Tuesday, April 20, 2010 10:01 PM
  • Jason Fenech,

                        You have the answer (in the case that you made an upgrade from W2k8 Std to Ent).

    Thank you.

    Regards.

    Wednesday, June 09, 2010 7:53 PM
  • This worked for me.  Thank you VERY much!
    Friday, July 09, 2010 4:34 AM
  • Hi Tamer,

    I ran winrm quickconfig on Windows Powershell. It informed me that it was going to add a listener and an exception for winrm in the firewall. I typed Y (Yest) to accept and it configured the settings. This resolved my issue. Thanks for your help.

    Friday, July 16, 2010 6:06 PM
  • That fixed mine Jason, thanks for the information.
    Tuesday, July 20, 2010 1:16 PM
  • Wanted to chime in - tried all of the above, and while winrm wasn't already installed, that did not fix my issue.  Turns out all of the Exchange Services were set to Disabled!  It's a brand new install, and they were working before I did Windows Updates, so I'm wondering if Update Rollup 4 did this for some reason?  I set them all properly per http://technet.microsoft.com/en-us/library/ee423542.aspx and finally was able to connect via the Console.
    Sunday, August 01, 2010 3:45 AM
  • I tried all of the above "fixes" on my way down the page. Then Pam says the Exchange services were disabled after RU4. I had trouble installing RU4 (had to disable UAC and then it installed fine). Sure enough all of the services were disabled. Followed the link from Pam (above) and enabled the services. I was beginning to think I was going to have to do a new (clean) install. Phew! I can enjoy the weekend now :-) 
    Saturday, August 14, 2010 8:35 AM
  • Thank you, After RU4 I also had this problem and by doing the following it worked:

    1. Disable anonymous authentication for powershell virtual directory on IIS 7.0
    2. IIS Admin Service was set to Disabled and Stopped so I turned it On Automatic and Started the service

    Thanks :)

    Tuesday, August 17, 2010 9:13 PM
  • Jason,

    This worked for me without a reboot required. Thanks for post!

    -David

    Wednesday, August 18, 2010 6:21 PM
  • Hi Nair,

    Good answer , i had this problem two days ago , i had upgrade my server 2008 r2 standard to entreprise and after that , impossible to restart my exhange server 2010.

    I installed WinRM IIS extensions and now is OK.

    Thank's

     

    Monday, October 25, 2010 12:11 PM
  • Thank you all for the help.  Installing WinRM IIS extentions resolved my issue also.

    Wednesday, November 24, 2010 7:47 PM
  • Thank you all for the help.  Installing WinRM IIS extentions resolved my issue also.

    Same here, thanks guys! (No reboot required for me anyway)

     


    Martin Gibney
    Wednesday, January 05, 2011 10:54 AM
  • mee to

    how can i do ?

    who tell me plz?

    Sunday, February 13, 2011 10:08 AM
  • People:

     

    If you are using IE with proxy setting or if you have configured the proxy using

    netsh

    then resetting the parameters to direct should avoing having to install and reinstall again.

    Hope this helps.

     

    Regards,

     

    Monday, February 14, 2011 11:46 PM
  • Thanks Nasir.

    This also resolved the issue for us.

    The exchange documentation really should mention in the list of supported OS versions that Std is only suported for servers that will not be part of a DAG

    Thursday, March 03, 2011 4:12 PM
  • Hi all,

    Jason Fenech's solution worked for me too, all I had to do was enable WinRM IIS extension [Server Manager -> Features -> Selected WinRM IIS Extension].

    I did NOT need to run WinRM config or restart anything.

    Thanks a lot.

    Monday, March 07, 2011 8:09 AM
  • somehow WinRM IIS extension is missing from the pre-requisite check...

    it works for me after this is installed.


    Edwin
    Thursday, March 17, 2011 12:45 AM
  • Thanks Mital_KE for giving the steps for WinRM IIS extensions setup.

    That helped me to solve my problem.

    Thursday, April 21, 2011 6:13 AM
  • I too encountered the same error messages and tried everything suggested in this thread.  None of it worked.  It turns out my problem was caused by the default firewall settings on both the Exchange server and the domain controller.  DOH!  Make sure inbound and outbound connections are allowed in the domain profile of your firewall settings.
    Wednesday, June 22, 2011 5:28 PM
  • I had the same problem (Management Console and Management Shell could not connect to server). After configuring a second Exchange Server 2010 on a virtual machine, I was able to run the Exchange Best Practices Analyzer.  ExPBA reported the wrong accounts were configured on the IIS Application Pools for Exchange. The Exchange application pools are supposed to run on the LocalSystem account, but mine were configured with the ApplicationPoolIdentity for each of the Exchange application pools.

    To correct, open IIS Manager and expand the Application Pools node.

    In each of the Exchange application pools, click Advanced Settings, and change the account to LocalSystem (be sure not to select LocalService by mistake).

    Click Ok when done. Restart IIS (at a command prompt, type IISRESTART /NOFORCE). 

    Hope this helps others who have been confounded by the generic "Error 500" message from WinRM.

    Friday, July 15, 2011 11:24 AM
  • The steps to remove and add the WinRM IIS Extensions eventually worked for me.

    What I needed to do was the following:

    *  Remove feature WinRM IIS

    *  Cycle the Windows Remote Management service

    * Add feature WinRM IIS

    * Cycle Windows Remote Management service

    Then I was able to run either the Exchange Management Console or Shell.

    Friday, November 11, 2011 6:57 PM
  • Hi all,

    I had the exact same issue and was caused by running an Windows Update on the server that crashed the server. During the installation of the update - some of the services were disabled. Among them; all the Exchange services - so I configured them back to Automatically Start again.. Still no luck..

    But.. After finding that the IIS Admin Service was disabled as well - it was really not hard to get the server back on track again.

    For me - the solution was to make sure that all services SUPPOSED to be running - really were running!
    Now when they do - no errors, no nothing.. Everything works as expected!

    (There may be a possibility to find this out if you try to uninstall Exchange. As soon as you choosen the role to uninstall, you will IF this is the case, get an error telling you that you cannot uninstall Exchange's role due to a non functional IIS installation. But - if you know what to look for - it's easier to find what's wrong.. Check your DISABLED or STOPPED services.. Any service stopped or disabled that probably should not be in that state?)

    Good luck!

    • Proposed as answer by Malevolent77 Friday, December 02, 2011 10:58 AM
    Friday, December 02, 2011 10:58 AM
  • I had the same problem (Management Console and Management Shell could not connect to server). After configuring a second Exchange Server 2010 on a virtual machine, I was able to run the Exchange Best Practices Analyzer.  ExPBA reported the wrong accounts were configured on the IIS Application Pools for Exchange. The Exchange application pools are supposed to run on the LocalSystem account, but mine were configured with the ApplicationPoolIdentity for each of the Exchange application pools.

    To correct, open IIS Manager and expand the Application Pools node.

    In each of the Exchange application pools, click Advanced Settings, and change the account to LocalSystem (be sure not to select LocalService by mistake).

    Click Ok when done. Restart IIS (at a command prompt, type IISRESTART /NOFORCE). 

    Hope this helps others who have been confounded by the generic "Error 500" message from WinRM.

    This worked for us, thank you so much for taking the time to write it up.
    Thursday, December 29, 2011 8:59 PM
  • Zhler....Thank you so much. I tried the WinRM feature add, and until I added the Exchange install path it would start the EMC.  Just installed a new database and bagan moving mailboxes.

     

    Thanks again.

    Monday, January 02, 2012 1:54 AM
  • Hello All,

    I was also facing same problem, so I have restarted the following service and it is working fine.

    WinRM Service OR Windows Remote Management (WS-Management)


    Regards,Ali
    Monday, January 30, 2012 6:01 AM
  • Hi all,

    I had the exact same issue and was caused by running an Windows Update on the server that crashed the server. During the installation of the update - some of the services were disabled. Among them; all the Exchange services - so I configured them back to Automatically Start again.. Still no luck..

    But.. After finding that the IIS Admin Service was disabled as well - it was really not hard to get the server back on track again.

    For me - the solution was to make sure that all services SUPPOSED to be running - really were running!
    Now when they do - no errors, no nothing.. Everything works as expected!

    (There may be a possibility to find this out if you try to uninstall Exchange. As soon as you choosen the role to uninstall, you will IF this is the case, get an error telling you that you cannot uninstall Exchange's role due to a non functional IIS installation. But - if you know what to look for - it's easier to find what's wrong.. Check your DISABLED or STOPPED services.. Any service stopped or disabled that probably should not be in that state?)

    Good luck!

    Thanks Malevolent77,

    I was searching for an answer to my problem for hours and your hint with the disabled services resolved my problem(s)! THANKS!

    Friday, March 30, 2012 1:10 PM
  • IISRESET solved my case, thanks all.

    Sunday, April 29, 2012 5:52 PM
  • I had the same problem in my test environment. After upgrading from Win 2008 Server Standard R2 to Enterprise, the Exchange console starting throwing the "The WinRM client received an HTTP server error status (500)" error.

    My test env consists of a Windows Std R2 DC and 2x Windows Ent R2 2008 with Exch 2010 Enterprise.

    This is what fixed it;

         Server Manager -> Features -> Selected WinRM IIS Extension (found this ticked off i.e not installed)

    In my case there was no need to iisreset or run the WinRM Quickconfig command.

    I ran this successfully on the two Exchange 2010 Enterprise servers I'm using.

    Hope this helps.

    Thank you, a perfect answer. Exactly the same issues I had. Upgraded Win 2008 R2 to Enterprise (for DAG) and no access to Management console.  Followed the advice above, all working sweetly. Nice on Jason.
    Friday, May 18, 2012 6:49 PM
  • I ran into this problem myself and this page finally had the answers for me.  My Exchange Services were all turned off as well in combination with IIS and WinRM issues.  WTF?!

    I find it quite unbelievable that these misconfiguration issues can occur on a fresh installation.  I've installed a number of Exchange 2010/Windows Server 2008 combinations over the last year and they all took days to complete.  The number of patches and manual fixes I have had to find and implement should make Microsoft and its developers embarrassed.

    The hard part in this latest installation for me is that nothing has gotten better since my last installations of any from 6 to 9 months ago.  In fact, this one took me even longer.  I had to apply the same patches and implement all sorts of checks and manual fixes to get this one done.  Why isn't any of this incorporated into the Exchange 2010 download that's currently downloadable?   Is the Exchange 2010 and Windows 2008 server code getting ignored?  Looks like it to me.

    Sorry to rant, but this software sure as hell is not worth $4K we had to pay for it.

    Wednesday, June 06, 2012 2:52 PM
  • This is what fixed it;

         Server Manager -> Features -> Selected WinRM IIS Extension (found this ticked off i.e not installed)

    I upgraded a Windows Server 2008 R2 machine that had Exchange 2010 on it to Windows Server 2012.  I got the 500 error when trying to use EMC.  This exact thing fixed it.  Just had to install WinRM IIS Extension from features.

    Many thanks Jason!!!

    Tuesday, September 11, 2012 11:39 PM
  • Make sure your IISADMIN service is not disabled but Automatic and running.  Had the above issues for days on my lab Excahnge 2010 server and finally discovered via another post that this was disabled.  EMC and EMS came on nicely thereafter.
    Monday, September 24, 2012 5:34 PM
  • start the services of ASP.NET State Service
    Monday, October 29, 2012 1:37 PM
  • MSExchangeOwaAppPool
    MSExchangeServicesAppPool

    Make sure these are using the LocalSystem Identity.

    IISRESET /NOFORCE

    Wednesday, November 07, 2012 12:28 AM
  • I went the entire day going through this thread and applying all the settings.

    I had most of the settings correct after checking them here, only thing i was missing was the winrm feature but after adding it did not fix my issue. Ive checked the default site to make sure it didn't have a name on HTTP, checked, the IIS manager app tool to local system, environment variables, even turned on the asp.net service.

    Nothing has helped solve my issue...

    Tuesday, April 09, 2013 5:26 PM
  • I have seen this error when server clocks are out of sync. 

    Tuesday, April 09, 2013 6:34 PM
  • I have seen this error when server clocks are out of sync. 

    the clocks are perfectly in sync
    Tuesday, April 09, 2013 6:39 PM
  • Hi

    I've just been experiencing this problem (WinRM HTTP error 500) and my problem turned out to be a name resolution issue. The EMC was trying to connect to the FQDN of my server, but if I tried pinging that name, the ping returned (::1) response, rather than it's IP address. nslookup was returning the correct IP address, and DNS was set up correctly. I fixed it by creating an entry in the local hosts file for the NetBIOS and FQDN of the server, confirming that the ping returned the correct value, then starting the EMC. That allowed it to connect correctly.

    The hosts file had an entry in there that read

    ::1 localhost

    Don't know where that came from - I hadn't added it.

    Regards

    Ken Z



    • Proposed as answer by KenZygmunt Thursday, April 18, 2013 7:34 AM
    • Edited by KenZygmunt Thursday, April 18, 2013 7:36 AM typo
    Thursday, April 18, 2013 7:34 AM
  • I had the same issue. The only thing that was needed was an IISRESET command. There was no need to install features to get it working.
    Friday, May 24, 2013 12:09 AM
  • I had the same issue, what fixed my server was to remove the WinRM feature in server manager, reboot, add the feature and reboot again. Reboots were just precautionary.

    Thursday, July 11, 2013 5:22 PM
  • Thanks a Lot , I have installed WinRM and it gets working like a charm.

    It was really headache that console was not working. Not seems working.

    Thanks

    Tejas Patel

    Tuesday, July 16, 2013 10:29 AM
  • Hi All,

     One of my user who member of Recipient Management group unexpectedly get this error message on a member server where EMC is installed. If I logon this computer via rdp and start EMC with my ceredential it is working properly. Unfortunately the profile delete didn't help, the only solution if I delete and create again this user inside AD.

    Does anybody any idea how can I resolve this issue without user deletion?

    Thanks

    Tuesday, November 26, 2013 11:46 AM
  • This working for me after a Windows Server 2008 R2 Standard to Enterprise in place upgrade...
    Friday, July 11, 2014 3:35 PM
  • Hi Everyone

    I know I'm a bit late but this may help others. Server 2012 Exchange 2010 SP3.

    Same error as original post. Tried all of the suggestions to no avail.

    I had a 'Site 2' that was non-responsive in IIS - wouldn't give me any properties at all. Removed this then iisreset /noforce and now everything works OK.

    Hope this helps others...

    Tuesday, September 23, 2014 4:53 PM
  • Thank you!

    I had the same problem, because I upgraded my tests environment. (WS 2008 R2 Std. -> WS 2008 R2 Ent. with Exchange 2010).

    *****************************

    This is what fixed it;

         Server Manager -> Features -> Selected WinRM IIS Extension (found this ticked off i.e not installed)

    In my case there was no need to iisreset or run the WinRM Quickconfig command.

    *****************************

    Wednesday, November 26, 2014 9:00 AM
  • Thank you, Jason Fenech.

    I had the same problem in my environment.

    :D :)

    Thursday, April 23, 2015 9:46 AM
  • I ran into a similar issue after setting up a basic Windows Server 2012 R2 with Active Directory and was not able to install the WinRM IIS Extensions because the setup always failed because of a WinRM error.

    I restarted the "Windows Remote Management" service manually, ran "winrm quickconfig" in a elevated command prompt. After this i was able to install the WinRM IIS Extensions.

    Friday, June 19, 2015 2:55 PM
  • I had a problem after upgrade Server 2008 Std -> 2008 Enterprise

    Jesús Ángel Señorán López. Administrador de sistemas y seguridad.

    Monday, March 07, 2016 2:50 PM