locked
Outlook 2013 Exchange 2013 Address Book Error 0x8004010F : The operation failed. An object cannot be found. RRS feed

  • Question

  • Hi,

    We have Exchange 2013 running in our network, and are using Outlook 2013 on all PCs. We added some users several weeks ago, and they are not showing up in the Address Book. When we try to download the Address Book in Outlook, we receive the error 0x8004010F : The operation failed. An object cannot be found.

    Please let me know how I can start to troubleshoot this.

    Regards,

    Chris

    Wednesday, September 24, 2014 8:34 AM

Answers

  • Can you restart the server and try to download OAB?
    Pleas update me the result.

    Thanks, MAS
    Please mark as helpful if you find my comment helpful or as an answer if it does answer your question. That will encourage me - and others - to take time out to help you.

    • Marked as answer by Chris.Lewis Wednesday, October 1, 2014 3:23 PM
    Thursday, September 25, 2014 11:51 AM

All replies

  • If possible configure split dns http://exchange.sembee.mobi/network/split-dns.asp

    Configure your internal and externals URLs the same and try.
    http://www.mustbegeek.com/configure-external-and-internal-url-in-exchange-2013/


    Thanks, MAS
    Please mark as helpful if you find my comment helpful or as an answer if it does answer your question. That will encourage me - and others - to take time out to help you.

    Wednesday, September 24, 2014 11:35 AM
  • Thank you for the reply.


    The server is already configured as per http://www.mustbegeek.com/configure-external-and-internal-url-in-exchange-2013/ and we are using split dns.

    Let me know if I can post any information that will help you to suggest possible troubleshooting steps.

    Wednesday, September 24, 2014 1:16 PM
  • Please check this also
    http://msexchangeguru.com/2013/12/04/e2013-oab/

    Thanks, MAS
    Please mark as helpful if you find my comment helpful or as an answer if it does answer your question. That will encourage me - and others - to take time out to help you.

    Wednesday, September 24, 2014 1:22 PM
  • Thanks again for your help.

    I have run the commands indicated in http://msexchangeguru.com/2013/12/04/e2013-oab/ and all seems to indicate that it is configured correctly.

    Running a couple more tests, I can see that if I attach a new Outlook client to the Exchange Server, it picks up the contacts that were previously missing. I suspect that this indicates that it is an issue with Outlook downloading the OAB after the initial configuration, or the availablity of the OAB to Outlook.

    Let me know which tests I can run next.

    Wednesday, September 24, 2014 2:24 PM
  • Please check the step 6 in this link and make sure OAB URL is correct and available. Exchange 2013 distributes OAB only through IIS.
    http://support.microsoft.com/kb/2429946

    Thanks, MAS
    Please mark as helpful if you find my comment helpful or as an answer if it does answer your question. That will encourage me - and others - to take time out to help you.

    Wednesday, September 24, 2014 2:31 PM
  • Hi,

    There is no 'OAB URL' in the 'Results' tab, and no <OABUrl> tag in the XML tab.

    Regards,

    Chris

    Wednesday, September 24, 2014 2:40 PM
  • You are supposed to see something similar to this.
    If not please update OAB URLs 

    Set-OabVirtualDirectory -Identity "server1\oab (default web site)" -InternalUrl https://mail.domain.com/oab -ExternalUrl https://mail.domain.com/oab

    Thanks, MAS
    Please mark as helpful if you find my comment helpful or as an answer if it does answer your question. That will encourage me - and others - to take time out to help you.

    Wednesday, September 24, 2014 2:54 PM
  • Hi,

    If I run Get-OabVirtualDirectory I get the following (I have blanked out the server name and URL):

    Which seems to indicate that it is set correctly. Is it worth running that command anyway?

    Regards,

    Chris

    Wednesday, September 24, 2014 3:10 PM
  • I have run that command, and get the following message:


    Wednesday, September 24, 2014 3:24 PM
  • This is my result in the 'Test Outlook Autoconfiguration'

    Wednesday, September 24, 2014 3:40 PM
  • Can you check the logs at %ExchangeInstallPath%\Logging\HttpProxy\OAB  in your CAS server and check for any error related to this?

    Please post the result of the below command

    Get-Mailbox -Arbitration | where {$_.PersistedCapabilities -like “*OAB*”} | ft Name, Servername, Database

    Thanks, MAS
    Please mark as helpful if you find my comment helpful or as an answer if it does answer your question. That will encourage me - and others - to take time out to help you.

    • Edited by MAS- Wednesday, September 24, 2014 4:16 PM
    Wednesday, September 24, 2014 4:11 PM
  • Hi,

    I cannot see any errors in the log. Let me know if you'd like me to send you some of them?

    The result of that command is below:

    Thursday, September 25, 2014 8:50 AM
  • Check OAB is configured in database
    Get-MailboxDatabase | Ft Name, *book*
    If you see any database not configured OAB. Please configure
    Get-Mailboxdatabase | Set-MailboxDatabase -OfflineAddressBook “Default Offline Address Book”
    Please try creating a new OAB and tag to the the database as well. Use these command to create new OAB and tag to the database.
    New-OfflineAddressBook -Name “NEW2013OAB” -AddressLists “\Default Global Address List” -VirtualDirectories “SERVERNAME\OAB (Default Web Site)”
    Get-Mailboxdatabase | Set-MailboxDatabase -OfflineAddressBook “NEW2013OAB”
    Please post back the results. 

    Thanks, MAS
    Please mark as helpful if you find my comment helpful or as an answer if it does answer your question. That will encourage me - and others - to take time out to help you.

    Thursday, September 25, 2014 9:09 AM
  • Hi,

    I have run each command, findings are below:

    4/5 databases did have the OAB configured, so I ran the command to configure the OAB. The previous command then had all databases configured with an OAB.

    At this point I tried the 'Test Outlook Autoconfiguration' again, which hasn't changed. (Can this take a while to pickup the change?)

    I then created a new OAB, and configured it on the Databases. A Get-MailboxDatabase | Ft Name, *book* reveals that it is now configured. Once again the Autoconfiguration isn't showing the OAB. Let me know if I need to restart any services to apply this

    Thursday, September 25, 2014 9:43 AM
  • I still feel your autodicover is still not correct as we have checked almost everything.
    If you ping autodiscover.emaildomain.com it should return your internal IP of exchange.

    Restart Mailbox assistant service,. That will not help I guess in your case.


    Thanks, MAS
    Please mark as helpful if you find my comment helpful or as an answer if it does answer your question. That will encourage me - and others - to take time out to help you.

    Thursday, September 25, 2014 11:38 AM
  • Can you restart the server and try to download OAB?
    Pleas update me the result.

    Thanks, MAS
    Please mark as helpful if you find my comment helpful or as an answer if it does answer your question. That will encourage me - and others - to take time out to help you.

    • Marked as answer by Chris.Lewis Wednesday, October 1, 2014 3:23 PM
    Thursday, September 25, 2014 11:51 AM
  • Hi Chris,

    Please try following steps:

    • Start Internet Explorer, click Tools, and then click Internet Options.
    • On the Connections tab, click LAN settings.
    • elect the Bypass proxy server for local addresses check box, and then click Advanced.
    • Type the FQDN of the CAS server, and then click OK.
    • Restart Outlook.

    Thanks

    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com


    Mavis Huang
    TechNet Community Support

    Saturday, September 27, 2014 7:13 AM
    Moderator
  • Hi Chris,

    Any update?

     

    Thanks


    Mavis Huang
    TechNet Community Support

    Monday, September 29, 2014 2:07 AM
    Moderator
  • Hi

    There is a multiple reason to receive an error 0x8004010f, it is just a generic MAPI error.

    Let’s check all settings are configured the way it is supposed to be: -

    1.    Make sure the authentication setting is set up properly by using this command: -

    Get-OabVirtualDirectory -ADPropertiesOnly | ft Identity, *Auth* -AutoSize

    2.    Check URL’S are configured properly: -

    Get-OabVirtualDirectory -ADPropertiesOnly | ft Identity, *url* -AutoSize

    3.    Check the location of OAB: -

    C:\Program Files\Microsoft\Exchange Server\V15\ClientAccess\OAB

    4.    Now find out the location of the database on which the Arbitration mailbox resides: -

    Get-Mailbox -Arbitration | where {$_.PersistedCapabilities -like “*OAB*”} | ft Name, Servername, Database
    Get-MailboxDatabaseCopyStatus MGUxxx

    5.    It is also important to ensure all database has the OAB set up properly for this use CMDLET: -

    Get-MailboxDatabase | Ft Name, *book*

    6.    If one or more database does not have OAB setup, then use CMDLET to set OAB for it: -

    Get-Mailboxdatabase | Set-MailboxDatabase -OfflineAddressBook “Default Offline Address Book”

    7.    If the issue is affecting only one or specific set of users, then check they have an OAB specified on their account: -

    Get-Mailbox abc.xyz | fl Name, OfflineAddressBook,Database

    Please correct me if the information that I am having is wrong.

    Reply awaited.

    Thanks and regards
     Ashish@S  


     

    Ashish@V

    Monday, September 29, 2014 9:24 AM
  • That seemed to do it, not sure if it simply refreshed the settings, but it's working now.

    Thank you very much.

    Regards,

    Chris

    Wednesday, October 1, 2014 3:23 PM
  • Glad to know it's fixed.

    Can you see OAB URLs now when you test autodiscover from outlook?


    Thanks, MAS
    Please mark as helpful if you find my comment helpful or as an answer if it does answer your question. That will encourage me - and others - to take time out to help you.

    Wednesday, October 1, 2014 4:18 PM