locked
Outlook 2010 Offline Address Book not working for some users RRS feed

  • Question

  • We have recently moved from Exchange 2003 to Exchange 2010 and now we are moving to Office 2010. We are in early days, but we have identified an issue with the Offline Address Book. We can download the Offline Address Book. The files show up in the appropriate place within the users profile (all 6 files with the OAB extension) and the registry entries are there to point to the files, but when I open Outlook, open an email and try to access the address book I get a message “The connection to Microsoft Exchange is unavailable. Outlook must be online to complete this action”.

    Here is the stranger part. It does not happen for all users. At the moment we have about a 50% success rate. One of my technicians it worked fine for him first time and a couple of the staff who we have moved across, but other, we just can not identify the causes.

    Can anyone assist with where we can look?

    Server 2008R2 with Exchange 2010

    Client Win 7x64 with Office 2010 32bit

    Both fully patched.

    Files downloaded to C:\Users\username\AppData\Local\Microsoft\Outlook\Offline Address Books\GUID


    Stephen B
    Monday, August 8, 2011 10:22 PM

Answers

  • Hello,

     

    You can try rebuilding the OAB by the following 4 steps:

     

    1.    [Create a new OAB object]

    ======================

    a.    Open Exchange Management Console, expand “Organization Configuration” ->”Mailbox”.

    b.    Click “Offline Address Book” tab. Right click the blank area and click “New Offline Address Book”.

    c.    Type a different OAB name and click “Browse” to select the Exchange 2010 mailbox server, as OAB generation server.

    d.    Checked “Include the default Global Address Lists” option.

    e.    Click Next and checked “ Enable Web-base distribution” option and “ Enable public folder distribution” option. Click “Add” to select the default OAB virtual directory.

    f.     Click “Next”, click “New” and click “Finish” to complete the creating process.

     

    2.    [Restart related services]

    =====================

    a.    Restart the “Microsoft Exchange System Attendant” service.

    b.    Restart “Microsoft Exchange File Distribution” service.

     

    3.    [Update the new OAB and set it as default]

    ==================================

    a.    Right click the new create OAB and click “Update” to update it manually. Waiting 15-30 minutes for the OAB generate finished.

    b.    Right click the new OAB and click “set as default”. Click “Yes” to confirm it.

     

    4.    [Associate the new OAB to all the users’ mailbox databases]

    ==============================================

    a.    In EMS, please type in the command:   

           Get-MailboxDatabase |  set-MailboxDatabase  -OfflineAddressBook "OAB name"

    b.    Wait for one day and check whether the problem is resolved.

     

    If it still does not work, please collect the following information for further research:

     

    1. [Collect OAB VD information]

    =================

    Run the following command on the CAS server:

     

    Get-OABVirtualDirectory |fl >c:\oabvd.txt

    Get-MailboxDatabase |FL >C:\mbx.txt

     

    2. [Collect AutoConfiguration Status in Outlook]

    ===================================

    a. While Outlook is running, click the CTRL key and then right-click the Outlook icon in the system tray and then select “Test Email Autoconfiguration”.

    b. Confirm that your email address is in the address field, uncheckUse Guessmart” and “secure Guessmart authentication” boxes. Then click the “Test” button.

    c. Once it runs, please send me a screen shot of the Log tab and Results tab.

     

    You can reach me at: v-simwu@microsoft.com

     

    Thanks,

    Simon

    Wednesday, August 10, 2011 7:55 AM
    Moderator

All replies

  • I guess then your using HTTP to distribute your OAB or are you using legacy Public Folders?

    Tuesday, August 9, 2011 6:26 AM
  • The server is set to "Web bassed distribution" so yes to HTTP.  We have never used public folders so I do not think anything in that area would be related. 
    Stephen B
    Tuesday, August 9, 2011 6:32 AM
  • I guess your getting no issues with connectivity tests or email autoconfiguration?

     

    Hold Ctrl > Right Click Outlook in Task Bar.

    Tuesday, August 9, 2011 6:35 AM
  • It appears to be working well in all other areas.  The auto config works like a dream and if we send an email whilst off-line in Cached mode it connects fine and sends the email when we later connect to the network, but I will try the "Ctrl-RC" when I get back to the office to see if it reports anything.
    Stephen B
    Tuesday, August 9, 2011 7:55 AM
  • Hello,

     

    You can try rebuilding the OAB by the following 4 steps:

     

    1.    [Create a new OAB object]

    ======================

    a.    Open Exchange Management Console, expand “Organization Configuration” ->”Mailbox”.

    b.    Click “Offline Address Book” tab. Right click the blank area and click “New Offline Address Book”.

    c.    Type a different OAB name and click “Browse” to select the Exchange 2010 mailbox server, as OAB generation server.

    d.    Checked “Include the default Global Address Lists” option.

    e.    Click Next and checked “ Enable Web-base distribution” option and “ Enable public folder distribution” option. Click “Add” to select the default OAB virtual directory.

    f.     Click “Next”, click “New” and click “Finish” to complete the creating process.

     

    2.    [Restart related services]

    =====================

    a.    Restart the “Microsoft Exchange System Attendant” service.

    b.    Restart “Microsoft Exchange File Distribution” service.

     

    3.    [Update the new OAB and set it as default]

    ==================================

    a.    Right click the new create OAB and click “Update” to update it manually. Waiting 15-30 minutes for the OAB generate finished.

    b.    Right click the new OAB and click “set as default”. Click “Yes” to confirm it.

     

    4.    [Associate the new OAB to all the users’ mailbox databases]

    ==============================================

    a.    In EMS, please type in the command:   

           Get-MailboxDatabase |  set-MailboxDatabase  -OfflineAddressBook "OAB name"

    b.    Wait for one day and check whether the problem is resolved.

     

    If it still does not work, please collect the following information for further research:

     

    1. [Collect OAB VD information]

    =================

    Run the following command on the CAS server:

     

    Get-OABVirtualDirectory |fl >c:\oabvd.txt

    Get-MailboxDatabase |FL >C:\mbx.txt

     

    2. [Collect AutoConfiguration Status in Outlook]

    ===================================

    a. While Outlook is running, click the CTRL key and then right-click the Outlook icon in the system tray and then select “Test Email Autoconfiguration”.

    b. Confirm that your email address is in the address field, uncheckUse Guessmart” and “secure Guessmart authentication” boxes. Then click the “Test” button.

    c. Once it runs, please send me a screen shot of the Log tab and Results tab.

     

    You can reach me at: v-simwu@microsoft.com

     

    Thanks,

    Simon

    Wednesday, August 10, 2011 7:55 AM
    Moderator
  • Thanks for the info.  We have not got it working as yet, but we have had some other issues to deal with which have slowed us up.  I will log the results.

     

    Steve


    Stephen B
    Thursday, August 18, 2011 4:48 AM