Windows Update Error 0x8007277a Defender Error 0X80072ee7


  • I've been trying to run windows update for some time now and it keeps giving me an error that windows update can't run because the service isn't running.  I also get the message: "Error 0x8007277a: The requested service provider could not be loaded or initialized." Microsoft Fix it won't run and gives the error: "We're sorry, but an error occurred while downloading one or more components and the troubleshooter cannot be run.  Please try again later." 

    From the support forums I've tried these solutions, with my Virus program deleted and firewall disabled, and have scanned for Malware.

    1. Running the Windows Update troubleshoot
    2. When I try to start the service it simply won't start.  Have tried changing from Automatic (delayed) to manual, automatic, etc.
    3. I ran the Norton uninstall.
    4. Ran SFC (System File Checker) and everything was fine.
    5. Ran update troubleshooter from Clean Boot, and also tried Mocrosoft Fix It.
    6. Restarted Windows Services through command prompt.
    Saturday, May 18, 2013 5:07 AM


All replies