none
Error when creating a new mailbox.

    Question

  • When I try to create a new mailbox I get the following error. Forest1.net is my domain name. exuser is the name of the new user account.

    Summary: 1 item(s). 0 succeeded, 1 failed.

    Elapsed time: 00:00:01

    exuser
    Failed

    Error:
    Load balancing failed to find a valid mailbox database.

    Exchange Management Shell command attempted:
    New-Mailbox -Name 'exuser' -Alias 'exuser' -UserPrincipalName 'exuser@Forest1.net' -SamAccountName 'exuser' -FirstName 'ex' -Initials '' -LastName 'user' -Password 'System.Security.SecureString' -ResetPasswordOnNextLogon $false

    Elapsed Time: 00:00:01


    Thanks and Regards, Radhakrishnan

    Thursday, July 5, 2012 8:58 AM

Answers

All replies

  • Hi

    What happens if you specify the -Database yourdatabasename parameter?  Are you databases suspended or excluded from provisioning?

    Steve

    Thursday, July 5, 2012 9:09 AM
  • How do I find my database name. I don't remember entering any database name when I installed exchange server 2010.

    Thanks and Regards, Radhakrishnan

    Thursday, July 5, 2012 10:06 AM
  • Get-MailboxDatabase will list the names of your databases.

    Steve

    Thursday, July 5, 2012 10:12 AM
  • I tried the command "Get-MailboxDatabase" in powershell. But I got the error that this is not recongnised as a cmdlet, funciot, script file.....

    I tried creating Distribution group and contact. It worked. I have problem with only creating a mailbox.


    Thanks and Regards, Radhakrishnan


    Thursday, July 5, 2012 10:31 AM
  • Hi ,

    Please verify the Information Store service is started.

    Distribution Group and contacts both have no mailbox in information store. So you can create them.

    And now, we may need to verify if the mailbox database is mounted and we can get its information.

    The following similar issue for your reference.

    Cannot execute Get-MailboxDatabase cmdlet:<//span>

    http://social.technet.microsoft.com/Forums/en-US/exchangesvradmin/thread/a8022f91-5f91-4660-80d0-ac6d98cd787a/

    By the way, do you choose which mailbox database you want to store when create mailbox ?


    Wendy Liu

    TechNet Community Support

    Friday, July 6, 2012 5:42 PM
    Moderator
  • You can try running this to fix the error in powershell:

    Add-PSSnapin Microsoft.Exchange.Management.PowerShell.E2010

    Friday, July 6, 2012 6:27 PM
    Owner
  • So,

    You need to run these commands in Exchange Management Shell. It sounds like your mailbox database is either non-existent or dismounted. I'm guessing that you don't have any mailboxes created yet.

    Make sure that you're a member of the Exchange Organizational Admin group. Then, Open Exchange Management Shell -> Organization Configuration -> Mailbox. Then on the right hand side, click on New Mailbox Database and follow the wizard. After you create a database, then try adding a mailbox again.

    If you see a Mailbox Database in there already, it will probably say "Dismounted" next to it. Right click on it and select Mount Database. Then you should be able to create mailboxes.

    Basically, Mailboxes have to be created within a database. If a database is not available, then a mailbox cannot be created.

    Cheers,

    Mitchel

    • Proposed as answer by Mitchel Lewis Saturday, July 7, 2012 12:20 AM
    Saturday, July 7, 2012 12:20 AM
  • I am using the ECP (web page) and I get the same error.  I have only 1 Mail Database, but must manually select it each time I create a mailbox. (Yes I am a member of the appropriate groups)
    Wednesday, January 9, 2013 8:47 PM
  • Sorry to dredge up an old post, but I had this issue on a single-sever Exchange site.  The posts above helped, but to clarify the issue was that the (only) mailbox database was disabled for provisioning.

    run Get-MailboxDatabase |fl to check - look near the top for the IsSuspendedFromProvisioning and IsExcludedFromProvisioning settings.  You will probably note that one or the other (or both) are enabled, which prevents auto-provisioning from working.

    To change these run the following commands:

    Set-MailboxDatabase "MailboxDatabaseName" -IsSuspendedFromProvisioning $false
    Set-MailboxDatabase "MailboxDatabaseName" -IsExcludedFromProvisioning $false

    After that it worked without needing to specify the database manually.

    Cheers

    Matthew


    Sunday, September 14, 2014 11:05 PM
  • Matthews post got me pointed in the right direction.  Here is something additional that I noticed about Exchange 2013, it seems to have a trigger to set the IsExcludedFromProvisioning based on available disk space.  In our clients instance it seemed to trigger that flag at 90% used space on the drive that contained the mailbox database.  See the results from our Get-MailboxDatabase command:

    ~~~~~~~~~~~~~~~~~~~~~~~~~~
    [PS] C:\Windows\system32>Get-MailboxDatabase |fl name,server,*provis*

    Name                                        : Mailbox Database 1026822345
    Server                                      : EX01
    IsExcludedFromProvisioning                  : True
    IsExcludedFromInitialProvisioning           : False
    IsSuspendedFromProvisioning                 : False
    IsExcludedFromProvisioningBySpaceMonitoring : True    
    ~~~~~~~~~~~~~~~~~~~~~~~~~~
     

    Hope that helps.

    Dirk


    • Edited by dwiggers Thursday, September 22, 2016 1:45 PM
    Thursday, September 22, 2016 1:44 PM