none
The page cannot be found error while accessing Exchange 2007 OWA from internet and intranet

    Question

  • Hi Team,

    Recently we reinstalled Windows 2003 SP2 on Exchange 2007 server and after a day owa stopped working, giving "The page cannot be found" error.

    I have disabled 32 bit asp.net version on the server but still not working

    Any help much appreciated!

    Thanks!

    Rajeesh

    Friday, January 31, 2014 5:04 AM

Answers

  • Hi,

    Based on my experience, the issue is caused by the settings are changed in IIS.
    And here is the resolution:
    1. Open the IIS manager
    2. from within there go to the web services extensions
    3. from within there ensure that asp.net and active server pages are "allowed".
    4. run iis reset and test

    Thanks,

     


    Angela Shi
    TechNet Community Support

    Tuesday, February 04, 2014 3:20 AM
    Moderator

All replies

  • Hello Rajeesh
    Any luck when you are accessing the default website locally on the Server - if not then proceed the troubleshooting with IIS

    If yes then probably you can try fixing the owa by recreating the virtual directories - mentioned below the steps for reference purpose

    XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX

    - Open Exchange Management Shell with elevated permission
    - Run the following commands:

    Get-AutodiscoverVirtualDirectory
    Get-OABVirtualDirectory
    Get-OWAVirtualDirectory
    Get-WebServicesVirtualDirectory
    Get-ActiveSyncVirtualDirectory
    Get-UMVirtualDirectory

    Then you can remove the Virtual Directories but change the XXXXXXX to the information you got earlier (AND DON'T JUST COPY AND PASTE INTO POWERSHELL! COPY IT INTO NOTEPAD AND THEN READ THE COMMAND AND CHANGE SERVERNAME OR OTHER RELATED INFORMATION)

    Remove-OWAVirtualDirectory -Identity "Owa (XXXXXXX)" -Confirm:$false
    Remove-OWAVirtualDirectory -Identity "Exadmin (XXXXXXX)" -Confirm:$false
    Remove-OWAVirtualDirectory -Identity "Exchange (XXXXXXX)" -Confirm:$false
    Remove-OWAVirtualDirectory -Identity "Exchweb (XXXXXXX)" -Confirm:$false
    Remove-OWAVirtualDirectory -Identity "Public (XXXXXXX)" -Confirm:$false
    Remove-WebServicesVirtualDirectory -Identity "EWS (XXXXXXX)" -Confirm:$false
    Remove-ActiveSyncVirtualDirectory -Identity "Microsoft-Server-ActiveSync (XXXXXXX)" -Confirm:$false
    Remove-OabVirtualDirectory -Identity "OAB (XXXXXXX)" -Force:$true -Confirm:$false
    Remove-UMVirtualDirectory -Identity "UnifiedMessaging (XXXXXXX)" -Confirm:$false
    Remove-AutodiscoverVirtualDirectory -Identity "Autodiscover (XXXXXXX)" -Confirm:$false

    To verify that the directories have been removed, run the following commands. You should receive no output:

    Get-AutodiscoverVirtualDirectory
    Get-OABVirtualDirectory
    Get-OWAVirtualDirectory
    Get-WebServicesVirtualDirectory
    Get-ActiveSyncVirtualDirectory
    Get-UMVirtualDirectory

    To properly create these virtual directories, run the following commands (Please keep the information what you got earlier for XXXXXXX and change it here to):

    - Open Exchange Management Shell with elevated permission
    - Run the following commands (THE COMMANDS ARE A ONE-LINER. THE NEXT COMMAND IS SEPERATED WITH -----------------------------. So copy and paste it into notepad, check if it is one line, read it carefully and change the information you have to provide. Information you have to provide is in BIG LETTERS or XXXXXXX):

    New-OWAVirtualDirectory -WebsiteName "XXXXXXX" -OwaVersion "Exchange2007"
    -ExternalAuthenticationMethods Fba
    -----------------------------
    Set-OWAVirtualDirectory -InternalUrl "https://INTERNAL_FQDN_OF_EXCHANGE/owa/"
    -ClientAuthCleanupLevel "Low" -LogonFormat "UserName" -DefaultDomain “NETBIOSDOMAINNAME”
    -Identity "Owa (XXXXXXX)"
    -----------------------------
    New-OWAVirtualDirectory -WebsiteName "XXXXXXX" -OwaVersion "Exchange2003or2000"
    -VirtualDirectoryType "Exadmin" -ExternalAuthenticationMethods Fba
    -----------------------------
    New-OWAVirtualDirectory -WebsiteName "XXXXXXX" -OwaVersion "Exchange2003or2000"
    -VirtualDirectoryType "Mailboxes" -ExternalAuthenticationMethods Fba
    -----------------------------
    New-OWAVirtualDirectory -WebsiteName "XXXXXXX" -OwaVersion "Exchange2003or2000"
    -VirtualDirectoryType "Exchweb" -ExternalAuthenticationMethods Fba
    -----------------------------
    New-OWAVirtualDirectory -WebsiteName "XXXXXXX" -OwaVersion "Exchange2003or2000"
    -VirtualDirectoryType "PublicFolders" -ExternalAuthenticationMethods Fba
    -----------------------------
    New-WebServicesVirtualDirectory -WebsiteName "XXXXXXX"
    -InternalUrl "https://INTERNAL_FQDN_OF_EXCHANGE/EWS/Exchange.asmx" -basicauthentication 1
    -windowsauthentication 1
    -----------------------------
    New-ActiveSyncVirtualDirectory -WebsiteName "XXXXXXX"
    -InternalUrl "https://INTERNAL_FQDN_OF_EXCHANGE/Microsoft-Server-ActiveSync"
    -ExternalAuthenticationMethods Basic -InternalAuthenticationMethods Basic
    -----------------------------
    New-OabVirtualDirectory -WebsiteName "XXXXXXX" -InternalUrl "https://INTERNAL_FQDN_OF_EXCHANGE/OAB"
    -----------------------------
    Set-OabVirtualDirectory -PollInterval "30" -Identity "oab (XXXXXXX)"
    -----------------------------
    New-UMVirtualDirectory -WebsiteName "XXXXXXX"
    -InternalUrl "https://INTERNAL_FQDN_OF_EXCHANGE/UnifiedMessaging/Service.asmx"
    -----------------------------
    New-AutodiscoverVirtualDirectory -WebsiteName "XXXXXXX"
    -InternalUrl "https://INTERNAL_FQDN_OF_EXCHANGE/Autodiscover/Autodiscover.xml"
    -BasicAuthentication 1 -WindowsAuthentication 1
    -----------------------------
    Set-ClientAccessServer -Identity “Servername”
    -AutoDiscoverServiceInternalUri "https://INTERNAL_FQDN_OF_EXCHANGE/Autodiscover/Autodiscover.xml"
    -----------------------------
    Set-OfflineAddressBook "Default Offline Address Book"
    -VirtualDirectories "Servername\OAB (XXXXXXX)" -Versions Version2,Version3,Version4)"

    - To check if we were successful in creating the virtual directories correctly type in the commands:

    Get-AutodiscoverVirtualDirectory
    Get-OABVirtualDirectory
    Get-OWAVirtualDirectory
    Get-WebServicesVirtualDirectory
    Get-ActiveSyncVirtualDirectory
    Get-UMVirtualDirectory

    XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX


    Syed MM Messaging SME - IBM || MCTS || MCSE || MCSA || VCP5 || VCA ||

    Friday, January 31, 2014 6:11 AM
  • Hi,

    Based on my experience, the issue is caused by the settings are changed in IIS.
    And here is the resolution:
    1. Open the IIS manager
    2. from within there go to the web services extensions
    3. from within there ensure that asp.net and active server pages are "allowed".
    4. run iis reset and test

    Thanks,

     


    Angela Shi
    TechNet Community Support

    Tuesday, February 04, 2014 3:20 AM
    Moderator