none
Outlook 2007 not showing hyperlinks (in automated emails sent in plain text.)

    Question

  • We recently upgraded from Office 2003 / Exchange 2003 to Office 2007 / Exchange 2007.  A number of automated systems send plain text emails with URLs (not hyperlinks).   In Outlook 2003 / Exchange 2003 the URLs displayed as clickable (with ctrl + click) hyperlinks. In Outlook 2007 / Exchange 2007 the do not. (not sure about Outlook 2007 / Exchange 2003.)

    Is there a way to make these appear as hyperlinks, short of having users foward the emails to themselves?

    We have verified the following settings in Outlook 2007:

    Tools -> Trust Center: Email Security -> "Read all standard mail in plain text" is unchecked. 

    Tools -> Options -> Mail Format -> editor Options -> proofing -> Autocorrect options -> Tab Autoformat: has Replace: "Internet and network paths with hyperlinks" checked.)

     

    Thanks,

    Alex

    Friday, July 02, 2010 1:31 PM

Answers

  • Eventually, we had to open a support case: Essentially we were told this is a bug not a feature. (Both answers are posted here.)

     

    No resolution is proposed.

    • Marked as answer by am2o Monday, October 04, 2010 9:30 PM
    Monday, October 04, 2010 9:29 PM

All replies

  • Symptom: A third-party application sends plain text message containing an inline URL to exchange users, the URL is seen as a hyperlink on Outlook 2007. However, the URL is not converted to hyperlink anymore after exchange 2007 SP1 RU4 and later versions

    Cause: After RU4, there is a special way to process plain text messages, and thus causes the hyperlink cannot be recognized by Outlook if you using the third party application to send Plain text message with hyperlinks

    Workaround:

    The third party application has to be modified to send HTML messages

    Resources:

    A URL in an e-mail message is not displayed as a hyperlink in Outlook 2007


    James Luo
    TechNet Subscriber Support (http://technet.microsoft.com/en-us/subscriptions/ms788697.aspx)
    If you have any feedback on our support, please contact tngfb@microsoft.com
    Monday, July 05, 2010 9:49 AM
  • It seems that not all of our users have this problem: On the same server (mbx1), some users get the hyperlinks, and others do not.
    Tuesday, July 06, 2010 8:40 PM
  • Per my research, if the users encountered the same issue that described in the symptom, and they also received the messages in plain text, it would be an expected behavior due to product change

    Is there any difference between the working machine and the problematic machine, like outlook version, OS version, and the like?

    What’s the result if you put the working user’s mail profile on the problematic user’s machine, and then put problematic user’s mail profile on the working user’s machine?


    James Luo
    TechNet Subscriber Support (http://technet.microsoft.com/en-us/subscriptions/ms788697.aspx)
    If you have any feedback on our support, please contact tngfb@microsoft.com
    Wednesday, July 07, 2010 1:38 AM
  • Researching: Apparently one source "problematic" emails is our helpdesk system.  One front-end for the system users ASPMail, and displays the hyperlinks.  Another front end uses a home grown mailer which does not appear (at least for some users) as hyperlinks.
    Wednesday, July 07, 2010 2:07 PM
  • another interesting note: If the email is moved from the inbox to a subfolder, then the links show up.  We are testing to see if this will still work with an automated rule..
    Wednesday, July 07, 2010 2:44 PM
  • Quote: “If the email is moved from the inbox to a subfolder, then the links show up”

    I have seen this (Move the problematic messages into PST file) in some cases, and it’s been used as one workaround for this symptom


    James Luo
    TechNet Subscriber Support (http://technet.microsoft.com/en-us/subscriptions/ms788697.aspx)
    If you have any feedback on our support, please contact tngfb@microsoft.com
    Thursday, July 08, 2010 1:29 AM
  • One of our developers made the following comment.

    After digging around a little more and doing some debugging using Macros, I noticed that the email messages that are received show that the BodyFormat is PlainText, which we already knew.  However, the emails have a BodyText field which is all the body as plain text, but it also has a field called HTMLBody in which the plain text email has been converted to HTML.  The conversion has created a hyperlink in the HTML, and so if there is some way to configure Exchange/Outlook so that the receivers can see that HTMLBody instead of plain text body, then it should work.  Here are the contents of HTMLBody:

     

    <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 3.2//EN">

    <HTML>

    <HEAD>

    <META NAME="Generator" CONTENT="MS Exchange Server version 08.00.0681.000">

    <TITLE></TITLE>

    </HEAD>

    <BODY>

    <!-- Converted from text/plain format -->

     

    <P><FONT SIZE=2>Please click on the link below for information on the status of your request:<BR>

    <A HREF="http://webdev1.abc4.gov/training_requests/view_registration.asp?reg_id=36897">http://webdev1.abc4.gov/training_requests/view_registration.asp?reg_id=36897</A><BR>

    Thank you.<BR>

    </FONT>

    </P>

     

    </BODY>

    </HTML>

     

    One thing I was also able to do is create a rule that runs a script for items received from property_request@abc4.gov and the script just saves the message as HTML format.  It works and the link is clickable; however, I doubt it would be a viable solution since Macros have to be enabled, which default behavior is to have them completely disabled. 

     

    So I’m wondering if maybe there is a way to set default type to HTML for emails from specific addresses, and we can provide a list of known addresses?

     

    Our current workarounds are:

    1)forward the email to yourself

    2) edit the email & save it: (right-click -> Messaging options -> Categories & pick one -> OK: Say yes at the message abour the properties of the message being changed.)

    3) Save the message into a .pst file & then put back in main folder. (This appears not to work with subfolders on the exchange server...)

    • Marked as answer by Alan.Gim Tuesday, July 13, 2010 1:51 AM
    • Unmarked as answer by am2o Monday, July 26, 2010 6:54 PM
    Thursday, July 08, 2010 2:36 PM
  • Thanks for sharing the workaround

    As I know, XSO behavior has been changed to create a specific converter object instead of default mode during conversion, Plain-text bodies will not get to convert into a hyperlink


    James Luo
    TechNet Subscriber Support (http://technet.microsoft.com/en-us/subscriptions/ms788697.aspx)
    If you have any feedback on our support, please contact tngfb@microsoft.com
    Monday, July 12, 2010 2:14 AM
  • Interesting thing: We ran a test email from one of the automated systems: and got disaparate results with the same OUtlook client.

     

    Automated System sends plain-text email to an Exchange 2003 Front-End server.

    2003 Front-End server sends to a 2003 backend server; a 2007 Hub Transport server -> 2007 Mailbox server

    Using the same Outlook 2007 update~8 client: and connecting to mailboxes on both the 2003; 2007 servers: The URL shows as a hyperlink on the 2003 server mailbox account, but as a plain-text URL on the 2007 server mailbox account.

    Suggestions?

    Thanks,

    Alex McDiarmid

    (Yes, we have & will maintain our 2003 Front-End servers untill we do a mailbox server consolidation on a remaining 14 domains.)

    Wednesday, July 14, 2010 7:54 PM
  • Quote: “URL shows as a hyperlink on the 2003 server mailbox account, but as a plain-text URL on the 2007 server mailbox account”

    So, the test has proved the behavior change for the content conversion on the exchange 2007 server, right?


    James Luo
    TechNet Subscriber Support (http://technet.microsoft.com/en-us/subscriptions/ms788697.aspx)
    If you have any feedback on our support, please contact tngfb@microsoft.com
    Thursday, July 15, 2010 1:46 AM
  • Eventually, we had to open a support case: Essentially we were told this is a bug not a feature. (Both answers are posted here.)

     

    No resolution is proposed.

    • Marked as answer by am2o Monday, October 04, 2010 9:30 PM
    Monday, October 04, 2010 9:29 PM