locked
WebDAV to SharePoint Online RRS feed

  • Question

  • I am developing a client application that uses WebDAV to put files to SharePoint online. I think I am making good progress here, but I am getting a 302 response that I don't understand. It looks successful, but the response HTML indicates that it has been moved. The link does not work, and I can't find the file on SharePoint online. Any thoughts would be appreciated.

    The request:

    PUT /sites/Demo1/Shared%20Documents/  HTTP/1.1

    Accept: Image/gif, */*

    Accept-Language: en-us

    Translate:  f

    Authorization: Basic abcdefghijklmnop

    Host: MYDOMAIN.COM

    Content-Length:  14

    Content-Type: text/plain

    User-Agent: Mozilla/4.0 (compatible; My application)

    Connection: Keep-Alive

    Cache-Control: no-cache

    Content-Language: en-us

    And here is the response:

    HTTP/1.1 302 Found

    Location: https://mydomain.sharepoint.com/sites/Demo1/_layouts/15/Authenticate.aspx?Source=/sites/Demo1/Shared%20Documents/

    Server: Microsoft-IIS/7.5

    X-SharePointHealthScore: 0

    SPRequestGuid: 202ba59c-7073-1000-6e57-e05844b322f6

    request-id: 202ba59c-7073-1000-6e57-e05844b322f6

    X-Powered-By: ASP.NET

    MicrosoftSharePointTeamServices: 16.0.0.3020

    X-Content-Type-Options: nosniff

    X-MS-InvokeApp: 1; RequireReadOnly

    P3P: CP="ALL IND DSP COR ADM CONo CUR CUSo IVAo IVDo PSA PSD TAI TELo OUR SAMo CNT COM INT NAV ONL PHYPRE PUR UNI"

    Date: Wed, 16 Jul 2014 18:52:56 GMT

    Content-Length: 246

    <html><head><title>Object moved</title></head><body><h2>Object moved to <a href="https://mydomain.sharepoint.com/sites/Demo1/_layouts/15/Authenticate.aspx?Source=/sites/Demo1/Shared%20Documents/">here</a></h2></body></html>




    Patrick Townsend

    Wednesday, July 16, 2014 7:53 PM

All replies

  • The HTTP 302 response is sending the client to the authentication page. Since the uploaded document doesn't end up in the site, my guess is your application isn't authenticating.

    Monday, July 28, 2014 2:46 PM
  • Thanks Jason. I am actually sending an Authorization: HTTP header with valid credentials. Is there another authentication step or setting that is required? Any pointers on this would be appreciated.

    Patrick


    Patrick Townsend

    Monday, July 28, 2014 3:59 PM