Active Sync not Working - Exchange 2013 with Exchange 2007


  • Hi

    Recently we introduced Exchange 2013 servers to our existing Exchange 2007 organization. The servers are just configured with default self-signed certificate and URLs are pointing to server FQDNs. Everything is at default as far as configuration is concerned in Exchange 2013.

    After just introducing the Exchange 2013 CAS servers was checking the ActiveSync functionality using a new mailbox created on Exchange 2013. We have not yet published our Exchange 2013 servers to Internet (before even doing that, want to ensure ActiveSync is working). We're connecting using our Private network and trying to make a connection to CAS FQDN. Checked a iOS7 (iPad) and a Windows Phone device, both of them configure successfully (with the certificate warning, which is obvious) but when it comes to synchronizing the contents they fail saying "Cannot Get Mail. Connection to Server Failed"

    Checked the IIS Logs on CAS server and found that the device makes a successful connection - as is indicated by successful configuration but thereafter nothing happnes on the device and no error logged in Event Viewer as well. Could it be that the mailbox server is denying the to check. How to go ahead with the troubleshooting.

    Everything else expect ActiveSync is working perfectly. Tries accessing the ActiveSync VD using the link HTTPS://Server_FQDN/Microsoft-Server-ActiveSync, this pops-up a window asking for credentials – which is normal behavior indicating ActiveSync virtual directory is good.



    Taranjeet Singh


    Tuesday, September 24, 2013 2:27 PM

All replies

  • Any ideas people.....


    Tuesday, September 24, 2013 8:42 PM
  • Do you get a 501/505 in the browser when you try to open the EAS vdir? (After typing in the credentials.)

    I've got a troubleshooting utility called EAS MD that emulates an ActiveSync Client that you could test:

    It doesn't always pinpoint exactly what the issue is, but hopefully it will return some kind of status code to set you off in the right direction.

    Wednesday, September 25, 2013 8:04 AM
  • Exchange 2013 and Exchange 2007 are in the same site right?

    If yes , better you go "proxy" way for both of this exchange systems.

    Because for Exchange 2013 coexist with Exchange 2007 (EAS) , it's proxy method.
    So this error occur cause Exchange 2013 dont know where can he forward traffic.

    Thing you have to do is.

    1. Internal URL for Active Sync (Exchange 2007) =
        External URL for Active SYNC (Exchange 2007) = blank

    2. External URL for Active SYnc (Exchange 2013) =

    Some kind like this

    Thursday, September 26, 2013 3:16 AM
  • Hey Guys

    Just to update here my initial testing revieled that if I run Test-ActiveSyncConnectivity by not specifying the -URL parameter like this:

    Test-ActiveSyncConnectivity -MailboxCredential (get-credential User1) |FL

     the command fails for an obvious reason as shown in the result. The command is getting the mailbox server name in the ActiveSync URL returned automatically:

    ClientAccessServer          : SITE-MBX-02.ABC.COM

    Scenario                    : Options

    ScenarioDescription         : Issue an HTTP OPTIONS command to retrieve the Exchange ActiveSync protocol version.

    PerformanceCounterName      : DirectPush Latency

    Result                      : Failure

    Error                       : The OPTIONS command returned HTTP 200, but the Exchange ActiveSync header

                                  (MS-Server-ActiveSync) wasn't returned. The request likely did not reach a Client Access

                                  server, either because

                                   - A proxy server intervened (check the headers below for any that may have been

                                  returned by a proxy)

                                   -The virtual directory could not be reached:


                                   - The virtual directory does not point to a Client Access server:


    If however, I manually provide the -URL parameter value with FQDN of CAS server:

    Test-ActiveSyncConnectivity -URL https://SITE-CAS-02.ABC.COM/Microsoft-Server-ActiveSync -MailboxCredential (get-credential User1) |FL

    it succeeds.

    We have our CAS and Mailbox servers installed on separate systems - no colocation.

    This is strange and makes me curious to find out, where does the command without -URL parameter is getting the ActiveSync URL that has mailbox server in it. I checked that the new Exchange 2013 CAS servers have InternalURL parameteres populated with their own FQDNs and the ExternalURL is empty for now.

    Need help in drilling down this further.


    Taranjeet Singh 


    Thursday, September 26, 2013 11:09 PM
  • Please follow this.

    1. Set AutodiscoverInternalURL using this command for every CAS server
    Set-ClientAccessserver -identity -CAS1 -AutodiscoverInternalURI (for FQDN , using your CAS NLB name if exist)

    2. Set OWA virtualdirectoy (2013) via EAC
    Internal URL : External URL :

    3. Set ECP virtualdirectory (2013) via EAC

    Internal URL : External URL :

    4. Set OAB virtualdirectory (2013) via EAC

    Internal URL : External URL :

    5. Set EWS virtualdirectory (2013) via EAC

    Internal URL : External URL :

    6. Set ActiveSync virtualdirectory (2013) viaEAC

    Internal URL :

    External URL :


    For 2007

    1. Set AutodiscoverInternalURL using this command for every CAS server
    Set-ClientAccessserver -identity -CAS1 -AutodiscoverInternalURI (for FQDN , using your CAS NLB name)

    2. Create DNS record = your CAS2007 NLB (if exist)

    3. Set OWA virtualdirectory (2007) via EMC

    External URL =

    4. Set ActiveSync (2007) via EMC

    Internal URL = https://serverFQDN/Microsoft-Active-Sync   <<<< Using for proxy

    External URL = <<<< Using for redirect

    5. OAB via EMC

    External URL =

    6. EWS via Exchange shell

    External URL =


    Monday, September 30, 2013 8:08 AM
  • I am not sure if this ever found a resolution, but I am having the same problem and error. We have a 2007 and 2013 coexistence and we have actually already cut client access through the 2013 CAS proxy. None of the users have been migrated yet but OWA, autodiscover, EWS, and client connections are all perfectly OK. However ActiveSync is failing and I get the exact same error that Taranjeet is getting when I run test-activesyncconnectivity. The odd thing is that none of the users on 2007 have a problem it is only our test accounts that are on 2013 that fail activesync. 

    I have verified all virtual directories and the configuration all looks correct. It seems like there is something in IIS that is not forwarding the request correctly to the MBX server although the IIS logs look OK. Are there any better answers out there other than double checking the virtual directories?

    Thursday, January 30, 2014 7:25 PM
  • Any solution to this? Having the same problem here.
    Thursday, February 06, 2014 1:47 PM