locked
Reply-To Address is not used bei Out of office replies

    Question

  •  

    Hi everybody,

     

    it seems, that Out of office answers are using the "from" email address for sending the out of office message instead of the mail address in the "reply-to" header (if there is one). When using "answer" in Outlook, it works like expected - the answer goes to the address in "reply-to". This happens with Exchange 2007 SP1 und Outlook 2007 SP1. The problem is, that in our scenario, the "from" address is a "no reply" address and the "reply-to" header contains the mail address of the person which should get the reply. For spam filter and security reasons, the users mail address cannot be used as the "from" address.

     

    Does anybody have a suggestion, how to solve the problem?

     

    Cheers,

    Thomas

    Wednesday, May 07, 2008 12:33 PM

All replies

  •  

    Hi Thomas,

     

    I would like to explain that by default, if we sent a following email to a user:

     

    Mail from: UserA@domain.com

    Rcpt to:  UserC@domain.com

    Data

    From: UserB@domain.com

    To: UserC@domain.com

    Subject: XXXXX

     

    By default, the Out of Office email will be replied to the UserB@domain instead of UserA@domain. After reviewing your description, I  want to confirm whether you would like to replace the UserB@domain.com address by using the UserA@domain.com address when send the Out of Office message.

     

    Mike

     

    Friday, May 09, 2008 11:40 AM
  • Hi all,

    I just ran into the same issue as Thomas described.

    I have an email in format

    From: userA@domain.com
    To: userB@domain.com
    Reply-To: userC@domain.com
    Subject: XXXX

    When I receive such an email in outlook and click on reply, the new mail will be sent to userC@domain.com. That's expected behaviour, because Reply-To header is set.

    However when I have my Out of Office message turned on, the email will be sent to userA@domain.com, completely ignoring the Reply-To header.

    Is this a feature or bug?

    Thanks for replies,

    Jan
    Friday, June 06, 2008 3:16 PM
  •  

    Jan,

     

    we are currently playing around with setting "Sender", "From" and "Reply-To" using the .NET MailMessage Class.

     

    How are you sending your mails?

     

    Cheers,

    Thomas

    Friday, June 06, 2008 3:20 PM
  • I am sending them from an intranet application written in PHP. But it should not matter. The key issue is that Outlook seems to not consider the Reply-To header when sending out-of-office replies. When normal reply is to be sent, it uses reply-to address as expected..
    Friday, June 06, 2008 3:25 PM
  • Maybe it's not Outlook, but Exchange which is behaving unexpected .... which Version of Exchange do you have?

     

     

    Friday, June 06, 2008 3:27 PM
  • Yes, I think you're right I wrote it wrong. It's Exchange who sends the oo replies. We have version 2003 (think it's 6.5).

    Did you found any solution so far?
    Friday, June 06, 2008 3:40 PM
  • as mentioned  - we will try to use "From" and "Sender" of the .NET MailMessage Class.

     

    I just called my developer collegue - he is setting the "From" header as the Address, which should get the reply and "Sender" header to the "technical" address - see http://tools.ietf.org/html/rfc2822 (Search for "From:") - now it works - in our case! But I think, Exchange should also benefit the "reply-to:" (regarding to the rfc) - so I think, it's definitely a bug in Exchange (we use Exchange 2007 SP1). I also found a KB Entry, where it's written, that Exchange 2003 does not behave as expected, when the sender is outside the exchange organization .... but in absence of Exchange 2003 I could not verify.

     

    cheers,

    Thomas

     

     

      Name Description
    AlternateViews Gets the attachment collection used to store alternate forms of the message body.
    Attachments Gets the attachment collection used to store data attached to this e-mail message.
    Bcc Gets the address collection that contains the blind carbon copy (BCC) recipients for this e-mail message.
    Body Gets or sets the message body.
    BodyEncoding Gets or sets the encoding used to encode the message body.
    CC Gets the address collection that contains the carbon copy (CC) recipients for this e-mail message.
    DeliveryNotificationOptions Gets or sets the delivery notifications for this e-mail message.
    From Gets or sets the from address for this e-mail message.
    Headers Gets the e-mail headers that are transmitted with this e-mail message.
    IsBodyHtml Gets or sets a value indicating whether the mail message body is in Html.
    Priority Gets or sets the priority of this e-mail message.
    ReplyTo Gets or sets the ReplyTo address for the mail message.
    Sender Gets or sets the sender's address for this e-mail message.
    Subject Gets or sets the subject line for this e-mail message.
    SubjectEncoding Gets or sets the encoding used for the subject content for this e-mail message.
    To Gets the address collection that contains the recipients of this e-mail message.

     

     

     

     

    Friday, June 06, 2008 3:56 PM
  • Thanks for the suggestion.

    I appear to have found a solution without using the Sender: field. It seems (according to RFC3834), that fields Auto-Submitted: and Precedence: are allowed to be used in an e-mail.

    They are designed to regulate automatic responses. However, Exchange does not handle Auto-Submitted (which is a standard), but a Precedence header (which is non-standard, but allowed to be used).

    So I set Precedence: bulk to my automatically created e-mails and I don't get any automatical replies from the 2003 Exchange.
    Friday, June 06, 2008 4:08 PM
  • Hi Tommy,

    Do you happen to have the number of the KB article please?
    Friday, June 20, 2008 3:09 AM