none
Enable Anonymous relay in exchange 2007 RRS feed

  • Question

  • Hi, for all the experts, i have a exhange 2007 in CCR environment, and i need to allow that from Linux server send mail using the exchange server connection without creat a mailbox account or authenticate against exchange 2007, just only allow anonymous relay. I'm following the technet's procedure create a receive connect in both hub transport sever member of the CCR environmet... that was very easy, but when i testing to send mail by command using telnet servername 25   i still having this message error....

    530 5.7.1 Client was not authenticated


    In receive connector i've configured Anonymous group for Autorized Group and authtentication i've selected basic Authentication... additional to create the connector i've made this process


    Get-ReceiveConnector “Receive Connector Name” | Add-ADPermission -User “NT AUTHORITY\ANONYMOUS LOGON” -ExtendedRights “Ms-Exch-SMTP-Accept-Any-Recipient”


    someone can help me 

    Thanks a lot

    Fabian
    Saturday, June 20, 2009 4:35 PM

Answers

  • Create a receive connector on one of the hub transport servers or both and allow for anonymous Relay from the IP address of the Linux server.

    See this article for details:

    Allowing application servers to relay off Exchange Server 2007:
    http://msexchangeteam.com/archive/2006/12/28/432013.aspx

    SF - MCITP:EMA, MCTS
    • Proposed as answer by Xiu Zhang Tuesday, June 23, 2009 3:43 AM
    • Marked as answer by Xiu Zhang Friday, July 3, 2009 9:28 AM
    Monday, June 22, 2009 1:54 PM
  • Check to see if you have externally secured checked in the receive connector and that the IP address of the solaris 10 box is entered in the Receive connector.  It may actually be hitting another rule on the Exchagne serve rso you could configure a new IP address and tell Exchange to listen on that IP address rather then all IP addresses.

    Another thing you could try to do is telent from the Solaris 10 box to port 25 on the Exchange server and see what happens.


    SF - MCITP:EMA, MCTS
    • Marked as answer by Xiu Zhang Friday, July 3, 2009 9:27 AM
    Tuesday, June 23, 2009 4:19 PM

All replies

  • Hi,

    If you trust this server and want it to anonymous relay using exchange 2007. Follow these steps.

    1. Delete any existing connector created for this purpose.

    2. Create a new  Receive connector, on the introduction page, enter name and select custom.

    3. Click Next on local network settings page.

    4. Add the IP address of Linux server on Remote Network Settings page.

    5. Click Next and then Finish.

    6. Go to the properties and then permission groups tab and select Anonymous users and Exchange servers.

    7. Go to Authentication tab and make sure only Transport Layer Security (TLS) and Externally Secured (for example, with IPsec). is selected.


    And you are done.

    Hth.

    -V

    • Proposed as answer by ismail yilmaz Monday, June 22, 2009 1:57 PM
    Sunday, June 21, 2009 9:03 AM
  • Create a receive connector on one of the hub transport servers or both and allow for anonymous Relay from the IP address of the Linux server.

    See this article for details:

    Allowing application servers to relay off Exchange Server 2007:
    http://msexchangeteam.com/archive/2006/12/28/432013.aspx

    SF - MCITP:EMA, MCTS
    • Proposed as answer by Xiu Zhang Tuesday, June 23, 2009 3:43 AM
    • Marked as answer by Xiu Zhang Friday, July 3, 2009 9:28 AM
    Monday, June 22, 2009 1:54 PM
  • I did these step and they worked from windows, Linux and solaris 9, but when i'm trying to get connecto from solaris 10 it doesn't work why is differet between platform?
    Tuesday, June 23, 2009 3:47 PM
  • The situation is like that, i have a new solaris 10 server, with a application and i want to test the anonymous relay from this server to exchange 2007 in CCR, now i've made many test from linux, windows and solaris 9 too, but with the new solaris 10 server trying by telnet command connectio to 25 port in exchange i'm still having this error
    Unable to Relay

    why it work for the antiguos solaris 9 server and doesn't work in new solaris 10.

    Thansk a lot for you help.

    Fabian
    Tuesday, June 23, 2009 3:57 PM
  • Check to see if you have externally secured checked in the receive connector and that the IP address of the solaris 10 box is entered in the Receive connector.  It may actually be hitting another rule on the Exchagne serve rso you could configure a new IP address and tell Exchange to listen on that IP address rather then all IP addresses.

    Another thing you could try to do is telent from the Solaris 10 box to port 25 on the Exchange server and see what happens.


    SF - MCITP:EMA, MCTS
    • Marked as answer by Xiu Zhang Friday, July 3, 2009 9:27 AM
    Tuesday, June 23, 2009 4:19 PM