none
There was an error while performing this operation

    Question

  • Hi Everyone:

    I get this popup, when access the directory virtual: Exchange, ExchWeb y Public:

    There was an error while performing this operation

    Details Filename \\?\C:\Program Files\Microsoft\Exchange\Server\V14\ClientAcess\Owa\web.config
    Line 37
    Error:Configuration section not allowed to be set below application

    "<?xml version="1.0" encoding="utf-8"?>
    <configuration>
      <location inheritInChildApplications="false">
        <system.net>
            <defaultProxy>
                <proxy usesystemdefault="true" bypassonlocal="true" />
                <bypasslist>
                    <add address=".*" />
                </bypasslist>
            </defaultProxy>
        </system.net>
        <system.webServer>
            <httpProtocol>
                <customHeaders>
                    <add name="X-UA-Compatible" value="IE=EmulateIE7" />
                </customHeaders>
            </httpProtocol>

            <!-- OWA HTTP Modules -->
            <modules>
                <add type="Microsoft.Exchange.Clients.Owa.Core.OwaModule, Microsoft.Exchange.Clients.Owa" name="OwaModule" />
                    <add name="exppw" />
            </modules>
            <handlers>
                <add verb="POST,GET" path="*.owa" type="Microsoft.Exchange.Clients.Owa.Core.OwaEventHandlerFactory, Microsoft.Exchange.Clients.Owa" name="OwaEventHandler" preCondition="managedHandler" />
                <add verb="GET,HEAD" path="attachment.ashx" type="Microsoft.Exchange.Clients.Owa.Core.AttachmentHandler, Microsoft.Exchange.Clients.Owa" name="AttachmentHandler" preCondition="managedHandler" />
                <add verb="GET,HEAD" path="*.ics" type="Microsoft.Exchange.Clients.Owa.Core.HttpHandlerICal, Microsoft.Exchange.Clients.Owa" name="ICalHttpHandler" preCondition="managedHandler" />
            </handlers>
            <security>
                <requestFiltering>
                    <requestLimits maxAllowedContentLength="35000000" />
                </requestFiltering>
            </security>
        </system.webServer>    # Line 37
        <system.web>
            <httpRuntime maxRequestLength="35000" />
            <authentication mode="Windows" />
            <sessionState mode="Off" />

            <globalization requestEncoding="utf-8" responseEncoding="utf-8" />

            <customErrors mode="On" defaultRedirect="auth/error.aspx" />

            <trace enabled="false" requestLimit="10" pageOutput="false" traceMode="SortByTime" localOnly="true" />

            <pages enableSessionState="false" enableViewState="false" enableViewStateMac="false" autoEventWireup="false" smartNavigation="false" validateRequest="false" />

            <compilation defaultLanguage="c#" debug="false">

                <assemblies>" # Line 54

    Exchange 2010 Sp1 + RU 2

    Windows 2008 R2 Enterprise.

    Anybody know what happend...?

    tks.

     


    migrations
    Sunday, January 16, 2011 8:44 PM

Answers

All replies

  • I investigated and i found this post. http://msexchangeteam.com/archive/2010/02/10/453991.aspx

    so, when I tried to connect  (https://exserver/public/) and  (https://exserver/exchange/), I recieve this warning:

    " Event code: 3008
    Event message: A configuration error has occurred.
    Event time: 1/18/2011 10:37:08 AM
    Event time (UTC): 1/18/2011 2:37:08 PM
    Event ID: b46ca24d3c9441d2a0098b5ac99c8cb1
    Event sequence: 2
    Event occurrence: 1
    Event detail code: 0
     
    Application information:
        Application domain: /LM/W3SVC/1/ROOT-1-129398350277504965
        Trust level: Full
        Application Virtual Path: /
        Application Path: C:\inetpub\wwwroot\
        Machine name: SERVER
     
    Process information:
        Process ID: 10132
        Process name: w3wp.exe
        Account name: IIS APPPOOL\DefaultAppPool
     
    Exception information:
        Exception type: ConfigurationErrorsException
        Exception message: It is an error to use a section registered as allowDefinition='MachineToApplication' beyond application level.  This error can be caused by a virtual directory not being configured as an application in IIS. (C:\Program Files\Microsoft\Exchange Server\V14\ClientAccess\Owa\web.config line 37)
     
    Request information:
        Request URL: https://XXX.XXX.XXX:443/exchange/default.aspx
        Request path: /exchange/default.aspx
        User host address: XXX.XXX.XXX.XXX
        User: 
        Is authenticated: False
        Authentication Type: 
        Thread account name: IIS APPPOOL\DefaultAppPool
     
    Thread information:
        Thread ID: 1
        Thread account name: IIS APPPOOL\DefaultAppPool
        Is impersonating: False
        Stack trace:    at System.Configuration.ConfigurationSchemaErrors.ThrowIfErrors(Boolean ignoreLocal)
       at System.Configuration.BaseConfigurationRecord.GetSectionRecursive(String configKey, Boolean getLkg, Boolean checkPermission, Boolean getRuntimeObject, Boolean requestIsHere, Object& result, Object& resultRuntimeObject)
       at System.Configuration.BaseConfigurationRecord.GetSection(String configKey)
       at System.Web.Configuration.RuntimeConfig.GetSectionObject(String sectionName)
       at System.Web.Configuration.RuntimeConfig.GetSection(String sectionName, Type type, ResultsIndex index)
       at System.Web.Configuration.RuntimeConfig.get_Identity()
       at System.Web.HttpContext.SetImpersonationEnabled()
       at System.Web.HttpRuntime.ProcessRequestNotificationPrivate(IIS7WorkerRequest wr, HttpContext context)
     
     
    Custom event details:
    "

    the post up

    _____________________

                             </system.webServer>    

                            <system.web>
                                  <httpRuntime maxRequestLength="35000" />
    Linea 37                           <authentication mode="Windows" />
                                <sessionState mode="Off" />

    ___________________________

    "

    sswift said:

    More than likely there is another configuration in the applicationhost.config file or another web.config file in place that causing conflict and ultimately the /public to fail.
    Check through the web.config file under the OWA Directory and check the applicationhost.config file to ensure that the section on /public only has the authentication mechanisms and entries as listed above.
    Compare it to the /exchweb, they should be the same.
    "

    I recreated the legacy virtual directory (Exchange, ExchWeb, Public) but nothing.

    _________

    "More than likely there is another configuration in the applicationhost.config file or another web.config file in place that causing conflict and ultimately the /public to fail. "

    __________

    But where?.

    Any idea? pls and tks for your help.

     


    migrations
    Tuesday, January 18, 2011 2:57 PM
  • I forgot this message in IE.:

    Runtime Error

    Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed remotely (for security reasons). It could, however, be viewed by browsers running on the local server machine.

    Details: To enable the details of this specific error message to be viewable on remote machines, please create a <customErrors> tag within a "web.config" configuration file located in the root directory of the current web application. This <customErrors> tag should then have its "mode" attribute set to "Off".

    <!-- Web.Config Configuration File -->
    
    <configuration>
      <system.web>
        <customErrors mode="Off"/>
      </system.web>
    </configuration>

    Notes: The current error page you are seeing can be replaced by a custom error page by modifying the "defaultRedirect" attribute of the application's <customErrors> configuration tag to point to a custom error page URL.

    <!-- Web.Config Configuration File -->
    
    <configuration>
      <system.web>
        <customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>
      </system.web>
    </configuration>


    migrations
    Tuesday, January 18, 2011 3:04 PM
  • well, nobody know the answer : ,) , but this post http://briandesmond.com/blog/small-update-to-redirection-blog/ help me, the problem persist, but the redirect owa, it ok, I will continue  investigating if i know something tell them.

     

    tks.


    migrations
    • Marked as answer by mirk23 Wednesday, January 19, 2011 2:23 PM
    Wednesday, January 19, 2011 2:22 PM