locked
Upgrade to Exchange 2010 SP3 Failed at Hub Transport RRS feed

  • Question

  • HELP!!! I am experiencing challenges upgrading from Exchange 2010 SP2 RU6 to Exchange 2010 SP3.

    Every attempt fails during the HUB Transport Role installation.

    Exchange is running on Windows 2008R2 SP1. 

    Below if the Error Portion form the exchange Setup Logs

    [04/10/2013 02:48:11.0768] [1] [ERROR] The following error was generated when "$error.Clear(); 
              $vdirName = "PowerShell (Default Web Site)";
              $proxyVdirName = "PowerShell-Proxy (Default Web Site)";
              $InternalPowerShellUrl="http://" + $RoleFqdnOrName + "/powershell";
              $vdir = get-PowerShellVirtualDirectory -server $RoleFqdnOrName -DomainController $RoleDomainController | where { $_.Name -eq $vdirName };
              $proxyVdir = get-PowerShellVirtualDirectory -server $RoleFqdnOrName -DomainController $RoleDomainController | where { $_.Name -eq $proxyVdirName };
              
              if ($vdir -ne $null -or $proxyVdir -ne $null)
              {
                update-PowerShellVirtualDirectoryVersion -DomainController $RoleDomainController;
              }

              if ($vdir -eq $null)
              {
                $vdirName = "PowerShell";
                new-PowerShellVirtualDirectory $vdirName -InternalUrl $InternalPowerShellUrl -DomainController $RoleDomainController -BasicAuthentication:$false -WindowsAuthentication:$false -RequireSSL:$false;
              }
              else
              {
                Set-PowerShellVirtualDirectory $vdirName -InternalUrl $InternalPowerShellUrl -DomainController $RoleDomainController -WindowsAuthentication:$false -RequireSSL:$false;
              }

              if ($proxyVdir -eq $null)
              {
                $proxyVdirName = "PowerShell-Proxy";
                new-PowerShellVirtualDirectory $proxyVdirName -DomainController $RoleDomainController -BasicAuthentication:$false -WindowsAuthentication:$true -RequireSSL:$true -AppPoolId "MSExchangePowerShellProxyAppPool" -Path ($RoleInstallPath + "ClientAccess\PowerShell-Proxy");
              }
              else
              {
                Set-PowerShellVirtualDirectory $proxyVdirName -DomainController $RoleDomainController -WindowsAuthentication:$true -RequireSSL:$true;
              }
            " was run: "A failure occurred while trying to update metabase properties.".
    [04/10/2013 02:48:11.0768] [1] [ERROR] A failure occurred while trying to update metabase properties.
    [04/10/2013 02:48:11.0768] [1] [ERROR] The system cannot find the path specified.

    [04/10/2013 02:48:11.0768] [1] [ERROR-REFERENCE] Id=PowerShellComponent___0933481a46d24e77abfdf174e8240b80 Component=EXCHANGE14:\Current\Release\Shared\Datacenter\Setup
    [04/10/2013 02:48:11.0768] [1] Setup is stopping now because of one or more critical errors.
    [04/10/2013 02:48:11.0768] [1] Finished executing component tasks.
    [04/10/2013 02:48:11.0815] [1] Ending processing Install-BridgeheadRole

    Wednesday, April 10, 2013 3:40 AM

Answers

  • Thanks Terence Yu, The upgrade was successful. 

    Based on your advise I did the below....

    Look at the HTTP protocol setting in ADSIEDIT.msc. 

    1. Open adsiedit.msc in an elevated command prompt, connect to a domain controller and set the connection point to configuration vice default. 

    2. Navigate to services\microsoft exchange\Admin groups\exchange admin group\servers\ then find the server name of the server you are working on and then click Protocols\ HTTP and see is the virtual directory is listed there.  If so delete it.

    3. Then check your IIS manager for that directory and delete it if it is there. 

    4. From a command prompt run IISRESET and wait for it to finish. 

    5. Then you may have to remove the water mark and action keys in the registry, to allow you to reinstall SP3, by going through regedit then navigate to HKLM\software\microsoft\exchangeserver\V14 and look for the client access role folder.

    After doing the above.. I was able to upgrade to SP3... Pending my Migration to exchange 2013...

    Thanks again Terence

    • Proposed as answer by BrianXtium Thursday, July 18, 2013 9:16 PM
    • Marked as answer by loadedleke Friday, July 19, 2013 5:54 AM
    Tuesday, April 16, 2013 8:10 AM
  • Hi
       Can you remove "powershell-proxyvirtualdirectory" and install sp3 again.

    Terence Yu

    TechNet Community Support

    • Marked as answer by loadedleke Tuesday, April 16, 2013 8:07 AM
    Friday, April 12, 2013 2:22 AM

All replies

  • hi,

    in the log it shows that the issue is related to power shell virtual directory, make sure you have the power-shell virtual directory in the IIS and check you can launch shell or EMC from your exchange 2010 sp2(without updating to sp3) if you get any error let us know.

    Regards

    Viman

    Wednesday, April 10, 2013 4:41 AM
  • I verified that I can launch Exchange Powershell and EMC on the Exch 2010 SP2..


    Wednesday, April 10, 2013 3:35 PM
  • Glad to hear that it's working.

    Share your solution, this will help others.


    OM (MCITP) | Blog

    Wednesday, April 10, 2013 3:40 PM
  • The Upgrade to Exch 2010 SP2 was seamless and require no intervention... My post is regarding upgrade to Exch 2010 SP3 which has nto been successful.. 

    I observed another thread with similar issue I posted and still not resolved...

    Wednesday, April 10, 2013 3:45 PM
  • Hi
       Can you remove "powershell-proxyvirtualdirectory" and install sp3 again.

    Terence Yu

    TechNet Community Support

    • Marked as answer by loadedleke Tuesday, April 16, 2013 8:07 AM
    Friday, April 12, 2013 2:22 AM
  • Thanks Terence Yu, The upgrade was successful. 

    Based on your advise I did the below....

    Look at the HTTP protocol setting in ADSIEDIT.msc. 

    1. Open adsiedit.msc in an elevated command prompt, connect to a domain controller and set the connection point to configuration vice default. 

    2. Navigate to services\microsoft exchange\Admin groups\exchange admin group\servers\ then find the server name of the server you are working on and then click Protocols\ HTTP and see is the virtual directory is listed there.  If so delete it.

    3. Then check your IIS manager for that directory and delete it if it is there. 

    4. From a command prompt run IISRESET and wait for it to finish. 

    5. Then you may have to remove the water mark and action keys in the registry, to allow you to reinstall SP3, by going through regedit then navigate to HKLM\software\microsoft\exchangeserver\V14 and look for the client access role folder.

    After doing the above.. I was able to upgrade to SP3... Pending my Migration to exchange 2013...

    Thanks again Terence

    • Proposed as answer by BrianXtium Thursday, July 18, 2013 9:16 PM
    • Marked as answer by loadedleke Friday, July 19, 2013 5:54 AM
    Tuesday, April 16, 2013 8:10 AM
  • Thank you, this helped me out with a problem when trying to upgrade from SP2 to SP3.
    Thursday, July 18, 2013 9:17 PM