locked
MapiExceptionADNotFound When Creating a new Mailbox Database, No such error on the internet RRS feed

  • Question

  •  

    HI

    I have a problem that is when I create a new Mailbox Database I face the Error

     

    Failed

    Error:
    Exchange is unable to mount the database that you specified. Specified database: EMAIL\Second Storage Group\EmailData; Error code: MapiExceptionADNotFound: Unable to mount database. (hr=0x80004005, ec=2417)
    .
    Exchange Management Shell command attempted:
    mount-database -Identity 'CN=EmailData,CN=Second Storage Group,CN=InformationStore,CN=EMAIL,CN=Servers,CN=Exchange Administrative Group (FYDIBOHF23SPDLT),CN=Administrative Groups,CN=First Organization,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=Domain,DC=com'
    Elapsed Time: 00:00:00
     
    I have this server exchange 2007 SP1 running on Server 2003 SP2 R2 64-Bit
    its also additional exchange to the old ex server 2003 SP2
    what is this error
     
    I check the evenlog and there is NO related error for this
    and I ran EXPBA and it report no problem
     
    I search MSN and Google for this and nothing usefull found
     
    what shell I do
    I am a fried that the Main database may fail if this present
    Monday, February 18, 2008 10:51 PM

All replies

  •  

    HI me

    how arey you .. I hope fine..

    this is the answer

    this seem to be one of bug in the exchange server 2007

    to fix it

    just and simply dont let the wizard to mount the database when you finish creating it

    aftter closing the wizard mount it and it will work fine

    See

    easy

     

    Friday, February 29, 2008 12:12 AM
  • Having the same issue as the OP, running E2007 SP1 and W2003 R2 SP2 x64.  Your fix is not working for me.

     

    Being that I'm an admitted GUI addict, I've been trying to create this new DB solely through EMC so far, but am about to try this through power shell as soon as I manage to validate the syntax that EMC is spitting out.

     

    Any other suggestions to resolve this?

     

    Thanks,

    Adam

    Thursday, March 6, 2008 7:33 PM
  •  

    Having the same issue as the original poster, running Exchange 2007 SP1 on Server 2003 R2 x64 SP2.  The proposed fix did not work for me.

     

    I have only tried creating the new database through the EMC so far, but will be trying this through Power Shell as soon as I validate the syntax that the EMC is generating.

     

    Any other suggestions on a fix for this issue?

     

    Thanks.

    Thursday, March 6, 2008 7:47 PM
  •  

    HI

    Would you please tell us the result of using the EMS

    and also what is the eventlog\application report

     

    Saturday, March 8, 2008 9:52 PM
  • I had the same problems - when DB was created using Wizard from Exchange Management Console it reports an error on mount procedure. When the same DB is created from Power Shell (Exchange Management Shell) - mount procedure complete succesfully.

    Here is my PS log:

    [PS] Z:\>New-MailboxDatabase -Name "Lucky DB" -StorageGroup "Lucky SG"


    Name                 Server          StorageGroup         Recovery
    ----                 ------          ------------         --------

    Lucky DB             EXCHA02         Lucky SG             False


    [PS] Z:\>Mount-Database -Identity "
    Lucky DB"

    P.S.
    IMHO: Console has some errors, when you face a problem using it - try Power Shell, in most cases it solves a problem.

    • Proposed as answer by osr_MVP Wednesday, February 1, 2012 7:31 AM
    Wednesday, May 28, 2008 1:29 PM
  • In my experience this is caused by Active Directory replication. If the change has not completely replicated into the Configuration partition of AD then the DB will not mount. I wait a few miniutes for replication to take place and then mount it.

    Give it a shot and see if that helps.

    Josh
    • Proposed as answer by NicB Van Wednesday, October 31, 2012 5:54 PM
    Thursday, May 29, 2008 2:22 AM
  • Hi

    Would you please port what Eventlog\Application report when you try to mont the database

    and please tell us about your network infra.

     

     

    Saturday, May 31, 2008 7:10 PM
  • Well maybe more than one has solved this problem, but i will give u this feedback to new ones...Definitively non of answers above solve the problem, finally i have tu use de Exchange Management Shell usind this cmdlet mount-database -identity servername\database. this mount the databse sucesfully. It happens when i create a PF databse.

     

    Hope this Help!

    Thursday, September 11, 2008 5:48 PM
  • I faced the same problem But waited for 15 minutes and tried again. The database was mounted without any issues, as the error code " mapiexceptionADnotfound ", it has something to do with the AD replication/updates.

     

    -Ravikumar.K

    Tuesday, September 16, 2008 4:33 PM
  • If you have Scalable Networking Pack (SNP) installed, please apply the fix mentioned in http://support.microsoft.com/kb/948496/. Please make sure you test this in non-production environment first.

     

    The problem can also occur if the write happens on different Domain Controller than read. This causes the mount to fail as replication has not completed between two DCs. You can verify read/write using netmon trace to see if it is going to same DC or different DCs.

     

    If netmon confirms that read and write happens on the same DC, Active Directory configuration and setup may be incomplete or changed since initial preparation.

     

    If this is the case run setup.com /prepareAD /domaincontroller:<fqdn of GC>

    Tuesday, September 16, 2008 5:50 PM
  • I had this same error any time I created a new mailbox db under a new Storage Group.  Eventually I found that restarting the Microsoft Exchange System Attendant service replicated the needed directory information and in turn allowed me to mount the database immediately without having to restart the server or take down users connections to the existing databases.
    Thursday, September 18, 2008 5:35 PM
  • Restarting SA may not be possible at all the stuations.. we should not do that... Thats my personal openion.

     

    Thursday, September 18, 2008 5:37 PM
  • Yep, all situations are different; in my environment restarting this service is not an issue.  Can you elaborate on the issues you might have when restarting the SA service?  Just saying 'We should not do that' does not give us much.
    Thursday, September 18, 2008 6:02 PM
  • I am curious if you have SNP enabled as I mentioned above.

     

    Thursday, September 18, 2008 6:14 PM
  • We do not currently have the SNP enabled in our production environment.  I have installed it in our test environment and will see if the issue occurs as you stated.
    Thursday, September 18, 2008 7:27 PM
  • The problem here is 100% replication, if you don't have the 9518 and 9519 errors.

    Wait for AD to replicate. I'm going to bet your mailbox servers are reading from one DC and writing to another. Netmon would tell you for sure.

    Wait 15 minutes, or force replication, and your problem will go away - it did for me!
    Saturday, December 20, 2008 3:57 AM
  • As Jason said it is AD replication..just force replication between domain controllers.
    Capecol MCSA - MCTS Exchange Server 2007
    Saturday, June 27, 2009 3:37 PM
  • This solution works in my case . Thanks Expert .......

    Wednesday, March 2, 2011 5:49 PM
  • Force replication betwenn Domain Controllers.

    Article in PT-BR:

    http://www.wellingtonagapto.org/2014/07/mapiexceptionadnotfound-unable-to-mount-database-hr-0x80004005-ec-2417-Exchange-Server-2007.html 

    Wellington Agápto
    Consultor de Comunicações Unificadas & Mobilidade
    ITIL, CCNA, MCP, MTA, MCITP, MCTS, MCSA, MCSE Communication
    Edefense Segurança Digital
    Site: http://www.edefense.com.br
    Blog: http://www.wellingtonagapto.org

    Wednesday, July 23, 2014 11:08 PM