locked
MSExchangeSA: The clocks on the client and server machines are skewed RRS feed

  • Question

  • The weird error happens on the mailbox servers from time to time:
    System attendant fails to start with an error, "
    Unexpected error The clocks on the client and server machines are skewed. ID no: 80090324 Microsoft Exchange System Attendant occurred."

    The clocks are synchronized on all servers and domain controllers.

    The workaround I use now is to restart MSExchangeADTopology service (which, alas, requires restart for all the exchnage services).

    Two questions:
    1) Is this a known bug? Is it going to be fixed?
    2) Is MSExchangeADTopology dependency going to be removed in the RTM? I was so glad when System Attendant dependency was removed in E12, but in E14 we have got another single point of failure service. I have a feeling it will cause a lot of pain in the future.

    Wednesday, April 29, 2009 6:33 PM

All replies

  • Anatoly,  I have not seen this particular issue on any of my Exchange 2010 servers, however I have seen similiar issues in the past with Exchange.  One item I found before that could cause this is that the clocks all seem to be the same time, but are set to different timezones. 
    Gary A. Cooper | Senior Systems Architect | MCA:Exchange2003 | MCM:Exchange2003/2007 | Horizons Consulting, Inc.
    • Proposed as answer by garyc007 Thursday, April 30, 2009 1:43 AM
    • Unproposed as answer by Anatoly Ivanov Thursday, April 30, 2009 3:03 AM
    Thursday, April 30, 2009 1:12 AM
  • It happenes if there is any time sync issue with the domain and member server which is running exchange


    Details
    Product: Exchange
    Event ID: 2060
    Source: MSExchangeSA
    Version: 8.0
    Symbolic Name: evtDsProxyErrorStarted
    Message: The DSProxy failed to start, error '%1'.
       
    Explanation

    This event indicates that the server that is running Microsoft Exchange Server may be unable to contact a Domain Controller. Alternatively, the Exchange server time may be out of sync with the Domain Controller time.

       
    User Action

    To resolve the error, follow these steps:

    • Make sure that the Exchange server has network connectivity with the Domain Controller.

    • Synchronize the Exchange server time with either the Domain Controller time or the time server that is used by the Domain Controller.

    • Try to start the Microsoft Exchange System Attendant.

     

    Note  If you are not already doing so, consider running the tools that Microsoft Exchange offers to help administrators analyze and troubleshoot their Exchange environment. These tools can help you make sure that your configuration is in line with Microsoft best practices. They can also help you identify and resolve performance issues, improve mail flow, and better manage disaster recovery scenarios. Go to the Toolbox node of the Exchange Management Console to run these tools now. For more information about these tools, see Toolbox in the Exchange Server 2007 Help.


    Arun Kumar | MCSE - 2K3 + Messaging | ITIL-F V3
    Thursday, April 30, 2009 1:28 AM
  • Hi Ivanov ,

    This error may be happen is there time,Date and TIme ZOne difference between Exchange server and Domain controller.
    Please check Windows Time services waether start on both servers.If it's stoped start Windows time and change the time,date and time zone according to your location.


    Regards


    Chinthaka | If you think my thread is helpful, Please vote.
    Thursday, April 30, 2009 1:31 AM
  • Thank you, I know that.
    This is why I mentioned the time is *NOT* skewed (I also checked the dates and timezones).
    Also, the problem disappears after restarting MSExchangeADTopology,which makes me suspect this is the root of the problem.

    I guess I have quite complex AD configuration - 4 AD sites across the continent, 6 domain controllers (again, all 6 have the correct time, date and timezone).

    Guys from MSFT - any comments?
    Thursday, April 30, 2009 3:02 AM

  • Are you running the local DCs or the Exchange 2010 servers on a virtual platform? If they are both virtualized are they on the same host or different hosts?
    I have seen similar issues appear if you are running on a virtualization platform and your clock sync settings are not consistent. 


     
    Joel Stidley | Microsoft Exchange MVP | http://exchangeexchange.com
    Thursday, April 30, 2009 4:46 AM
  • I agree with Joel, It happens when you are in virtualized environment and clock sync settings are not consistent
    Arun Kumar | MCSE - 2K3 + Messaging | ITIL-F V3
    Thursday, April 30, 2009 4:42 PM
  • Hi Shamaeera,

    You are kidding, right?
    Thursday, April 30, 2009 6:54 PM
  • Guys, you are correct - almost every host is a VM.
    However, the VMs do not synchronize the clock against the hosts, and hosts are running ntpd anyway.
    And again - I checked the clock, the time was correct all over the place.

    Thursday, April 30, 2009 6:58 PM
  • Was there any updates on this issue.  I am having the same problem with E2K7.  Yes, it's a VM but the store never starts and it always generates the time error above.  For some reason manually starting it always works.
    Wednesday, July 29, 2009 1:06 PM
  • Hi Sameera,

    this solution work for me....

    i think before starting trableshoot we need to check these settings

    Sunday, January 24, 2010 6:25 AM
  • This error may be happen is there time,Date and TIme ZOne difference between Exchange server and Domain controller.
    Please check Windows Time services waether start on both servers.If it's stoped start Windows time and change the time,date and time zone according to your location.
    All time sync for Kerberos is done using GMT so the timezones being different won't matter. :)
    Brian Day, Overall Exchange & AD Geek
    MCSA 2000/2003, CCNA
    MCTS: Microsoft Exchange Server 2010 Configuration
    LMNOP
    Tuesday, January 26, 2010 3:02 AM
  • These steps resolved my issue:

    1. Make sure that exchange server is member of "Exchange servers" and "Exchange Trusted Subsystem" exchange security groups

    2. Sync the time of exchange server with AD using command "Net time \\AD server /set"

    3. Restart Microsoft Exchange Active Directory Topology service (All exchange services)

    4. Make sure that DNS lookup work fine for exchange server and AD server is reachable

    Monday, July 27, 2015 11:45 AM