User unknown in virtual alias table



    Ok, new problem popped up today.

    In Exchange 2003, we are experiancing a weird problem.


    I can email one of our employees by directly emailing

    But for what ever reason, we can not do a reply from an email from this user.

    When we do a reply, we get the following error back


    The e-mail account does not exist at the organization this message was sent to. Check the e-mail address, or contact the recipient directly to find out the correct address.

    < #5.1.1 smtp;550 5.1.1 Recipient address rejected: User unknown in virtual alias table>


    Anyone have any suggestions besides deleting this user's account and re-creating it?

    His account has been fine for years until now.  No configuration changes have been made to the system lately so i'm unsure of what could have happened.




    Thursday, March 29, 2007 4:34 PM

All replies

  • Can you do an AD attribute dump of the user?  It sounds like one of the key attributes required for Exchange may be missing or corrupted (I'm thinking maybe legacyExchangeDN given that it's a reply issue).


    One way to do this is to use ADFIND from, e.g. if the user's logon ID is"BobC":


    adfind -default -f "(&(objectClass=user)(objectCategory=person)(samAccountname=BobC))"





    Thursday, March 29, 2007 11:02 PM
  • I tried the ADFIND & it works well. I have the same issue of users sending email out but when someone

    wants to reply, the message is returned with

    User unknown in relay recipient table
    Have Exchange 2003 SP2 installed. Cannot seem to solve this issue. The
    legacyExchangeDN seems OK in that the info is correct. Anyone have this problem?
    Friday, November 02, 2007 9:19 PM
  • I never have gotten this fixed.

    We found that we are unable to email this user from outside of our domain also.

    Luckily, he doesn't normally need emailed outside of our domain, but it's still a pain in the @#$




    Friday, November 16, 2007 9:03 PM
  • Our domain is getting this error when sending to a specific domain outside our company.

    Ex:  sends e-mail to

    We filter our e-mail with an external provider (MX Logic) and suspect this could be part of the problem.


    We can send to the same SMTP address from an external service provider (hotmail) but e-mail is rejected when sent from our Company( to one specific Company(


    Below is the bounce back message:

    -----Original Message-----

    From: Mail Delivery System []

    Sent: Thursday, May 01, 2008 1:51 PM

    To: User1 name

    Subject: Mail delivery failed

    This message was created automatically by mail delivery software.

    A message that you have sent could not be delivered to one or more

    recipients. This is a permanent error. The following address failed:

    <>: 5.1.0 <>: Sender address rejected: User unknown in relay recipient table



    Included is a copy of the message header:


    Received: from unknown [] (EHLO

    by (mxl_mta-5.4.0-3)

    with ESMTP id (envelope-from <>);

    Thu, 01 May 2008 12:50:48 -0600 (MDT)

    Content-class: urn:content-classes:message

    MIME-Version: 1.0

    Content-Type: multipart/related;



    Disposition-Notification-To: "User1 Name" <>

    X-MimeOLE: Produced By Microsoft Exchange V6.5

    Subject: FW: Testing E-Mail For Titan Specialty

    Date: Thu, 1 May 2008 13:50:46 -0500

    Message-ID: <>



    Thread-Topic: Testing E-Mail For Titan Specialty

    Thread-Index: AcirmtyvgIho1IbeSqqcOx+SZ4JMjgAIUMew

    From: "User1 name" <>

    To: <>

    Thursday, May 01, 2008 7:43 PM
  • Hi Tony, I have had the same problem pop up this week. Exch003 all working fine receiving email to alis address and primary addrersses alike. This week however, no email aliases are receiving email, all bounce with error 5.1.1 user unknown.  ADFind shows all of the email addresses as Proxy addresses, no corruption is evident.
    Have tried deleting the secondary addresses, waitin ten minutes, putting them back, no joy.
    I suspect that this may be a paid call to microsoft!

    This particular server has been stable for three years, nothing has been changed.
    Any clues greatly appreciated.
    Friday, November 20, 2009 3:11 AM