none
Offline Files - Couldn't reconnect network drives RRS feed

  • Question

  • Hey,

    I'm not sure if this belongs in this place or a Windows 10 area.

    We have a load of Surface (Pro 4, Pro '5', Books, Laptops) all with this same issue.  We have offline files configured at group policy level and have configured slow-link mode for latency and connection speed.  Both of these are set well below what we have when in the office.

    Everytime anyone works out of the office in an offline state and then comes back into the office, none of the network drives reconnect first time.  It takes a couple of reboots to fix.

    We have Surface Docks too.  I can't see anything obvious as to why this happens.

    Thanks!

    Tuesday, July 18, 2017 7:27 AM

All replies

  • Hi,

    May I ask is there other version of the OS in your environment(windows7, windows8). Same results?

    And what exactly error do you get?

    Please also test   to disable the Offline on Slow Link option

    https://support.microsoft.com/en-us/help/811525/configure-slow-link-speed-group-policy-does-not-force-offline-files-to

    Here is the thread discussed before, please also take a look.

    https://social.technet.microsoft.com/Forums/windowsserver/en-US/be0fdca1-a4bc-4a50-8709-85006cffead8/error-reconnecting-to-network-drives-with-offline-folders-through-a-slow-connection?forum=winserverfiles

    Best Regards,

    Mary


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, July 18, 2017 8:56 AM
    Moderator
  • Hi Mary,

    Yes, there are other OS in ur environment but none of them have offline files enabled.  We are using Windows 10 Creators Update with the 2 cumulative updates from June this year.  We've had it with the previous Anniversary Update and the RTM release before that.

    Those links don't help really.  They're more about problems when actually out of the office and establishing connections to drive maps.  Our is the opposite in that when being actually offline away from the office, when connected bac into the corporate LAN Windows thinks it's still on a slow link so leaves the drives disconnected.  Simply rebooting 3 or 4 times (and logging in each time) fixes it... or clears the "I'm still on a slow link" logic.

    Saturday, July 22, 2017 4:22 PM
  • Hi Lanky Doodle,

    So your problem When the user logs in, if the connection to a server is below the slow link setting, CSC will automatically transition offline against that server?

    If so, please also check the thread discussed before.

    https://social.technet.microsoft.com/Forums/windows/en-US/3d25da46-28b7-47d4-ae31-3890c3c8020f/windows-offline-files-is-it-possible-to-reduce-the-slow-link-detection-time-interval?forum=w8itprogeneral

    Best Regards,

    Mary


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, July 24, 2017 2:30 AM
    Moderator
  • Hi Mary,

    Yes, basically.  If I work when disconnected from the LAN, i.e. at home, then go back to the office and connect to the LAN, Ethernet not WiFi, it puts me in an offline state so drive maps stay disconnected.  Doing nothing other than rebooting a few times just magically fixes it.  My LAN latency is <= 1ms so I have no idea why it is doing this.  My group policy settings for slow-link mode are:

    UNC Paths:   
    "\\corp.domain.com\dfs-root" "Latency=32000"
    "\\corp.domain.com\dfs-root\*" "Throughput=10485760, Latency=60"

    As you will see, that is a DFS namespace.

    When it does come back, if I leave my device connected to the LAN and shut down go home and restart the next day, it's never a problem.  It is only when the device is logged in when disconnected from the LAN then reconnected, even with a shut down and restart.

    I've posted in that thread so will see if something comes up.  I don't think it's the 2 minutes thing mentioned there as this is straight from a clean startup.


    Sunday, July 30, 2017 8:49 AM
  • Hello Mary,

    is there any news or a solution to the problem?

    Best regards Alex

    Friday, August 16, 2019 7:06 AM
  • Hi,

    Just to say this is really winding my users up now...

    Work in the office day 1 = fine
    Work in the office day 2 = fine
    Work out of the office day 3 = fine (we also use DirectAccess)
    Work in the office day 4 = busted, offline files is in offline mode

    Reboot a couple of times and it fixes itself. Sometimes we can do Easy Access in File Explorer > toggle offline state. Sometimes we can't (it's greyed out)

    Sometimes offline files reports errors that access was denied to the root DFS share. After reboot it magically works. Access is either denied or it isn't - it can't pick and choose when it is or isn't.

    There is no obvious reason why it reverts to offline mode after having previously been used out of the office - it never happens day after day after day while all inside the LAN.

    One thing I thought of is Windows is booting up/logging on too quickly to check offline files slow-slink parameters. We have the 'Always wait for the network at computer startup and logon' policy set to enabled as well.

    I have followed the MS blog guides on DFS + Offline Files here: https://blogs.technet.microsoft.com/askds/2011/12/14/slow-link-with-windows-7-and-dfs-namespaces/

    Other articles say to use FQDN or NetBIOS for drive mapping but we have many sites, hence using DFS.

    Tuesday, September 17, 2019 2:28 PM
  • I done some testing yesterday after posting - some of what I did post got me thinking...

    I found that after a shutdown the PC would indeed boot up much quicker, to the point there was no 'Please wait' spinner before the login screen. Then after a straight reboot (not shutdown this time) without even logging in, 'Please wait' spinner would show up before login screen.

    That led me to 'Fast startup' setting in power options. After turning this off I now get 'Please wait' spinner before login screen appears for both shutdowns and restarts.

    After testing being in and out of the office (by tethering to my mobile for data) a couple of times, I haven't noticed this problem anymore.

    I've rolled this out via Group Policy Preferences (this proper policy that exists doesn't allow you to turn it off) and will see how it goes for other users.

    If this turns out to be the fix, the default needs to be changed so that Fast startup is forced off on domain joined clients with offline files enabled.

    Wednesday, September 18, 2019 8:31 AM
  • Another update.

    Fast startup doesn't seem to be the only culprit with Offline Files. Also having an affect is GpNetworkStartTimeoutPolicyValue

    The help for the policy simplay says that the default is 30 seconds if not configured. That is not true:

    https://support.microsoft.com/en-gb/help/2421599/windows-7-clients-intermittently-fail-to-apply-group-policy-at-startup

    "If you define the Group policy setting, then it would override the manual setting. However, if neither manual or group policy setting has been defined then the value is picked from the following registry location"

    So I've forced it to 10 seconds and so far this seems to have cleared it all up. It would be good to know if there's any proper Microsoft documentation/guidance for my exact setup of Offline Files + Windows 10 + Always wait for network + Fast startup + Startup policy processing wait time

    Friday, September 20, 2019 1:05 PM
  • Regarding GpNetworkStartTimeoutPolicyValue setting, I've set this to 10 seconds but I'm seeing times much longer than that before login screen.

    Is that normal?

    Sunday, September 22, 2019 2:45 PM