none
Initial Outlook Configuration with AutoDiscover populates wrong email address

    Question

  • Hi,

    This one is pushing me right over the edge....

    Add a new user in AD.

    Add a new user mailbox for the new user in Exchange 2007 Management Console.

    Check the user's mailbox properties (specifically Email addresses). All OK.

    New user logs in to domain workstation. OK.

    User starts Outlook 2007.

    Outlook starts the Account Configuration Wizard.

    "Yes"...click next. OK

    "Your Name" filed is correct.

    "E-Mail Address" field is incorrect. Instead of the email address associated with the user (which is listed correctly in exchange mailbox properties and AD user properties), the field is populated with the users`s AD account name ie: username@domain.

    Can anyone shed some light on this for meÉ

    Thanks in advance.

    M

     

    Tuesday, December 21, 2010 4:05 PM

All replies

  • Same issue! Can anyone help?

    Also can admit, that nothing in configuration were changed. Suppose, that it starrted after some updates. Windows 2008R2 + Exchange 2010 sp1.

    Wednesday, December 22, 2010 2:12 PM
  • Is it causing you problems?

    Sounds like its populating the name field with the UPN. Is that a bad thing?

     

    Wednesday, December 22, 2010 2:45 PM
  • Hmmm...had to sign in using a different ID...oh well...MKSanchez here...

    Yes it does cause a problem:

    I delegate the outlook setup to the users themselves. Bascially a few clicks and they're good to go. Now they have to replace the UPN with their actual email addresss and supply their password. This basically blows away the purpose of autodiscover: to reduce complexity of adding an outlook account. Now I have new users calling help desk to ask "what's my email address?"..."what do I do at this prompt?"...etc...

    So I'm highly motivated to solve this issue.

     

    M

    Wednesday, December 22, 2010 2:53 PM
  • Hmmm...had to sign in using a different ID...oh well...MKSanchez here...

    Yes it does cause a problem:

    I delegate the outlook setup to the users themselves. Bascially a few clicks and they're good to go. Now they have to replace the UPN with their actual email addresss and supply their password. This basically blows away the purpose of autodiscover: to reduce complexity of adding an outlook account. Now I have new users calling help desk to ask "what's my email address?"..."what do I do at this prompt?"...etc...

    So I'm highly motivated to solve this issue.

     

    M


    Why do they have to replace the UPN with their actual SMTP address? I'm missing something here.

     

    Wednesday, December 22, 2010 3:35 PM
  • They don't "have to". The autodiscover stll finds their account but in outlook the account name shows up as the UPN. The users then need to rename it to something they are famililiar with. Also, I prefer to hide the implementation of certain things in AD (like UPN's) from the users. I know this may seem like a quibble, but it makes my job so much easier. I'd like the process to return to its former behaviour...ie autofill the users email address in the outlook initial auto configuration. How canb I do this?

    Thanks for your help.

    M

    Wednesday, December 22, 2010 5:14 PM
  • Today I discovered we are facing the same problem. In AD the logon domain is domain.local, our e-mail domain is <company>.nl  It used to work  normal, now the wizard comes up with the @domain.local address. Last time I created a new account (about a month ago) it worked fine.

    @xchargerx:  did you find a solution yet?

    thnx.

     

     

    Monday, January 03, 2011 2:54 PM
  • Hello,

     

    Do you have multiple email addresses on these accounts?

    It shouldn't be a problem but try creating a user with just one proxyaddress

     

     

    Monday, January 03, 2011 6:49 PM
  • There isn't multiple email addresses on these accounts.

     

    Can anyone give me some direction on this???

     

    M

     

    Wednesday, January 05, 2011 7:35 PM
  • There isn't multiple email addresses on these accounts.

     

    Can anyone give me some direction on this???

     

    M

     


    You may want to open a case with Microsoft.

     

    Wednesday, January 05, 2011 8:44 PM
  • Hello,

     

    I have the same problem, can you resolve it ?

    Monday, January 10, 2011 12:49 PM
  • Hi! same problem here!

    Seems like Outlook/Exchange AD lookup for e-mail address gives back upn instead of mail attribute.

    Can I find the configuration settings that comes back from autodiscover on the client some way?

    anyone?

    Monday, January 10, 2011 4:03 PM
  • Try removing the recent Microsoft Update KB2412171. I don't know exactly what it changed but it is Outlook related. AutoDiscover seems to be working fine afterwards.
    • Proposed as answer by bloo0153 Wednesday, January 12, 2011 4:30 PM
    Wednesday, January 12, 2011 4:29 PM
  • I just wanted to add my .2c here.

    On our network we use smartcard authentication. What this means is that in AD the user logon field contains the smart card certificate number instead of the account name: (e.g. 123456789)

    In the user logon (pre-windows 2000) field the regular account name is present. (e.g. some.user)

    Given that we are in a multi-domain environment with fairly lengthy names (e.g. some.domain.name.in.here) we added a upn suffix of (e.g. name). Here is where the problem comes into play:

    some.user logs into their workstation for the first time, when they open outlook(2007) the e-mail address field is populated with 123456789@name instead of some.user@some.domain.name, and the user is unable to be resolved.

    Simply changing the e-mail address field in outlook to some.user@some.domain.com presents another problem because it asks for a password and our user accounts don't have passwords since we force smartcard logon.

    In the meantime WSUS has been set to "approved for removal" for the KB2412171 update . At the same time this update has me wondering why it would change the attribute outlook reads in AD. I would think that instead of using the UPN attribute outlook would use the mail attribute.

    I am hoping that Microsoft can issue an update for this patch to correct this behavior.

    Friday, January 14, 2011 9:10 AM
  • Bless your cotton socks bloo0153 you saved me when I had already spent 9 hours on this issue and was about to break!

    Microsoft please release another update to fix the KB2412171 problem. This as it's obviously causing a lot of people grief!

    Tuesday, February 08, 2011 3:54 AM
  • Same problem here, removing update KB2412171 is a workaraound.

    thanks

    • Proposed as answer by pgsledder1 Friday, February 11, 2011 11:56 PM
    Tuesday, February 08, 2011 1:49 PM
  • This worked for my Windows 7 workstations, however, after removing update 2412171 on my XP workstations, the problem was not fixed.  Has any one else had success with XP?

    Friday, February 11, 2011 11:58 PM
  • Same problem over here and removing KB2412171does not help on Windows XP.
    Thursday, February 17, 2011 12:00 PM
  • I've got a similar problem on Outlook 2010. When the user enters an alternate user in the "From" field on a new email, the UPN is displayed rather than the primary email. KB2412171 applies to outlook 2007, any thoughts on a work around for 2010?

    Thanks

    Monday, February 21, 2011 5:20 PM
  •  Found the root of the problem here:

    http://serverfault.com/questions/222774/autodiscover-service-seems-to-reply-with-user-principal-name-instead-of-email-add/223493#223493

    The value comes from the E-mail field on the General tab of Active Directory Users and Computers, so if you change that field to something else, the Outlook AutoDiscover value should change to reflect that.

     

    Monday, February 21, 2011 5:36 PM
  • Two powerscripts I've just used to set the "WindowsEmailAddress" to be the same as the primary email address:

    This one lists all affected mailboxes

    Get-Mailbox | Where-Object {$_.WindowsEmailAddress -ne $_.PrimarySmtpAddress}
    

    This one updates all affected mailboxes with the primarysmtpaddress

    Get-Mailbox | Where-Object {$_.WindowsEmailAddress -ne $_.PrimarySmtpAddress} | ForEach-Object {Set-Mailbox -identity $_ -WindowsEmailAddress $_.PrimarySmtpAddress}
    
    Monday, February 21, 2011 8:49 PM
  • This brand new update seems to fix this issue:

     

    http://support.microsoft.com/kb/2475891

    Friday, March 04, 2011 10:22 PM
  • In Outlook, go to Contacts and you'll see a contact list called "Suggested Contacts".  Right-click and go to Properties / Outlook Address Book and uncheck the box.  Click okay and your Outlook will be normal again.  Got to love it when Microsoft tries to help you with these handy "features".
    Monday, December 17, 2012 10:17 PM
  • In Outlook, go to Contacts and you'll see a contact list called "Suggested Contacts".  Right-click and go to Properties / Outlook Address Book and uncheck the box.  Click okay and your Outlook will be normal again.  Got to love it when Microsoft tries to help you with these handy "features".
    Monday, December 17, 2012 10:17 PM
  • In Outlook, go to Contacts and you'll see a contact list called "Suggested Contacts".  Right-click and go to Properties / Outlook Address Book and uncheck the box.  Click okay and your Outlook will be normal again.  Got to love it when Microsoft tries to help you with these handy "features".
    • Proposed as answer by mooret5 Monday, December 17, 2012 10:17 PM
    Monday, December 17, 2012 10:17 PM