none
Exchange 2010sp1. Retention policy will not delete messages from "deleted item" RRS feed

  • Question

  • Hello.

    Configure a simple retention policy tag removes all messages from all folders, mailbox older than 40 days.

    New-RetentionPolicyTag-Name '111 '-Type' All '-Comment''-AgeLimitForRetention '40 .00:00:00'-RetentionAction 'PermanentlyDelete'-RetentionEnabled $ true

    Created a policy on the basis of this tag. Connected to a user's mailbox policy.

    I do Start-ManagedFolderAssistant when the team makes a request to enter the box is attached policy.

    As a result, cleaned up all the folders except the Deleted Items folder. From folder "deleted item" messages are not deleted. In what may be the problem?

    And yet. Without sp1 tab in the Server Configuration - Mailbox - Server Properties - Messaging Records Management - Setup could set the time when there is a processing mailbox policy. After installing sp1 Management tab MRM "disappeared. So it should be? How can I set the time interval processing boxes?
    Wednesday, October 13, 2010 2:03 PM

Answers

  • We have one account setup with a different policy that is set to “permanently delete” the deleted items after 1 day that seems to be working. Our default policy that is set to “delete and allow recovery” after 30 days does not work.

    Not an answer but maybe a workaround? Changing our default policy to the same, we shall see. 

    • Proposed as answer by TheJourney Friday, October 15, 2010 1:30 PM
    • Marked as answer by Gen LinModerator Friday, October 22, 2010 2:22 AM
    Friday, October 15, 2010 1:30 PM
  • I ended up creating new Tags and Policy with Deleted Items set to permanently delete after 1 day. Applied this policy to myself and it worked. I am now going to recreate tags and policy for the rest of our users with permanently delete after 21 days.
    Monday, October 18, 2010 2:01 PM

All replies

  • I am having this issue as well on SP1.  The retention policy will not remove any messages from the deleted items folder.  I need this to work ASAP>
    Wednesday, October 13, 2010 3:13 PM
  • If you create a Retention Tag specific to the Deleted Item folder does it work?  What expiration date does the email show in Outlook or OWA 2010?  See link:

    http://howdouc.blogspot.com/2010/08/using-retention-policies-in-exchange.html


    Tim Harrington - Catapult Systems - http://HowDoUC.blogspot.com
    Wednesday, October 13, 2010 5:25 PM
  • I am create retension tag specific to the deleted item, but it tag does not work also. The deleted item folder not cleaned after Start-ManagedFolderAssistant
    Thursday, October 14, 2010 5:47 AM
  • In outlook and owa I do not see the expiration date.
    Thursday, October 14, 2010 6:18 AM
  • Did you add the retention tag to the Retention policy that is assigned to those mailboxes?  If you are not seeing the expiration date in the email, then it is not applying. 
    Tim Harrington - Catapult Systems - http://HowDoUC.blogspot.com
    Thursday, October 14, 2010 1:05 PM
  • I am having the same issue, Items in the Deleted Items folder are marked as expired in OWA and Outlook 2010. But the are not being deleted.

     

    Exchange 2010 SP1 Rollup 1.

    Thursday, October 14, 2010 9:22 PM
  • Same here; emails in deleted items are marked as expired, but won't delete. (Ex2010 SP1 RU1)
    Friday, October 15, 2010 6:21 AM
  • same here, junk e-mail works fine but deleted items not. (EX2010 SP1)
    Regards Ronny
    Friday, October 15, 2010 7:00 AM
  • same here ;)

    All other folders are working fine... (Ex2010 SP1 UR1)

    • Proposed as answer by TheJourney Friday, October 15, 2010 1:26 PM
    Friday, October 15, 2010 12:06 PM
  • We have one account setup with a different policy that is set to “permanently delete” the deleted items after 1 day that seems to be working. Our default policy that is set to “delete and allow recovery” after 30 days does not work.

    Not an answer but maybe a workaround? Changing our default policy to the same, we shall see. 

    • Proposed as answer by TheJourney Friday, October 15, 2010 1:30 PM
    • Marked as answer by Gen LinModerator Friday, October 22, 2010 2:22 AM
    Friday, October 15, 2010 1:30 PM
  • I ended up creating new Tags and Policy with Deleted Items set to permanently delete after 1 day. Applied this policy to myself and it worked. I am now going to recreate tags and policy for the rest of our users with permanently delete after 21 days.
    Monday, October 18, 2010 2:01 PM