locked
"The data area passed to a system call is too small" NFS client Windows 2008 R2 SP1 RRS feed

  • Question

  • Hi

    I need to map a Hyper-V virtual windows server to a UNIX folder, but when i made de mapping and tried to navigate in to the mapped unit and shows me:

    "The data area passed to a system call is too small"

    I tried too many things like adding a registry key (and windows 2008 r2 already has)

    Use a similar account between Unix and Windows domain

    I done the steps in the document: http://technet.microsoft.com/en-us/library/cc753302(WS.10).aspx

    And nothing, this is just frustrating, also I disabled the firewall in the virtual machine and the host server.

    I have a Windows 2008 Domain R2 functionality and the virtual machine is Windows 2008 R2 too.

    The version of unix are:

    AIX6.1  x64

    AIX 6.3 x64

    AIX 5.1  x86

    Any Idea?

    Thanks!

     


    Doc MX


    • Edited by DocMX Thursday, October 27, 2011 11:21 PM
    Thursday, October 27, 2011 10:58 PM

Answers

  • Hi Arthur, thanks for the answer and I applied that but It does not solve the problem....

    An update of this issue!!

    I used around 5 servers with Windows 2008 R2 x64 with SP1 to try to connect to the AIX servers... and noting, but I installed a virtual Windows 2008 x32 with SP2 and the server connected without any problem, this is a great concern because the application is for x64 and I need this server to map these 4 AIX servers...

    Is there a difference between TCPIP x32 and x64? or the NFS client x32 and x64? or there is a registry key to fix this? or something else can help me to resolve this issue?

    In advance thanks,



    Doc MX
    • Marked as answer by DocMX Wednesday, May 23, 2012 1:30 PM
    • Unmarked as answer by DocMX Tuesday, September 18, 2012 4:27 PM
    • Marked as answer by DocMX Wednesday, January 9, 2013 5:55 PM
    Thursday, November 10, 2011 2:10 AM

All replies

  • Hi,

     

    You may perform the following troubleshooting suggestions:

     

    l  Change how your NFS servers export the NFS shares and make them allow connections from high ports.

    l  Add UseReservedPorts DWORD value under HKLM\Software\Microsoft\Client for NFS\CurrentVersion\Default and set it to 1. Restart the Client for NFS service to allow the change to take effect.

     

    For more information, please refer to the following Microsoft MSDN blog:

     

    "Network Error 53", "The data area passed to a system call is too small" or "Unknown Error"

    http://blogs.msdn.com/b/sfu/archive/2011/07/14/3087987.aspx

     

    Regards,


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Saturday, October 29, 2011 4:14 PM
  • Hi Arthur, thanks for the answer and I applied that but It does not solve the problem....

    An update of this issue!!

    I used around 5 servers with Windows 2008 R2 x64 with SP1 to try to connect to the AIX servers... and noting, but I installed a virtual Windows 2008 x32 with SP2 and the server connected without any problem, this is a great concern because the application is for x64 and I need this server to map these 4 AIX servers...

    Is there a difference between TCPIP x32 and x64? or the NFS client x32 and x64? or there is a registry key to fix this? or something else can help me to resolve this issue?

    In advance thanks,



    Doc MX
    • Marked as answer by DocMX Wednesday, May 23, 2012 1:30 PM
    • Unmarked as answer by DocMX Tuesday, September 18, 2012 4:27 PM
    • Marked as answer by DocMX Wednesday, January 9, 2013 5:55 PM
    Thursday, November 10, 2011 2:10 AM
  • Hello.

    Use

    mount -o sec=sys \\<server>\<share>\ s:\ 

    command

    • Proposed as answer by Nikhil Mahajan Friday, October 14, 2016 7:26 PM
    Tuesday, March 24, 2015 4:18 PM
  • This worked. I am still not able to access the share using \\ but it is mounted and works. Does anyone know why?
    Friday, October 14, 2016 7:26 PM