none
Exchange 2010 - OWA cannot reply or forward email - default domain name suspect

    Question

  • Using Exchange 2010 SP1 (all Windows Updates applied), OWA (only configured internally without SSL) can open existing email and send new email. However, when replying or forwarding, the error appears:

    "An unexpected error occurred and your request couldn't be handled."

    The error details are:

    Request

    Url: http://10.0.0.53:80/owa/?ae=PreFormAction&a=Reply&t=IPM.Note&id=RgAAAABc9B6tsQLnQ4i%2bSLQb0fUiBwBE9hu664tpS4EHNu48%2fFxTAAAAACT6AABgoNc1XzgJRp30zf90%2bj6NAAASUCZiAAAJ&pspid=_1322514478065_185765785

    User host address: 10.0.0.34

    User: Michael Gordon

    EX Address: /o=EMFExchange/ou=First Administrative Group/cn=Recipients/cn=Michael Gordon

    SMTP Address: gordonm@emfcontrols.com

    OWA version: 14.1.355.2

    Mailbox server: EMFSERVER003.office.emfcontrols.com

     

    Exception

    Exception type: System.ArgumentException

    Exception message: imceaDomain must be a valid domain name.

     

    Call stack

     

    Microsoft.Exchange.Data.Storage.InboundConversionOptions.CheckImceaDomain(String imceaDomain) 

    Microsoft.Exchange.Data.Storage.InboundConversionOptions..ctor(String imceaDomain) 

    Microsoft.Exchange.Clients.Owa.Core.Utilities.CreateInboundConversionOptions(UserContext userContext) 

    Microsoft.Exchange.Clients.Owa.Core.ReplyForwardUtilities.CreateReplyOrReplyAllItem(BodyFormat bodyFormat, Item item, ReplyForwardFlags flags, Boolean replyAll, UserContext userContext, StoreObjectId parentFolderId) 

    Microsoft.Exchange.Clients.Owa.Core.ReplyForwardUtilities.CreateReplyItem(BodyFormat bodyFormat, Item item, ReplyForwardFlags flags, UserContext userContext, StoreObjectId parentFolderId) 

    Microsoft.Exchange.Clients.Owa.Premium.Controls.ItemReplyPreFormAction.Execute(OwaContext owaContext, ApplicationElement& applicationElement, String& type, String& state, String& action) 

    Microsoft.Exchange.Clients.Owa.Core.RequestDispatcher.DoFinalDispatch(OwaContext owaContext) 

    Microsoft.Exchange.Clients.Owa.Core.RequestDispatcher.InternalDispatchRequest(OwaContext owaContext) 

    Microsoft.Exchange.Clients.Owa.Core.RequestDispatcher.DispatchRequest(OwaContext owaContext) 

    Microsoft.Exchange.Clients.Owa.Core.OwaRequestEventInspector.OnPostAuthorizeRequest(Object sender, EventArgs e) 

    System.Web.HttpApplication.SyncEventExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() 

    System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)

     

    I have read that if the default accepted domain contains an asterisk, the above problem can occur.

    We upgraded from Exchange 2003 to 2010 and the default domain was set for us.

    The name is "emfcontrols.com"

    The accepted domain is "*.emfcontrols.com"

    We do not need the asterisk ... we only have emfcontrols.com

    I cannot change the accepted domain using any methods known to me.

    When I try to delete the accepted domain entry (to recreate it), I am blocked because "it's referenced in an e-mail address policy by the proxy address template 'SMTP:@emfcontrols.com'."

     

    I have put aside this problem to date since we only use native Outlook. However, we are looking to support Exchange via SmartPhones (iPhone and Android) ... moving away from Blackberry.

    I believe I now need to resolve this problem.

    I am looking for guidance on the steps necessary to resolve this problem. 

    If anyone can provide a detailed sequence that will result in removing the asterisk from the accepted domain name, I would appreciate it. Please advise how to temporarily suspend mail processing if necessary during this procedure.

    Thank you very much.

     

     

    Monday, November 28, 2011 9:33 PM

Answers

  • I performed the ADSIEdit procedure this morning, and it worked just fine. Dealing with the email address policies added more work than I considered necessary. We were fully backed up (done every night) in case something went wrong. But it didn't. After editing the attribute I restarted the server and it appears all is well. Finally, we can reply and forward using OWA and can use iPhone and Android devices.

    Regards.

    • Proposed as answer by Martina_Miskovic Monday, December 5, 2011 11:14 PM
    • Marked as answer by Evan Liu Wednesday, December 7, 2011 9:37 AM
    Wednesday, November 30, 2011 1:06 PM

All replies

  • You can change the accepted domain name via Set-AcceptedDomain.

     

    There is an example in this blog post (see point #7): http://blogs.technet.com/b/exchange/archive/2010/09/01/exchange-2010-sp1-faq-and-known-issues.aspx

     

    Monday, November 28, 2011 10:48 PM
  • hi,

    The problem is caused with one of the accepted domains, probably a space or other illegal character at the end of the domain name. Set the domain name again with the command like above say in the exchange management shell.Remember restart the server after completing this .

    thanks,

    castin

     

    Tuesday, November 29, 2011 9:27 AM
  • Thank you for the information. I have previously tried to use the set-accepteddomain.

    However, the response indicates "command completed successfully but no settings of 'emfcontrols.com' have been modified. It appears that the problem is with the domainname ... it is set to "*.emfcontrols.com" and does not change by using the set-accepteddomain command.

    Using the ADSI Edit utility, I can find the particular active directory entry that probably needs to be changed.

    Under Configuration / Services / Microsoft Exchange / EMFExchange / Transport Settings / Accepted Domains / emfcontrols.com   - there is the attribute "msExchAcceptedDomainName" that has the value "*.emfcontrols.com"

    Perhaps I should change that attribute to "emfcontrols.com"

    Below I am including the short and formatted output from get-accepteddomain. The only domain we use is emfcontrols.com.  The domain name is office.emfcontrols.com but all email both internally and externally only use the name "emfcontrols.com"

    Thank you very much in advance.

    Regards,

    Michael Gordon

     

    --------------------------------------------------------------------------------------------------------------------

    The get-accepteddomain results follow ...

    VERBOSE: Connected to EMFServer003.office.emfcontrols.com.

    [PS] C:\Windows\system32>get-accepteddomain

     

    Name                           DomainName                     DomainType                   Default

    ----                           ----------                     ----------                   -------

    office.emfcontrols.com         office.emfcontrols.com         Authoritative                False

    emfcontrols.com                *.emfcontrols.com              Authoritative                True

     

     

    [PS] C:\Windows\system32>get-accepteddomain | fl

     

     

    RunspaceId                 : 6f415f18-a2f5-4187-8450-f28061696f3b

    DomainName                 : office.emfcontrols.com

    DomainType                 : Authoritative

    AddressBookEnabled         : True

    Default                    : False

    AuthenticationType         :

    LiveIdInstanceType         :

    PendingRemoval             : False

    FederatedOrganizationLink  :

    MailFlowPartner            :

    OutboundOnly               : False

    PerimeterDuplicateDetected : False

    AdminDisplayName           :

    ExchangeVersion            : 0.1 (8.0.535.0)

    Name                       : office.emfcontrols.com

    DistinguishedName          : CN=office.emfcontrols.com,CN=Accepted Domains,CN=Transport Settings,CN=EMFExchange,CN=Micr

                                 osoft Exchange,CN=Services,CN=Configuration,DC=office,DC=emfcontrols,DC=com

    Identity                   : office.emfcontrols.com

    Guid                       : 73c80f02-96a2-40d1-b946-b57e0f0c6a18

    ObjectCategory             : office.emfcontrols.com/Configuration/Schema/ms-Exch-Accepted-Domain

    ObjectClass                : {top, msExchAcceptedDomain}

    WhenChanged                : 10/12/2011 10:17:58 AM

    WhenCreated                : 1/4/2011 1:31:05 PM

    WhenChangedUTC             : 10/12/2011 2:17:58 PM

    WhenCreatedUTC             : 1/4/2011 6:31:05 PM

    OrganizationId             :

    OriginatingServer          : EMFOfficeServer.office.emfcontrols.com

    IsValid                    : True

     

    RunspaceId                 : 6f415f18-a2f5-4187-8450-f28061696f3b

    DomainName                 : *.emfcontrols.com

    DomainType                 : Authoritative

    AddressBookEnabled         : True

    Default                    : True

    AuthenticationType         :

    LiveIdInstanceType         :

    PendingRemoval             : False

    FederatedOrganizationLink  :

    MailFlowPartner            :

    OutboundOnly               : False

    PerimeterDuplicateDetected : False

    AdminDisplayName           :

    ExchangeVersion            : 0.1 (8.0.535.0)

    Name                       : emfcontrols.com

    DistinguishedName          : CN=emfcontrols.com,CN=Accepted Domains,CN=Transport Settings,CN=EMFExchange,CN=Microsoft E

                                 xchange,CN=Services,CN=Configuration,DC=office,DC=emfcontrols,DC=com

    Identity                   : emfcontrols.com

    Guid                       : 85b10591-b5e9-4cee-a72e-eb443b97529e

    ObjectCategory             : office.emfcontrols.com/Configuration/Schema/ms-Exch-Accepted-Domain

    ObjectClass                : {top, msExchAcceptedDomain}

    WhenChanged                : 11/28/2011 8:37:50 AM

    WhenCreated                : 1/5/2011 10:42:04 AM

    WhenChangedUTC             : 11/28/2011 1:37:50 PM

    WhenCreatedUTC             : 1/5/2011 3:42:04 PM

    OrganizationId             :

    OriginatingServer          : EMFOfficeServer.office.emfcontrols.com

    IsValid                    : True

     

     

     

    [PS] C:\Windows\system32>

    Tuesday, November 29, 2011 5:53 PM
  • While editing the value via ADSIEdit may work it will certainly be unsupported and may cause issues.  I think the proper method will be:

     

    1.  Use Set-AcceptedDomain office.emfcontrols.com -MakeDefault $true

    2.  Modify your E-Mail address policies to remove references to emfcontrols.com

    3.  Remove emfcontrols.com as an accepted domain using Remove-AcceptedDomain (this will cut off mail flow until you re-create it in the next step)

    4.  Create a new accepted domain using New-AcceptedDomain for emfcontrols.com

    5.  Set this as default via Set-AcceptedDomain emfcontrols.com -MakeDefault $true

    6.  Fix your e-mail address policies appropriately.

    7.  Reboot your exchange servers.

     

    Although removing the accepted domain won't remove the email addresses already on your mailbox accounts, this naturally is something you should test and plan out.

    Tuesday, November 29, 2011 9:51 PM
  • I performed the ADSIEdit procedure this morning, and it worked just fine. Dealing with the email address policies added more work than I considered necessary. We were fully backed up (done every night) in case something went wrong. But it didn't. After editing the attribute I restarted the server and it appears all is well. Finally, we can reply and forward using OWA and can use iPhone and Android devices.

    Regards.

    • Proposed as answer by Martina_Miskovic Monday, December 5, 2011 11:14 PM
    • Marked as answer by Evan Liu Wednesday, December 7, 2011 9:37 AM
    Wednesday, November 30, 2011 1:06 PM
  • FYI:

    I had the same problem:Exception message: imceaDomain must be a valid domain name.

    Changing the Accepted Domain(s) Names (i.e., removing the spaces from the name) fixed the problem.


    However, I wanted to get the system up and running ASAP without any downtime due to rebooting the server. In addition to restarting all the Exchange services, you also need to reboot IIS. That will get you back up and running without performing a full server reboot.
    Monday, December 5, 2011 6:57 PM