none
Event 9646, MSExchangeIS - Mapi session exceeded the maximum - Exchange 2010 SP1 w/ Update Roll Up 2

    Question

  • Based on the older version of this article here:

    http://support.microsoft.com/kb/2009942

    I created the ParameterSystem Subkey, with the Maximun Polling Frequency key and set the Decimal value to 45000.
    This was to mitigate the delay issues in Outlook 2003.
    Ever since then I receive this error message in my event viewer.

    Event 9646, MSExchangeIS

    Mapi session "13fbc88b-c9fc-4b9c-9efd-14de7957eee4: /o=MYDOMAIN/ou=First Administrative Group/cn=Recipients/cn=MYUSER" exceeded the maximum of 32 objects of type "session".

    Another user get this:

    Mapi session "2e5673f1-a3bd-4d56-b988-03c1267012b2: /o=MYDOMAIN/ou=First Administrative Group/cn=Recipients/cn=MYUSER" exceeded the maximum of 250 objects of type "objtMessage".

    I have received about 6 of these.

    I'm not saying this started as a result of me creating the subkey...Microsoft would have to confirm that.
    I'm just saying that this is when I started to notice it.

    My system specs are:
    Exchange 2010 SP1 Enterprise - Update Roll Up 2
    Windows Server 2008 R2 - All updated up until December 12, 2010.

    Any ideas?

    Treadstone
    Friday, March 11, 2011 8:18 PM

Answers

  • @m.salah, I am not sure why would want to delete that Registry entry!!!!!!!!!

    Try this and it will fix the issue.


    Click Start, click Run, type regedit in the Open box, and then click OK.
    Locate and then click the following registry subkey:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem
    If the Maximum Allowed Sessions Per User entry does not exist, do the following:
    On the Edit menu, point to New, and then click DWORD Value.
    Type Maximum Allowed Sessions Per User as the entry name, and then press ENTER.
    Right-click the Maximum Allowed Sessions Per User entry, and then click Modify.
    Click Decimal, type the value that you want to set in the Value data box, and then click OK. (Max Value is 36000)
    Exit Registry Editor.
    Click Start, click Run, type services.msc in the Open box, and then click OK.
    Click the MSExchange Information Store service, and then click Restart Service.

    Keep in mind, before making any changes in registry, take the backup of the registry.
    I would like to inform you that there is no fix resolution for this issue, you might get this fix in SP2 for 2010 which is coming in the month of June or so..

    http://support.microsoft.com/kb/842022

    Cheers,


    Gulab | MCTS-MCITP Messaging: 2010 | MCTS-MCITP Messaging: 2007 | MCC 2011 | Skype: Gulab.Mallah
    • Edited by Gulab Prasad Sunday, March 13, 2011 12:49 PM update
    • Marked as answer by Treadstone21 Monday, March 28, 2011 8:54 PM
    Sunday, March 13, 2011 12:49 PM
  • Hi,

     

    Details: MAPI session "5384d2a1-812e-4bf5-9a61-e83d867d00aa: /o=My Domain/ou=First Administrative Group/cn=Recipients/cn=MYuser" exceeded the maximum of 32 objects of type "session". If you notice, the objects of type is session. Would this fix apply to this also?"

    1. Click Start, click run, type regedit, and then click OK.

    2. Expand the following registry subkey:

        HKEY_LOCAL_MACHINE \SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

    3. Right-click ParametersSystem, point to New, and then click Key.

    4. Type MaxObjsPerMapiSession, and then press ENTER to name the new subkey.

    5. Right-click MaxObjsPerMapiSession, click New, and then click DWORD Value.

    6. Type Object_type, and then press ENTER to name the object.

    Note:

    Object_type is the name of the object type in the error message that is mentioned in the "Symptoms" section.

    More information:

    http://support.microsoft.com/?kbid=830829


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by Treadstone21 Monday, March 28, 2011 8:54 PM
    Monday, March 14, 2011 8:11 AM
    Moderator

All replies

  • Hi,

    Can you please try the following

    1. Open a registry editor, such as Regedit

    2. Navigate to:

      HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\MaxObjsPerMapiSession .

    3. Delete the objtFolder registry value.

    4. Close the registry editor and restart the Microsoft Exchange Information Store service for the change to take effect.

    5. Alternatively, if you wish to make use of the objtFolder registry value, instead of deleting it, keep it set to its existing value or adjust it as needed.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Sunday, March 13, 2011 9:54 AM
  • @m.salah, I am not sure why would want to delete that Registry entry!!!!!!!!!

    Try this and it will fix the issue.


    Click Start, click Run, type regedit in the Open box, and then click OK.
    Locate and then click the following registry subkey:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem
    If the Maximum Allowed Sessions Per User entry does not exist, do the following:
    On the Edit menu, point to New, and then click DWORD Value.
    Type Maximum Allowed Sessions Per User as the entry name, and then press ENTER.
    Right-click the Maximum Allowed Sessions Per User entry, and then click Modify.
    Click Decimal, type the value that you want to set in the Value data box, and then click OK. (Max Value is 36000)
    Exit Registry Editor.
    Click Start, click Run, type services.msc in the Open box, and then click OK.
    Click the MSExchange Information Store service, and then click Restart Service.

    Keep in mind, before making any changes in registry, take the backup of the registry.
    I would like to inform you that there is no fix resolution for this issue, you might get this fix in SP2 for 2010 which is coming in the month of June or so..

    http://support.microsoft.com/kb/842022

    Cheers,


    Gulab | MCTS-MCITP Messaging: 2010 | MCTS-MCITP Messaging: 2007 | MCC 2011 | Skype: Gulab.Mallah
    • Edited by Gulab Prasad Sunday, March 13, 2011 12:49 PM update
    • Marked as answer by Treadstone21 Monday, March 28, 2011 8:54 PM
    Sunday, March 13, 2011 12:49 PM
  • @Gulab, This article can answer your question

    http://technet.microsoft.com/en-us/library/aa996193%28EXCHG.80%29.aspx

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Sunday, March 13, 2011 12:56 PM
  • So what Decimal value to do you think would be appropriate for a server of 100-120 mailboxes?

    We utilize Office 2003, Office 2007, Office 2010 and blackberrys.


    Treadstone
    Sunday, March 13, 2011 3:02 PM
  • Also, what about the event that says "session" instead of "objtMessage", will this fix apply to that also?
    Treadstone
    Sunday, March 13, 2011 3:15 PM
  • @m.salah this change will set it to the default value, which i think is already set to default.

    @ Treadstone21 you can set it to say 25000 or so, but make sure that its not more than 36000.
    Post the event regarding objtMessage

    Cheers,


    Gulab | MCTS-MCITP Messaging: 2010 | MCTS-MCITP Messaging: 2007 | MCC 2011 | Skype: Gulab.Mallah
    • Proposed as answer by bobokrull Wednesday, November 06, 2013 4:45 PM
    Sunday, March 13, 2011 3:22 PM
  • http://support.microsoft.com/kb/830836
    Gulab | MCTS-MCITP Messaging: 2010 | MCTS-MCITP Messaging: 2007 | MCC 2011 | Skype: Gulab.Mallah
    Sunday, March 13, 2011 3:34 PM
  • @Gulab

    The Event regarding "Session" is:

    Event ID: 9646

    Source: MSExchange IS

    Details: Mapi session "5384d2a1-812e-4bf5-9a61-e83d867d00aa: /o=My Domain/ou=First Administrative Group/cn=Recipients/cn=MYuser" exceeded the maximum of 32 objects of type "session".

    If you notice, the objects of type is session.  Would this fix apply to this also?


    Treadstone
    Sunday, March 13, 2011 5:59 PM
  • @Treadstone

    Microsoft has released Update Rollup 3 for Microsoft Exchange Server 2010 Service Pack 1 (SP1) 

    it re-add UDP support for Exchange 2010 for use with Outlook 2003

    Issues that the update rollup resolves:

    2009942  Folders take a long time to update when an Exchange Server 2010 user uses Outlook 2003 in online mode

    For a list of changes that are included in this update rollup, see KB2492690.

    Download from here Update Rollup 3 for Exchange Server 2010 Service Pack 1



    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Sunday, March 13, 2011 8:24 PM
  • Hi,

     

    Details: MAPI session "5384d2a1-812e-4bf5-9a61-e83d867d00aa: /o=My Domain/ou=First Administrative Group/cn=Recipients/cn=MYuser" exceeded the maximum of 32 objects of type "session". If you notice, the objects of type is session. Would this fix apply to this also?"

    1. Click Start, click run, type regedit, and then click OK.

    2. Expand the following registry subkey:

        HKEY_LOCAL_MACHINE \SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

    3. Right-click ParametersSystem, point to New, and then click Key.

    4. Type MaxObjsPerMapiSession, and then press ENTER to name the new subkey.

    5. Right-click MaxObjsPerMapiSession, click New, and then click DWORD Value.

    6. Type Object_type, and then press ENTER to name the object.

    Note:

    Object_type is the name of the object type in the error message that is mentioned in the "Symptoms" section.

    More information:

    http://support.microsoft.com/?kbid=830829


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by Treadstone21 Monday, March 28, 2011 8:54 PM
    Monday, March 14, 2011 8:11 AM
    Moderator
  • @ Jerome

    So what Decimal value to do you think would be appropriate for a server of 100-120 mailboxes?

    We utilize Office 2003, Office 2007, Office 2010 and blackberrys.


    Treadstone
    Monday, March 14, 2011 2:38 PM
  • This question is for everyone....

     

    When I install update roll up 3 should I remove all the registry keys related to this thread?

    Will they conflict with the roll up?


    Treadstone
    Monday, March 14, 2011 2:42 PM
  • Should I set this one to 36000 also?
    Treadstone
    Thursday, March 17, 2011 8:56 PM
  • Hi,

     

    In fact , I haven’t read any document about how the threshold affect the performance. I think it will not affect the performance.

    So you can set it to the max value.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Thursday, March 24, 2011 4:28 AM
    Moderator
  • @Gulab...

    when creating new value in registry,  do i need to create a DWORD or a Qword?  exchange 2010 is a 64bit application ??...

    thanks for input... 

    Wednesday, April 20, 2011 8:47 AM
  • DWORD
    Gulab | MCTS-MCITP Messaging: 2010 | MCTS-MCITP Messaging: 2007 | MCC 2011 | Skype: Gulab.Mallah
    Wednesday, April 20, 2011 9:05 AM
  • Started getting this error when the boss got an iPhone and we configured it to get email from the server. Two other 'driods working fine, it's just his account we get the error on. I've previously upped the "Maximum Allowed Sessions Per User" to 40 (still maxes out) and now to 80. We all run Outlook 2k3 so it isn't the related Outlook 2k7 issue.

    Would love to know if anyone has ideas on what to change / do on the iPhone end.

    Friday, November 18, 2011 7:02 PM
  • Why is this happening? Really max mapi sessions.

    1. MAPI connections use RPC client Access Service so the sessions generated by outlook are handled dynamically through CAS

    2. POP, IMAP, OWA etc create these sessions as they connect to the store.

    Thursday, April 26, 2012 7:32 PM
  • Hello,  your solution from http://support.microsoft.com/kb/842022  does not apply for Exchange 2010.
    Thursday, August 02, 2012 10:38 AM
  • there is another article for Exchange 2010 http://support.microsoft.com/kb/980049/en-us

    the regkey slightly different from old versions...

    Thursday, August 02, 2012 11:33 AM
  • Hi Jerome Xiong,

    After i Add the registry key and restart the server. I still got the following error.

    Mapi session "2d5019a7-c6b7-47b4-b9f7-212a4cabf8f4: /o=First Organization/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Recipients/cn=073604" exceeded the maximum of 16 objects of type "session".

    Any idea?

    many thanks.

    Jason

    Monday, December 03, 2012 3:00 AM
  • I hope you restarted the Information Store service.

    Gulab Prasad,
    gulab@exchangeranger.com
    My Blog | Z-Hire Employee Provisioning App

    Monday, December 03, 2012 5:11 AM
  • Also check this:

    http://www.problutions.com/?p=704#comment-23782

    This solved my problem. I was trying changing the “Maximum Allowed Service Sessions Per User” and other MaxObjsPerMapiSession parameters to ridiculous values. Changing the web.config solved my problems and I could reset those parameters to their default values.

    Monday, May 27, 2013 9:06 PM
  • Hello Guillermo,

    I have the same problem as described above.

    Can you explane your solution "Changing the web.config" please.

    I can't open the site http://www.problutions.com/?p=704#comment-23782

    Thanks.

    Uwe.

    Tuesday, July 09, 2013 10:49 AM
  • Today  http://www.problutions.com is reachable, but that solution is not the answer for me.
    After installing SP3 we don't have the described SSL Problem.

    But we have still event 9646

    - "exceeded the maximum of 32 bjects of type "session"
    - "exceeded the maximum of 250 objects of type "objtMessage"

    Now I changed to 64 session + 500 objtMessage.

    Exchange restart being planned for the weekend.

    Wednesday, July 10, 2013 7:42 AM
  • Could you please provide the steps to change the below value in exchange 2010 SP1

    exceeded the maximum of 32 bjects of type "session" to what  ?
    exceeded the maximum of 250 objects of type "objtMessage" to what ?

    Generating the below events on exchange mailbox server

    Mapi session "68e7a8e4-4f98-428d-9c91-da7caba20883: /o=First Organization/ou=First Administrative Group/cn=Recipients/cn=----" exceeded the maximum of 32 objects of type "session".

    Regards,

    Tuesday, July 16, 2013 8:31 AM
  • What did you change in the web.config file?
    Tuesday, July 16, 2013 2:18 PM