none
Moved from Exchange 2003 to 2010, Outlook clients can't download offline address book RRS feed

  • Question

  • Hello everyone,

    I have a simple setup. One Exchange 2003 box is going to be replaced with one Exchange 2010 box.

    Now I have done the installation of 2010 into the existing 2003 organization and everything went smoothly. I went ahead and Moved All Replicas of public folders over to the Exchange 2010 box and confirmed everything was moved by making sure the Public Folders Instances was empty.

    I also changed to OAB generation server to the new 2010 server. I then deleted the public folder store from the 2003 box. I also moved the Public Folder hierarchy to the 2010 box.

    I converted all Address Lists and Recipient policies to Exchange 2010 without issue.

    Mailboxes were moved to the 2010 server as well without issue and then the Mailbox store on the 2003 server was deleted.

    The only steps I have not taken so far are deleting the Routing Group connector between the old 2003 box and 2010, removing the RUS entries, and uninstalling Exchange 2003.

    Outlook 2003 SP3 clients are getting the generic 0x8004010f error when trying to download the Offline Address Book. This one really gets me irritated as I mentioned above I made sure to replicate all the Public Folders from 2003 to 2010. Any ideas on this?

    I did try checking Free+Busy Information by scheduling an appointment and attendees and that seems to be working fine as I could see the invited attendees Busy information in Outlook.

    I am hoping someone has a similar situation and can help me out.

    Thanks!

    Saturday, June 26, 2010 9:54 PM

Answers

  • You can check it using "Public Folder Management Console" or Get-PublicFolderStatistics in EMS.
    OK, ran command. I see all public folders that I created before in Outlook as well as OAB v2,3, and 4 along with their respective item count.

    1. Now first verify that you have correct oab set at mailbox level, and just target the user which u are using in OL 2003.

    Get-Mailbox YourUser@Domain.com |FL OfflineAddressBook

    if it is not set then OAB from database is considered, which u can verify using following ps command:

    Get-MailboxDatabase "YourDatabase" |FL OfflineAddressBook

    Here put the database name, where ur mailbox exists.

    If it is also shows u empty result then set the OAB on either database level 

    Get-MailboxDatabase  "DBName" | Set-MailboxDatabase -OfflineAddressBook OABName

    or at mailbox level (which overrides db level setting)

    Get-Mailbox "YourUser@Domain.com" | Set-Mailbox -OfflineAddressBook OABName


    2. When verified, then goto your OL client machine and remove all the file with extension .oab

    By default, the *.oab files are located in the following folder:

    \Documents and Settings\<username>\Local Settings\Application Data\Microsoft\Outlook

     

    Then download the OAB using outlook Tools->Send Recieve->Download Address Book option.

    Regards,


    Laeeq Qazi|Team Lead(Exchange + Sharepoint + BES + DynamicsCRM) www.HostingController.com
    Sunday, June 27, 2010 1:15 AM

All replies

  • Hi,

    This might be due to the fact that your Offline Address Books are still pointing to old ex 2003 public folder database , which you can confirm in 2 ways:

    1. Get-OfflineAddressBook |FL Name,PublicFolderDatabase

    This will show exch 2003 db name.

    2. Open ADSIEdit on your server and then locate OfflineAddressBook objects in this section

    CN=Configuration, DC=ADDomain, DC=tld”

    CN=Services,

    CN=Microsoft Exchange, 

    CN=First Organization,  [Your Exchange Org Name]

     CN=Address Lists Container, 

    "CN=Offline Address Lists,

    On right side select any of the OAB and then view its properties, then locate the attribute 'siteFolderServer'

    This will be pointing to old ex03 public folder db. 

     

    Solution: You have to change this value and need to put the Distinguished name of the ex 2010 public folder database for 'siteFolderServer' attribute of all OABs and exchange 2010 administrative group in Active Directory. You can find the 'Administrative Group' object in AD using ADSIEdit.msc and its path should be

    CN=Configuration, DC=ADDomain, DC=tld”

    CN=Services,

    CN=Microsoft Exchange, 

    CN=First Organization,  [Your Exchange Org Name]

    CN=Administrative Groups,

    CN=<AdministrativeGroupName> 

    Here is a MS articles regarding this subject.

    http://technet.microsoft.com/en-us/library/aa996485(EXCHG.80).aspx

    http://technet.microsoft.com/en-us/library/aa996288(EXCHG.80).aspx

    Regards,


    Laeeq Qazi|Team Lead(Exchange + Sharepoint + BES + DynamicsCRM) www.HostingController.com
    Saturday, June 26, 2010 10:17 PM
  • Well I should have mentioned I ran Get-OfflineAddressList | Format and did confirm that the PublicFolderDatabase reports the name of the 2010 public folder database.
    Saturday, June 26, 2010 10:37 PM
  • Well I should have mentioned I ran Get-OfflineAddressList | Format and did confirm that the PublicFolderDatabase reports the name of the 2010 public folder database.

    Ok, what about  'siteFolderServer' attribute of exchange 2010 administrative group in Active Directory. Check it and modify it too. Also ensure that your public folder OAB has been replicated to Ex2010 server. You can check it using "Public Folder Management Console" or Get-PublicFolderStatistics in EMS.

    Regards,


    Laeeq Qazi|Team Lead(Exchange + Sharepoint + BES + DynamicsCRM) www.HostingController.com
    Saturday, June 26, 2010 11:15 PM
  • Checked the OAB in ADSIEdit and the only OAB is the Default OAB and the siteFolderServer also points to the 2010 Public folder database.

    Also ensure that your public folder OAB has been replicated to Ex2010 server. You can check it using "Public Folder Management Console" or Get-PublicFolderStatistics in EMS.

    I used MoveAllReplicas from ESM on the Exchange 2003 box and confirmed everything was moved by making sure the Public Folder Instances was empty. I then deleted the Public Folder database from the 2003 box. I'll see what Get-PublicFolderStatistics reports.

    Saturday, June 26, 2010 11:40 PM
  • You can check it using "Public Folder Management Console" or Get-PublicFolderStatistics in EMS.
    OK, ran command. I see all public folders that I created before in Outlook as well as OAB v2,3, and 4 along with their respective item count.
    Saturday, June 26, 2010 11:45 PM
  • You can check it using "Public Folder Management Console" or Get-PublicFolderStatistics in EMS.
    OK, ran command. I see all public folders that I created before in Outlook as well as OAB v2,3, and 4 along with their respective item count.

    1. Now first verify that you have correct oab set at mailbox level, and just target the user which u are using in OL 2003.

    Get-Mailbox YourUser@Domain.com |FL OfflineAddressBook

    if it is not set then OAB from database is considered, which u can verify using following ps command:

    Get-MailboxDatabase "YourDatabase" |FL OfflineAddressBook

    Here put the database name, where ur mailbox exists.

    If it is also shows u empty result then set the OAB on either database level 

    Get-MailboxDatabase  "DBName" | Set-MailboxDatabase -OfflineAddressBook OABName

    or at mailbox level (which overrides db level setting)

    Get-Mailbox "YourUser@Domain.com" | Set-Mailbox -OfflineAddressBook OABName


    2. When verified, then goto your OL client machine and remove all the file with extension .oab

    By default, the *.oab files are located in the following folder:

    \Documents and Settings\<username>\Local Settings\Application Data\Microsoft\Outlook

     

    Then download the OAB using outlook Tools->Send Recieve->Download Address Book option.

    Regards,


    Laeeq Qazi|Team Lead(Exchange + Sharepoint + BES + DynamicsCRM) www.HostingController.com
    Sunday, June 27, 2010 1:15 AM
  • 1. Now first verify that you have correct oab set at mailbox level, and just target the user which u are using in OL 2003.

    Get-Mailbox YourUser@Domain.com |FL OfflineAddressBook

    if it is not set then OAB from database is considered, which u can verify using following ps command:

    Get-MailboxDatabase "YourDatabase" |FL OfflineAddressBook

    Here put the database name, where ur mailbox exists.

    If it is also shows u empty result then set the OAB on either database level 

    Get-MailboxDatabase  "DBName" | Set-MailboxDatabase -OfflineAddressBook OABName

    or at mailbox level (which overrides db level setting)

    Get-Mailbox "YourUser@Domain.com" | Set-Mailbox -OfflineAddressBook OABName


     

    2. When verified, then goto your OL client machine and remove all the file with extension .oab

    By default, the *.oab files are located in the following folder:

    \Documents and Settings\<username>\Local Settings\Application Data\Microsoft\Outlook

     

    Then download the OAB using outlook Tools->Send Recieve->Download Address Book option.

    This seems to have solved it! So far so good, I can download OAB without any Sync issues being reported.

    Now I really want to know why did I have to do this? All my transition papers I have read never mentioned anything about this. Did I miss a step or something?

    Sunday, June 27, 2010 2:07 AM
  • If the problem have been solved, don't forget to mark the correct answer so the thread is marked as solved :)

    Jonas Andersson MCTS: Microsoft Exchange Server 2007/2010 | MCITP: EMA 2007/2010 | MCSE/MCSA Blog: http://www.testlabs.se/blog
    Wednesday, June 30, 2010 7:29 AM