none
Exchange 2010/Outlook 2010: One user needs two mailboxes

    Question

  • Hi all.  I have a user who needs to be able to use two mailboxes.  PC is Win7 w/ Outlook 2010, server is Exchange 2010 SP1. 

    The user is jim@domain.com and the 2nd account he needs to use in Outlook is info@domain.com

    Outlook is set to use one Profile.  In EMC, I've already put the Send-As Full Control thingie and added the jim user to the mailbxoes for info@. 

    What results is that within outlook, I do see both mailboxes on the left side.  New emails for Info come in and are visible in the Inbox for Info and the same occurs for Jim so that's fine.  But anything I send from Info gives me two problems. 

    First, I get the undeliverable error:

    "You can't send a message on behalf of this user unless you have permission to do so. Please make sure you're sending on behalf of the correct sender, or request the necessary permission. If the problem continues, please contact your helpdesk. "

    The problem is, I need this person to have complete transparency so all email to/from Info@ is loo0king like it's coming to/from info@.  noe of this "on behalf of" stuff. 

    The second issue is probably just tied to the first, which is that when I open a message, select the info@ account in the From field and send the message (even though it bounces), the message still ends up in the jim@ Sent Items folder and not the info@ one.  However the bounced delivery notification does come into the info@ Inbox. 

    Perhaps I just need to have two Profiles in Mail via Control Panel, but it would be much more convenient for a user not to have to flip betweenthe two Profiles every time email needs to be viewed. 

    Can anyone assist?  My searches aren't finding this specific issue though it seems rather common by nature in my mind, so I do aplogize if I missed an easy searchable answer. 

    Thanks! 

     

     


    • Edited by viProCon Sunday, October 16, 2011 5:45 PM
    Sunday, October 16, 2011 5:43 PM

Answers

  • Hi ViProcon,

    See http://blogs.office.com/b/microsoft-outlook/archive/2009/08/25/multiple-exchange-accounts-in-outlook-2010.aspx.

    You Do NOT need to add any additional permission for the second mailbox you would like to use. Just add the account via the steps described in the above link (close Outlook first), and then logon Outlook. you will noticed that you are prompted twice, one for the main account, and the other for the second mailbox you added.

    Please remove the permission from EMC, and remove the additonal mailbox from Outlook/Account settings/more settings/advance, and then try the steps above. It is able to send from the second mailbox in my local lab.


    Fiona
    Tuesday, October 18, 2011 9:48 AM
    Moderator
  • Full Mailbox Access is just access, not the permission to Send As.
    It used to be that Full Mailbox also gave you Send As, but there was a desire to see the permissions separated and it was changed in a hotfix for Exchange 2003 SP2. Now you need both.

    The poster above who has said to grant Send As, Full Permission and Send on Behalf of is wrong.
    You can't have Send As and Send on Behalf of set at the same time - well you can, but you don't get both permissions, you on get Send on Behalf of. You should set EITHER Send As or Send on Behalf of. NOT both.

    Simon.


    Simon Butler, Exchange MVP
    Blog | Exchange Resources | In the UK? Hire Me.
    • Marked as answer by viProCon Monday, October 24, 2011 3:19 PM
    Tuesday, October 18, 2011 6:03 PM
  • Thanks Simon.  It apepars whether I use Control Panel or directly in Outlook the effect is the same (Win7, Outlook 2010), but what it turned out to be that I was missing was indeed the Send As Permission.  I had thought Full Access meant ALL THINGS : like such a permission would normally mean in most contexts, but in Exchange it doesn't mean you get to Send As that mailbox.  Anyway, problem resolved it turns out :) Thank you for the info. 


    Hi viProCon,

    Did you remove the additional mailbox from Advance option? Where is the problematic email message that cannot be sent? in the Outbox of info@domain.com? or in the Sentitems of Jim@domain.com?   

    In my local test I encountered the same error message that no sufficient permission to sent as even though I have logged on with two credentials provided. the problem was fixed after I removed the additional mailbox from Account settings/more settings/advance/additional mailbox , and removed the permission.

    Actually, we do not need "Full Access" or Sendas permission, when we loggon and provide two  credentials, we have "full control" on the two mailbox and we can send as the user.

    See my pictures below:

    multiple mailbox in OL10

    11

     

     

     


    Fiona

    Wednesday, October 19, 2011 2:19 AM
    Moderator

All replies

  • Hi

    If you have to accounts in one outlook profile it's normall when you send an email from second account the sent email will go to the sent items default email account. 

    I had the similar problem, and I use extraoutlook, I created two profiles on client computer, user has open one profile with his default mailbox and second mailbox is added to this profile. When he need to respond from second email address he open extraoutlook with second profile and he can work with two outlooks in the same time. 

    Another option is to create rules in default outlook profile which will move sent items from address info@domain.com to sent items (second account) info@domain.com

     

    Sunday, October 16, 2011 6:19 PM
  • Hi

    If you have to accounts in one outlook profile it's normall when you send an email from second account the sent email will go to the sent items default email account. 

    I had the similar problem, and I use extraoutlook, I created two profiles on client computer, user has open one profile with his default mailbox and second mailbox is added to this profile. When he need to respond from second email address he open extraoutlook with second profile and he can work with two outlooks in the same time. 

    Another option is to create rules in default outlook profile which will move sent items from address info@domain.com to sent items (second account) info@domain.com

     


    If you use Outlook 2010 and add the second mailbox as an additional ACCOUNT, not an additional mailbox, then there is no need to use anything else. Outlook will store the email in to the second mailbox sent items automatically. No need for rules, no need for additional profiles. All built in.

    The primary account must have both Send as and Full Mailbox permissions to send as the second account. If the user is also a domain admin or other protected account those permissions may well be removed. Also remember that Exchange permissions are cached, therefore a change is not live, it can take two hours for the change to take full effect.

    Simon.


    Simon Butler, Exchange MVP
    Blog | Exchange Resources | In the UK? Hire Me.
    Sunday, October 16, 2011 6:43 PM
  • Thanks guys.  I have had no success however. 

    Sembee:  I assume by ACCOUNTS you mean if I go to Mail in Control Panel, in the Email Accounts button, I would see the two acconts listed.  This is indeed what I have, and both are listed as Exchange accountsw with Jim's account set as the default send account.  Yet I still get the undeliverable every time I try to send email from the info@ account, and the messages still go to Jim's Sent Items. 

    Also I thought I still had that Send As... Full Access thing set but for the life of me I can't even remember where to go find the setting.  But would this have to be on or off for the above change to the Limits tab to work?  Or does it matter? 

    Sunday, October 16, 2011 10:41 PM
  • Don't use the Control Panel applet - remove the second account.

    Start Outlook as normal and then run the Add Account wizard in Outlook, Options. The account will then appear with the other one. This is the same method that allows an Outlook installation to connect to two completely separate Exchange orgs.

    Both Send As and Full Mailbox are set in EMC. When you choose the user they should be an option on the right.

    Simon.


    Simon Butler, Exchange MVP
    Blog | Exchange Resources | In the UK? Hire Me.
    Sunday, October 16, 2011 11:58 PM
  • Hi ViProcon,

    See http://blogs.office.com/b/microsoft-outlook/archive/2009/08/25/multiple-exchange-accounts-in-outlook-2010.aspx.

    You Do NOT need to add any additional permission for the second mailbox you would like to use. Just add the account via the steps described in the above link (close Outlook first), and then logon Outlook. you will noticed that you are prompted twice, one for the main account, and the other for the second mailbox you added.

    Please remove the permission from EMC, and remove the additonal mailbox from Outlook/Account settings/more settings/advance, and then try the steps above. It is able to send from the second mailbox in my local lab.


    Fiona
    Tuesday, October 18, 2011 9:48 AM
    Moderator
  • Thanks guys.  I have had no success however. 

    Sembee:  I assume by ACCOUNTS you mean if I go to Mail in Control Panel, in the Email Accounts button, I would see the two acconts listed.  This is indeed what I have, and both are listed as Exchange accountsw with Jim's account set as the default send account.  Yet I still get the undeliverable every time I try to send email from the info@ account, and the messages still go to Jim's Sent Items. 

    Also I thought I still had that Send As... Full Access thing set but for the life of me I can't even remember where to go find the setting.  But would this have to be on or off for the above change to the Limits tab to work?  Or does it matter? 

    Try to put permission to Manage Full access permission and add second user to that mail, and see if error still persist.
    Tuesday, October 18, 2011 1:00 PM
  • HI,

    In Your case jim@domain.com is PRIMARY mailbox & info@domain.com is additional shared mailbox.

    You will have to provide “Send as”, "Full Permission" & “Sent on Behalf of” permission to jim@domain.com on info@domain.com account.

     

    Additionally when JIM sent mail on behalf of INFO, it will store in JIM’s mailbox (Primary Mailbox). To avoid this kindly fin below article, hot fix for Office 2007 & 2003.

    http://exchangeshare.wordpress.com/2009/07/15/shared-mailbox-added-in-outlook-profile-but-where-will-sent-item-be-saved/

     

    ThankS!

    Tuesday, October 18, 2011 3:46 PM
  • Thanks Simon.  It apepars whether I use Control Panel or directly in Outlook the effect is the same (Win7, Outlook 2010), but what it turned out to be that I was missing was indeed the Send As Permission.  I had thought Full Access meant ALL THINGS : like such a permission would normally mean in most contexts, but in Exchange it doesn't mean you get to Send As that mailbox.  Anyway, problem resolved it turns out :) Thank you for the info. 
    Tuesday, October 18, 2011 5:43 PM
  • Full Mailbox Access is just access, not the permission to Send As.
    It used to be that Full Mailbox also gave you Send As, but there was a desire to see the permissions separated and it was changed in a hotfix for Exchange 2003 SP2. Now you need both.

    The poster above who has said to grant Send As, Full Permission and Send on Behalf of is wrong.
    You can't have Send As and Send on Behalf of set at the same time - well you can, but you don't get both permissions, you on get Send on Behalf of. You should set EITHER Send As or Send on Behalf of. NOT both.

    Simon.


    Simon Butler, Exchange MVP
    Blog | Exchange Resources | In the UK? Hire Me.
    • Marked as answer by viProCon Monday, October 24, 2011 3:19 PM
    Tuesday, October 18, 2011 6:03 PM
  • Thanks Simon.  It apepars whether I use Control Panel or directly in Outlook the effect is the same (Win7, Outlook 2010), but what it turned out to be that I was missing was indeed the Send As Permission.  I had thought Full Access meant ALL THINGS : like such a permission would normally mean in most contexts, but in Exchange it doesn't mean you get to Send As that mailbox.  Anyway, problem resolved it turns out :) Thank you for the info. 


    Hi viProCon,

    Did you remove the additional mailbox from Advance option? Where is the problematic email message that cannot be sent? in the Outbox of info@domain.com? or in the Sentitems of Jim@domain.com?   

    In my local test I encountered the same error message that no sufficient permission to sent as even though I have logged on with two credentials provided. the problem was fixed after I removed the additional mailbox from Account settings/more settings/advance/additional mailbox , and removed the permission.

    Actually, we do not need "Full Access" or Sendas permission, when we loggon and provide two  credentials, we have "full control" on the two mailbox and we can send as the user.

    See my pictures below:

    multiple mailbox in OL10

    11

     

     

     


    Fiona

    Wednesday, October 19, 2011 2:19 AM
    Moderator
  • Sorry guys, I'm posting out of sequence here.  I had only seen Simon and Rem's post by the time I wrote my two responses.  I'll review Fiona's and any others after I post this one reply. 

    To summarize, here is what I found worked, and bear in mind I discovered this through testing on the users's PC before seeing any poosts after Sembee's first (or 2nd) one.   

    Whether I do it in Outlook 2010, or in Control Panel > Mail (in Win7):  Removing/adding Email Accounts seems to produce the same result.  Example I go into Mail in Control Panel and add an Email Account, I will then see it under Accounts if I look in Outlook and it is listed as an Exchange account.  Of course, I do specify Exchange as the mail type when I create the account, and then I pick the mail server.  I guess autodiscover only applies to the primary account or mailbox. 

    Then in EMC > Recipient Config > under the Info mailbox, if I set the Send As and the Full Access permissions and add Jim to those lists of users allowed, I get full functionality.  All email sent from Info@ ends up in that account's Sent Items folder, and arrives as Info@ to the inbox of the reeiver.  Replies come back to Info and arrive in it's Inbox.  So Jim is able to do full send/receive using Info, he just has to pick Info@ in the From box on a new message. 

    Bear in mind, I"m not looking to do any On Behalf f stuff, I just need Jim to be able to monitor Info@ and forward any external inquiries sent to it.  Actually I'm not sure where to set On Behalf Of but I'll look around or maybe it's mentioned in some posts above.  I'll re-read them now and reply again but wanted to mention that what I did above was enough to get things working. 

     

     

    Wednesday, October 19, 2011 6:12 PM
  • Fiona,

    Although the problem was fixed because the first thing I tried was the Send As and athe Full Access permissions wthin EMC, I'm still going to do some testing with the stuff you posted because I"m curious about it more.  I haven't done a lot with any of these settings yet so it's a bit new.  It'll be a while before I can do so, maybe a month or more, but at least I have good info to go on.  Thanks!

     

     

    Monday, October 24, 2011 3:19 PM