none
Exchange 2010 recipient limit

    Question

  • Hello All,

    We are currently in the process of migrating from a mixed Exchange 2003 / 2007 environment to an Exchange 2010 environment (finally!)

     

    However, i have a problem with the recipientlimit of 1 of our users.

    Our company policy has users limited to 250 recipients.

    This user has to send e-mails to 5000 users (internally)

     

    I configured the users Mail Flow settings to enable a 5000 user cap.

    As i understand the userlimit overrules all other limits.

     

    However, each and every time the user tries to send the e-mail it get's bounced stating there are more recipients then the 250 allowed.

    And the user is sending a message to "only" 1000 users.

     

    It looks to me as if the users mail-flow settings are ignored.

     

    The Shell command i used to set the limit on the user is as followed;

     

    set-mailbox -identity "<user>" -domaincontroller <GC.domain.local> -RecipientLimits 5000
    

     

     

    I could definatly use some help resolving this issue.

    Thanks in advance!

     

    Marco.

    • Edited by Tmaniac Monday, October 03, 2011 2:32 PM
    Monday, October 03, 2011 2:32 PM

Answers

  • this morning we discoverd that the group the user was trying to send the email to was a security group.

     

    we changed the security group to a distribution group and now the user is able to send to the group.

     

    Weird solution but it seems to work.

    Thursday, October 13, 2011 2:33 PM

All replies

  • Did you gave sometime to replicate the information into AD?
    Replicate the DC's and check the issue. 
    Gulab | MCITP: Exchange 2010-2007 | Lync Server 2010 | Windows Server 2008 | Skype: Exchange.Ranger | Blog: www.ExchangeRanger.Blogspot.com
    Monday, October 03, 2011 3:03 PM
  • Hi Marco,

    We have one more option to set recipient per message limit. Check whether the 250 Limit is set the receive connector settings.

    Get-ReceiveConnector -Identity ServerName\"Default connector" | Fl

    And chec the recipient per message limit is limited.

    Inform if any issue.

    Thank you

    Monday, October 03, 2011 3:22 PM
  • @Gulab
    I gave the user a time window of 1 hour to check the settings.
    The user waited till the next morning to try; Same result.

    @Rajkumar
    I checked the receive connectors previously and set them all to 5000;

    [PS] C:\Windows\system32>get-receiveconnector -identity "<server>\<connector>" |fl *recipient*
    MaxRecipientsPerMessage : 5000

    The only place in the organisation where i have limited the amount of messages is in the transport configuration;

    [PS] C:\Windows\system32>get-transportconfig |fl *recipient*
    MaxRecipientEnvelopeLimit : 250

    But because i gave the user a 5000 limit there should not be any problem since (as far as i know) user limit overrules any other limit.
    [PS] C:\Windows\system32>get-mailbox <user> -domaincontroller <dc.fqdn> | fl *recipient*

    RecipientLimits      : 5000
    RemoteRecipientType  : None
    RecipientType        : UserMailbox
    RecipientTypeDetails : UserMailbox

    I even checked the users attributes with ADSI edit, there it states 5000 as well.

     

    Tuesday, October 04, 2011 7:08 AM
  • Have you tried to create a new profile and test or use online mode


    Sukh
    Thursday, October 13, 2011 2:29 PM
  • this morning we discoverd that the group the user was trying to send the email to was a security group.

     

    we changed the security group to a distribution group and now the user is able to send to the group.

     

    Weird solution but it seems to work.

    Thursday, October 13, 2011 2:33 PM
  • this morning we discoverd that the group the user was trying to send the email to was a security group.

     

    we changed the security group to a distribution group and now the user is able to send to the group.

     

    Weird solution but it seems to work.

    You can send email if you are in Security Group, you just need to make sure that they are Universal Security Group.

    Do this and post the update.


    Gulab | MCITP: Exchange 2010-2007 | Lync Server 2010 | Windows Server 2008 | Skype: Exchange.Ranger | Blog: www.ExchangeRanger.Blogspot.com
    Thursday, October 13, 2011 2:37 PM