none
Entourage 2008 EWS Attachment limit on Exchange 2010

    Question

  • Hi Folks,

    I'm having a problem allowing my Entourage users to attach files larger than 10MB. I've looked through all of the potential attachment limits on Transport config/Send connectors/Receive connectors/Users mailbox settings, but they all look okay to me.

    [PS] C:\Windows\system32>get-mailbox user | fl max*
    MaxSafeSenders    :
    MaxBlockedSenders :
    MaxSendSize       : 150 MB (157,286,400 bytes)
    MaxReceiveSize    : 150 MB (157,286,400 bytes)

    [PS] C:\Windows\system32>get-sendconnector | fl max*

    MaxMessageSize : 150 MB (157,286,400 bytes)
    MaxMessageSize : 150 MB (157,286,400 bytes)

    [PS] C:\Windows\system32>get-receiveconnector | fl max*

    MaxInboundConnection                    : 5000
    MaxInboundConnectionPerSource           : unlimited
    MaxInboundConnectionPercentagePerSource : 100
    MaxHeaderSize                           : 64 KB (65,536 bytes)
    MaxHopCount                             : 30
    MaxLocalHopCount                        : 8
    MaxLogonFailures                        : 3
    MaxMessageSize                          : 150 MB (157,286,400 bytes)
    MaxProtocolErrors                       : 5
    MaxRecipientsPerMessage                 : 5000
    MaxAcknowledgementDelay                 : 00:00:30

    MaxInboundConnection                    : 5000
    MaxInboundConnectionPerSource           : 20
    MaxInboundConnectionPercentagePerSource : 2
    MaxHeaderSize                           : 64 KB (65,536 bytes)
    MaxHopCount                             : 30
    MaxLocalHopCount                        : 8
    MaxLogonFailures                        : 3
    MaxMessageSize                          : 150 MB (157,286,400 bytes)
    MaxProtocolErrors                       : 5
    MaxRecipientsPerMessage                 : 200
    MaxAcknowledgementDelay                 : 00:00:30

    [PS] C:\Windows\system32>get-transportconfig | fl max*

    MaxDumpsterSizePerDatabase : 100 MB (104,857,600 bytes)
    MaxDumpsterTime            : 7.00:00:00
    MaxReceiveSize             : 150 MB (157,286,400 bytes)
    MaxRecipientEnvelopeLimit  : unlimited
    MaxSendSize                : 150 MB (157,286,400 bytes)

    I'm running Exchange 2010 (with Rollup3 installed), on Server 2008R2.
    My clients are running Entourage 2008 EWS, patched up with the latest Office Mac updates.
    Apart from their inability to send 10+MB attachments, everything else is fine.

    Regards,

    Tuesday, April 20, 2010 8:59 AM

Answers

  • Hi Guys,

    Finally got to the bottom of this problem. I needed to make a further change to my EWS web.config file. The maxReceivedMessageSize variable needed to be increased, I changed it to 51200000.

     

    Solution:
    Increase the 'maxRequestLength' of web.config (found in 'ClientAccess\exchweb\ews' & 'ClientAccess\owa').
    Increase the 'maxReceivedMessageSize' of web.config  (found in 'ClientAccess\exchweb\ews').
    Opened command prompt & run the following:
    cd \Windows\System32\inetsrv
    appcmd set config "Default Web Site/ews" -section:requestFiltering -requestLimits.maxAllowedContentLength:51200000
    appcmd set config "Default Web Site/owa" -section:requestFiltering -requestLimits.maxAllowedContentLength:51200000
    iisreset

    • Marked as answer by JDH1 Tuesday, April 27, 2010 3:22 PM
    Tuesday, April 27, 2010 3:22 PM

All replies

  • Come on guys, can't anyone offer advise? This seems like a very basic administrator question, yet it's not documented anywhere.

    Situation - Entourage EWS 2008 users cannot attach files greater than 10MB due to mailbox limitations (on Exchange 2010 w/ Rollup 3 installed)
    Problem - I cannot find where this limit is coming from, Transport config/Send connectors/Receive connectors/Users mailbox settings are all set to 150MB files.

    Wednesday, April 21, 2010 7:52 PM
  • Is the attachment limit just with EWS? Limits shouldn't care about what protocol is being used.
    Wednesday, April 21, 2010 11:44 PM
  • You need to edit the web.config file for ews (C:\Program Files\Microsoft\Exchange Server\ClientAccess\exchweb\ews).

     

    http://ministry-it.blogspot.com/2009/08/entourage-ews-attachment-limits.html

    http://portal.msxforum.de/modules/newbb/viewtopic.php?topic_id=11135&forum=38

     

    Thursday, April 22, 2010 6:23 AM
  • Thanks for the links mahoneybay, much appreciated. I've got past the initial error, but now I'm getting another error.

    When my Entourage users attempt to send a 10MB+ file, they receive the following:

    Error
    HTTP error. The server cannot fulfill the request.
    Explanation
    Mail could not be sent. The message has been moved to your Drafts folder. Account Name "myaccount"
    Error: -18500.

    Any advice for this error? i've tried stopping/starting IIS, & rebooting the entire server.

    Monday, April 26, 2010 12:27 PM
  • Since entourage connects to exhcaneg 2010 through OWA the attachment size limit needs modified as mahonebay suggested. I had to modify the web.conf file and increased it to 100 MB. Make certain to open notepad as an administrator so you can edit the file.

    regards,

    Peter

     


    Hi Peter could you be more precise? I've followed the notes from mahonebay's links.

    I have updated the mazrequestlength of web.config (found in 'ClientAccess\exchweb\ews' & 'ClientAccess\owa').
    Then I opened command prompt & ran the following:
    cd \Windows\System32\inetsrv
    appcmd set config "Default Web Site/ews" -section:requestFiltering -requestLimits.maxAllowedContentLength:51200000
    appcmd set config "Default Web Site/owa" -section:requestFiltering -requestLimits.maxAllowedContentLength:51200000
    iisreset

    After these changes, I started to receive a new error: "HTTP error. The server cannot fulfill the request"
    Before these changes the error was a message stating the user had exceeded a size limit, so i feel we've got past the 1st hurdle, but something is still not going through.

    Tuesday, April 27, 2010 9:15 AM
  • Hi Guys,

    Finally got to the bottom of this problem. I needed to make a further change to my EWS web.config file. The maxReceivedMessageSize variable needed to be increased, I changed it to 51200000.

     

    Solution:
    Increase the 'maxRequestLength' of web.config (found in 'ClientAccess\exchweb\ews' & 'ClientAccess\owa').
    Increase the 'maxReceivedMessageSize' of web.config  (found in 'ClientAccess\exchweb\ews').
    Opened command prompt & run the following:
    cd \Windows\System32\inetsrv
    appcmd set config "Default Web Site/ews" -section:requestFiltering -requestLimits.maxAllowedContentLength:51200000
    appcmd set config "Default Web Site/owa" -section:requestFiltering -requestLimits.maxAllowedContentLength:51200000
    iisreset

    • Marked as answer by JDH1 Tuesday, April 27, 2010 3:22 PM
    Tuesday, April 27, 2010 3:22 PM
  • Followed this to the letter changing all instances of maxRequestLength and it breaks EWS access via Entourage and OWA. Driving me up the wall.

     

    Getting the HTTP error reported above

     

    Running Fully patched Exchange 2010 on Windows 2008 R2 - mixture or Outlook 2010 clients and Entourage 2008 latest version

    Friday, June 25, 2010 4:36 AM
  • Found this article when I was searching for an issue i'm having with Entourage 2008 and with OWA attachment sizes.  I'm not using 2010, i'm using 2007 so this may not resolve your issue Ride 165 but give it a try.

    I enabled Custom Error logging and found that the max size must be between 0-2097151, where as above it sets it to 51200000, like I said Exchange 2010 may have a larger cap then 2007 and this may be completely unrelated but I figured I would reply.  All I did was follow the above steps and instead of using 51200000 I used 2097151.

    Monday, June 28, 2010 4:41 PM
  • Followed this to the letter changing all instances of maxRequestLength and it breaks EWS access via Entourage and OWA. Driving me up the wall.

     

    Getting the HTTP error reported above

     

    Running Fully patched Exchange 2010 on Windows 2008 R2 - mixture or Outlook 2010 clients and Entourage 2008 latest version


    Has anyone else gotten this to work?  As mentioned, there are multiple maxrequestlength entries in the ews web.config.  The OPs instructions are very vague.  Is the iis "appcmd" part necessary?  How would one undo that if it breaks IIS like it did for Ride165?  I need to fix the attachment issue but would rather not screw up OWA and EWS for everyone.

     

    Thanks

    Saturday, July 31, 2010 11:27 AM
  • So how in the world did this get marked as the answer?  basically nothing in it does anything for me but break stuff. 

    I'm in the same boat as JDH1 and at the command prompt I get errors from the appcmd lines.  Don't the appcmd lines just modify the web.conf file anyway, so why can't that be done when maxrequestlength and maxreceivedmessagesize are being changed? 

    Also, when I modify those values, I can't connect using EWS.  I have to set them back to the default and restart IIS.

    Is there a KB or some official information from microsoft as to why their Entourage product, made to work with EWS, only partly works with EWS? 

    Friday, August 13, 2010 8:32 PM
  • No, I've had no luck either.  Check my reply to JDH1's posting that's marked as the answer.
    Friday, August 13, 2010 8:33 PM
  • This is a base 64 encoded message, for me, JDH1's value didn't work. I used 33600000, in ONLY the EWS/web.config file. I didn't touch OWA. 

    Then,  I ran: appcmd set config "Default Web Site/ews" -section:requestFiltering -requestLimits.maxAllowedContentLength:33600000 

    (This is required because if you don't, it will revert to the original value upon restarting IIS or the server).

     

    Then, I finally ran: IISRESET.

    Then restarted my Outlook 2011 Mail Clients. Worked perfectly then. You may want to retain a backup copy of the file you modified, and another copy of the current one incase a patch overwrites it. Then rerun the appcmd statement to make the new value stick.

     

     

    Friday, February 18, 2011 9:10 PM
  • I am also having trouble with this. I set the limits to 102400000 but I can only send a 15MB attachment, I cannot send a 25MB attachment. Anyone have a suggestion?
    Monday, March 07, 2011 6:41 PM
  • Wednesday, July 06, 2011 12:57 PM
  • Hi Everyone,

     

    Outlook 2011 technician here. The web.config file needs to be modified with correct values to allow EWS clients to send larger emails.

    Outlook 2011 14.1.3 currently has a known issue in sending large attachments. This will be resolved in a future release.

    Edit the web.config file under ..\Program Files\Microsoft\Exchange Server\v14\ClientAccess\Exchweb\EWS and change the following values:

     

    maxReceivedMessageSize value to [example value] 51200000 underneath the heading <EWSMessageEncoderSoap11Element />. There are 6 places to make this change (bytes)

    MaxRequestLength - leave it at the default value 2097152 (KB)

    MaxAllowedContentLength - you may want to increase the value slightly from the message limit set in transport to allow for message bloat in transit [example value] 52428800 (50MB) (bytes)

    Add the entry executionTimeout - this value will extend the HTTP timeout for the session and because Outlook 2011 needs to send the message and also sync it back up to the client and when the message is large you run the risk of it timing out in transit (seconds).

     

    Saturday, November 19, 2011 1:58 AM
  • Also please see http://technet.microsoft.com/en-us/library/bb124345(EXCHG.80).aspx
    Saturday, November 19, 2011 2:00 AM
    • Proposed as answer by Shane Toutges Saturday, November 19, 2011 2:07 AM
    Saturday, November 19, 2011 2:06 AM
  • Your links are all for Exchange 2007.  This is an Exchange 2010 forum.  Also, this is by no means an outlook 2011 issue that can be fixed by a client update.  This is an EWS protocol issue.

    I have never seen an official Microsoft document on how to fix the EWS attachment size in Exchange 2010.  Internet searches always bring up this thread or some sketchy back alley blogs.  From what I've pieced together from all these sources, this is the only way I know of to increase the EWS attachment size:

     

    Make a backup of any of the files before editing.  This example is for ~100 MB.  Taylor the values for your environment.

    1. edit C:\Windows\System32\inetsrv\config\applicationHost.config

    Requestfiltering=Allow


    2. from a command prompt:

    C:\Windows\System32\inetsrv\appcmd set config "Default Web Site/ews" -section:requestFiltering -requestLimits.maxAllowedContentLength:100800000

     

    3. edit web.config in the ews directory of each CAS and set these values:


    maxAllowedContentLength=100800000 (step 2 should have inserted this value)
    maxReceivedMessageSize=100800000 (multiple instances of this. Change all of them)

    4. iisreset

    If things go horribly wrong, restore the backup you made of the web.config file.

    • Proposed as answer by Nehuskerz Friday, June 28, 2013 6:53 PM
    Saturday, November 19, 2011 5:16 AM
  • Please check, what version you are using?

    Exchange 2010 is required Microsoft Office for Mac 2011 with Service Pack 1. i am asuming you are using Microsoft Office for Mac 2011 (with out SP1).

    Cheers,

    Vijay.

    Monday, January 30, 2012 10:31 AM
  • Is there an official KB article from microsoft for this configuration on a Exchange 2010 with SP1 and MS Office 2011 for Mac?

    the link above is for Entourage 2008 for Mac, Exchange 2007 server on Small Business Server 2008.

    Tuesday, February 14, 2012 4:07 PM
  • Hi,

    i also encountered same issue. I've adjusted size to 50MB in web config (EWS) and web config (OWA). But mac users 2011 are still unable to send the attachment file more than 20MB. However, it is no problem in OWA which i can send the attachement up to 50MB.

    Any Solution?

    Saturday, November 03, 2012 4:19 AM
  • Hi,

    i also encountered same issue. I've adjusted size to 50MB in web config (EWS) and web config (OWA). But mac users 2011 are still unable to send the attachment file more than 20MB. However, it is no problem in OWA which i can send the attachement up to 50MB.

    Any Solution?

    Saturday, November 03, 2012 4:19 AM
  • This is the fix. Follow these direction exactly.

    Well done JRVA_Q.

    • Edited by Rick Culler Tuesday, January 20, 2015 10:12 PM
    Tuesday, January 20, 2015 10:11 PM
  • Shane Toutges solution worked for us.  Exchange Server 2010 (current patch level as of March 2015), Mac OS Outlook 2011 via EWS.

    Key to the solution is this revision:
    maxReceivedMessageSize value to [example value] 51200000 underneath the heading <EWSMessageEncoderSoap11Element />. There are 6 places to make this change (bytes)

    I have not seen this noted under the several MS Tech Net articles that pertain to the problem of sending large email attachments via Mac Outlook 2011 via EWS.

    Tuesday, March 03, 2015 3:54 PM