none
Internal Autodiscover not working

    Question

  • Hello

    Since a rather troublesome S2 install recently (had to run with /m:recoverserver after it crashed half way through), we are having no luck with Autodiscovery. Test-outlookwebservices gives:

     

    Id      : 1003

    Type    : Information

    Message : About to test AutoDiscover with the e-mail address temp-admin@domain.com.

     

    Id      : 1007

    Type    : Information

    Message : Testing server server.domain.local with the published name ht

              tps://server.domain.local/EWS/Exchange.asmx & .

     

    Id      : 1019

    Type    : Information

    Message : Found a valid AutoDiscover service connection point. The AutoDiscover

               URL on this object is https://server.domain.local/Autodiscov

              er/Autodiscover.xml.

     

    Id      : 1013

    Type    : Error

    Message : When contacting https://server.domain.local/Autodiscover/Auto

              discover.xml received the error The remote server returned an error: 

              (404) Not Found.

     

    Id      : 1006

    Type    : Error

    Message : The Autodiscover service could not be contacted.

     

     

    If I browse to https://server.domain.local/autodiscover/autodiscover.xml I get 'page cannot be displayed' (whilst logged on to the cas. If I browse to https://localhost/autodiscover.autodiscover.xml I get the 600 invalid request error....

    testing from the client gives an output of

     

    4888 16338125 07/08/10 12:20:50 Autodiscover to https://domain.com/autodiscover/autodiscover.xml starting

    4888 16341156 07/08/10 12:20:53 Autodiscover request completed with http status code 502

    4888 16341156 07/08/10 12:20:53 Autodiscover to https://domain.com/autodiscover/autodiscover.xml FAILED (0x80004005)

    4888 16341156 07/08/10 12:20:53 Autodiscover to https://autodiscover.domain.com/autodiscover/autodiscover.xml starting

    4888 16341187 07/08/10 12:20:53 Autodiscover request completed with http status code 502

    4888 16341187 07/08/10 12:20:53 Autodiscover to https://autodiscover.domain.com/autodiscover/autodiscover.xml FAILED (0x80004005)

    4888 16341187 07/08/10 12:20:53 Local autodiscover for domain.com starting

    4888 16341187 07/08/10 12:20:53 Local autodiscover for domain.com FAILED (0x8004010F)

    4888 16341187 07/08/10 12:20:53 Redirect check to http://autodiscover.domain.com/autodiscover/autodiscover.xml starting

    4888 16341203 07/08/10 12:20:53 Redirect check to http://autodiscover.domain.com/autodiscover/autodiscover.xml FAILED (0x80004005)

    4888 16341203 07/08/10 12:20:53 Srv Record lookup for domain.com starting

    4888 16341203 07/08/10 12:20:53 Srv Record lookup for domain.com FAILED (0x8004010F)

     

     

    I need to get internal autodiscover access working, nothing else. I don't understand why local autodiscover is looking for server.com when the server fqdn is server.local. Is this right?

    I can't alter DNS, due to a dispute with service provider (which is in the process of being sorted, fortunately).

    This worked perfectly before the SP2 install.

     

    I have also removed and recreated the autodiscover vdir, and the internaluri is set in the SCP as http://server.domain.local/autodiscover/autodiscover.xml

    This xml file does exist and have the correct permissions.

    Can anyone offer any advice? I'll be happy to answer questions.

    Thanks

    Jim

    Thursday, July 08, 2010 4:56 AM

Answers

All replies

  • Hi Jim ,

    I hope you will get your answer from these links.

    http://exchange-genie.blogspot.com/2007/07/401-error-when-attempting-test.html
    http://support.microsoft.com/?id =896861

     

    Regards.

    Shafaquat Ali.


    M.C.I.T.P Exchange 2007/2010, M.C.I.T.P Windows Server 2008, M.C.T.S OCS Server 2007 R2
    Thursday, July 08, 2010 5:13 AM
  • Thanks for your reply, but the error I see is a 404, not 401, and the test-outlookwebservices runs fine - am I missing a reason why you pointed me at these articles? Apologies if so.

     

    Jim

    Thursday, July 08, 2010 5:24 AM
  • Hi Jim ,

    Its ok but I think you did not get my point I M giving you the links for your event IDs not for your error because if you will remove these events than it will work fine and in these link there is discussion about to remove these event errors.

     

    Regards.

    Shafaquat Ali.


    M.C.I.T.P Exchange 2007/2010, M.C.I.T.P Windows Server 2008, M.C.T.S OCS Server 2007 R2
    Thursday, July 08, 2010 5:30 AM
  • OK, well thanks for getting back to me. I will look at this option. It's also the case that no Outlook clients can access the autodiscovery feature (as shown by my second log dump which is a test-autconfiguration from the client. I doubt these would be affected by disabling lookback??

     

    Does anyone else have an opinion?

    Thursday, July 08, 2010 6:24 AM
  • Hi,

    To get the 600 error code when accessing https://localhost/autodiscover/autodiscover.xml, that is the expected behaviour. However, it's wrong response when accessing https://server.domain.local/autodiscover/autodiscover. That should be the same response as received 600 error code.

    404 error code related to the A record in the DNS. Thus, please ensure the server.domain.local record can be resolved for your internal clients in the DNS.

    Thanks

    Allen

    • Marked as answer by Allen Song Friday, July 16, 2010 9:44 AM
    Tuesday, July 13, 2010 8:33 AM
  • It would be much appreciated if autodiscover was optional for Microsoft customers.
    Thursday, August 25, 2011 5:50 PM