locked
Mdamon To Exchange 2007 migration RRS feed

  • Question

  • Hello,

    We have an Mdaemom 9.6 server mail, that we want migrate to Exchange 2007 SP2. We have installed Microsoft transporter Suite for export some mailboxes to Exchange.

    When try to export the mailboxes, all mailboxes with folder that have more of 1500 messages fails, with this error:

    "Failed to retrieve the properties of a message in folder INBOX for the following reason: Failed to retrieve the properties of a message in folder INBOX for the following reason:  FETCH parse error.

    Microsoft.Exchange.Transporter.TransporterException: Failed to retrieve the properties of a message in folder INBOX for the following reason: Failed to retrieve the properties of a message in folder INBOX for the following reason:  FETCH parse error.. ---> Microsoft.Exchange.Transporter.TransporterException: Failed to retrieve the properties of a message in folder INBOX for the following reason:  FETCH parse error.
       at Microsoft.Exchange.Transporter.Provider.PopImap.Imap4Client.ParseMessageProperties(RequestState`3 requestState)
       at Microsoft.Exchange.Transporter.Provider.PopImap.Imap4Client.RequestMessageProperties(Object threadParam)
       --- End of inner exception stack trace ---"

    When I receive this error, the folder is skipped and no message are exported to exchange.

    Can i resolve thi issue, without change message number per folder?

    Thank you!

    Daniele

    Monday, August 16, 2010 8:09 AM

Answers

  • You can try to following registry key and see if it help. This will limit the number of messages the migration process will bring over at once.

    ImapFetchBatchSize

    To create this reg key:

    1. Navigate to HKCU\Software\Microsoft\Transporter\Preferences.
    2. On the Properties of the Preferences key, right click and select New, String Value.
    3. Name this new string value "ImapFetchBatchSize".
    4. For the Value data field, enter 2000 and close registry editor.
    Note: The default batch size is 2500. Decreasing the value will increase the duration time of the migration. If the value of 2000 still produce this warning message, continue to decrease the value until the warning is no longer producing. Likewise if the value of 2000 does not generate the warning, you can increase it slightly if you want to decrease the duration time of the migration. I would set it around 500 and see if the migration is successful. The value can always be increased if that works.

    Another option is to run the move-imapmailboxtoexchange cmdlet with the /debug switch and get the output in-house

    Example:
    move-imapmailtoexchange -sourceidentity "tom@contoso.com" -sourceloginid "tom" -sourcepassword "P@ssword1"-sourceserver "contoso.imap.com" /debug

    Wednesday, August 25, 2010 1:35 PM

All replies

  • Hi,

    I think you should use these methods.

    1.  make your MDAEMON as gateway only...By changing its name from YOURDOMAIN.COM to MYDOMAIN.LOCAL

    2. make a gateway in MDAEMON of name YOURDOMAIN.COM and forward all its emails to that IP  of your exchange server. (All emails coming from outside would go directly to EXCHANGE server, without checking users. This is best scenario to protect yourself from viruses/spams..etc
    Note: Don't forget to declare in MS EXCHANGE this MDAEMON IP /DOMAIN as RELAY SERVER, otherwise, MS EXCHANGE WOULDN't accept emails from it


    3. Best way is that outgoing emails should go direct from MSEXCHANGE...otherwise, put IP or domain as TRUST domain in MDAEMON settings. it would accept emails from Exchange and forward  it to OUTER world

    to move emails from users inbox to Exchange is simple, just after doing copy email user by user inbox emails in INBOUND QUEUE of MDAEMON
    It would again process the email and would send it to GATEWAY...YOURDOMAIN.COM folder...then it would process to MSEXCHANGE

    Only problem is All messages would be seen as new (even already read messages)
    Other option is to export as PST then merge into exchange

     

    I hope this will help you.

     

    Regards.

    Shafaquat Ali.


    M.C.I.T.P Exchange 2007/2010, M.C.I.T.P Windows Server 2008, M.C.T.S OCS Server 2007 R2, URL: http://blog.WhatDoUC.net Phone: +923008210320
    Monday, August 16, 2010 9:07 AM
  • This is not a solution, because our mailboxes are very big. We want retain send and receive data.

    All mailbox content must be migrated to Exchange.

    Are there no workaround for the problem that I can see with the Transporter Suite?

    Thank you!

    Daniele

    Friday, August 20, 2010 1:54 PM
  • You can try to following registry key and see if it help. This will limit the number of messages the migration process will bring over at once.

    ImapFetchBatchSize

    To create this reg key:

    1. Navigate to HKCU\Software\Microsoft\Transporter\Preferences.
    2. On the Properties of the Preferences key, right click and select New, String Value.
    3. Name this new string value "ImapFetchBatchSize".
    4. For the Value data field, enter 2000 and close registry editor.
    Note: The default batch size is 2500. Decreasing the value will increase the duration time of the migration. If the value of 2000 still produce this warning message, continue to decrease the value until the warning is no longer producing. Likewise if the value of 2000 does not generate the warning, you can increase it slightly if you want to decrease the duration time of the migration. I would set it around 500 and see if the migration is successful. The value can always be increased if that works.

    Another option is to run the move-imapmailboxtoexchange cmdlet with the /debug switch and get the output in-house

    Example:
    move-imapmailtoexchange -sourceidentity "tom@contoso.com" -sourceloginid "tom" -sourcepassword "P@ssword1"-sourceserver "contoso.imap.com" /debug

    Wednesday, August 25, 2010 1:35 PM
  • Dear Shafaquat Ali,
    Hope you are fine and doing well.
    We are planning to migrate from MDaemon latest version to MS Exchange 2010.
    I have tested all the configurations (CAS array , Mailbox HA, Policies) in test environment.
    Now we are planning to migrate our current email server user’s emails to MS Exchange 2010.
    For this i did the same configurations as per your suggestion in test lab but users emails are not going form inbound queue of MDaemon to MS Exchange 2010 Mailbox account.
    Kindly guide me if I am missing something or something I need to try.
    Your cooperation in this regard will be highly appreciated.
    Br, Rizwan Ahmed
    Sunday, April 22, 2012 8:48 AM