none
Distribution Group manager can't modify group RRS feed

  • Question

  • Setup

    MS Exchange 2010 version 14.3 (Build 123.4)

    Distribution Group is a Mail Universal Distribution which has less than 20 members total

    There are three managers in the "Managed By" listing.  Of these two can modify the list, the third cannot.  When the third manager tries to modify the list they get the following error:

    The Public Group cannot be displayed.  The connection to Microsoft Exchange is unavailable.  Outlook must be online or connected to complete this action.

    Note: The user is connected to the Exchange environment as evidenced by the "Connected to Microsoft Exchange" in the lower right portion of his Outlook 2010 window.  He is also hardwired into the network, ie no wireless connection.  He tried the going in through OWA and got the same error as above.  

    Any ideas on what I can check to see why this manager cannot modify the list whereas the other two can? 


    nc

    Thursday, February 12, 2015 8:55 PM

All replies

  • Hi ncouch55,

    Thank you for your question.

    Did the specific manager belong to different domain?

    We could use the following command to check if the user has been granted permission by the item of “ManageBy”:

    Get-DistributionGroup –Identity “DistributionGroup name”

    If the specific user wasn’t existed in the item of “Manger By”, we could refer to the following command to configure permission with the specific user:

    Set-DistributionGroup –Identity “DistributionGroup name” –ManageBy  “the specific user”

    Then we could check if we has configured successfully by Get-DistributionGroup.

    If there are any questions regarding this issue, please be free to let me know. 

    Best Regard,

    Jim

    Friday, February 13, 2015 5:16 AM
  • Thank you for your reply Jim.

    In answer to your questions:

    1) Yes, the manager who is having the problem is in the same domain as the other two managers.  All three are in the same AD container.

    2) I checked the manager's permissions with the Get-DistributionGroup cmdlet above and he does show up in the Managed By listing.

    Nate


    nc

    Friday, February 13, 2015 3:25 PM
  • Hi ncouch55,

    If there are multiple GCs in organization, We could refer to the following link to choose the closest GC for the specific user:

    1). Click Start, and then click Run.

    2). In the Open box, type regedit.exe, and then click OK.

    3). Locate and then click the following key in the registry:

    HKEY_CURRENT_USER\Software\Microsoft\Exchange\Exchange Provider

    Note You may have to create the registry path.

    4). On the Edit menu, click Add Value, and then add the following registry value:

    Value name: GC Server

    Data type: REG_SZ (string)

    Value data: the FQDN of the closest GC server

    5). Quit Registry Editor.

    If the issue persist, we could clear manager on distribution group and re-grant permission to three manager.

    If there are any questions regarding this issue, please be free to let me know. 

    Best Regard,

    Jim

    Sunday, February 15, 2015 8:25 AM
  • Jim,

    Thank you for your reply.  Unfortunately, I am unable to make such a change as the environment I administer contains over 70,000 mailboxes (something I should have mentioned).  Hence, any change I make must go through change control.  Not a big deal in and of itself, but not feasible for a single user.  If this issue effected hundreds or thousands of users then I would gladly do it.  What I was hoping for was something that could be done at his workstation, or on his particular account/mailbox, or the distribution group in question, i.e. something more granular to this manager.

    Additional note, the manager did find that he could manage the list via OWA.  I am unsure what he was doing before when he said he could not do so.  Maybe it was a version issue.  I will see if I can find out.

    Anyway, thank you for your time.  If you think of anything else that would be helpful please let me know.

    Regards.

    Nate



    nc

    Wednesday, February 18, 2015 5:31 PM