Radeon Graphics card driver failure (N-Series VM) RRS feed

  • Question

  • I'm trying to get a VM with a graphics card working in Azure.  I've created a Win10 VM from the marketplace - sized as NV4as_v4, and followed the instructions:




    This appears to be a Radeon MI25, but I can't get it to run.

    It worked for about a week on Windows 2016 Server, and then failed after a reboot, never to work again.  I've tried numerous ways to install, uninstall, change Azure size.  In my current attempt, here's what I've done:

    1. Deploy Win 10 NV4as_v4 from marketplace
    2. Power it on for initial logon (privacy question, etc.)
    3. Run powershell: Set-AzVMExtension -ResourceGroupName <resource> -VMName <vmname> -Location "East US" -Publisher "Microsoft.HpcCompute" -ExtensionName "AmdGpuDriverWindows" -ExtensionType "AmdGpuDriverWindows" -TypeHandlerVersion 1.0 -SettingString '{ }'
    4. VM logs appear to indicate that the install completes normally (exit code 0)
    5. Wait for CPU to settle down (5 or 10 minutes?), and manually reboot - there was no automated reboot.

    How do I get a graphics card to work in Azure?

    Sunday, May 17, 2020 7:27 AM

All replies

  • Help?  Is this some sort of issue where the installed driver has an affinity for the physical card it was installed for, which may not always be the case in a cloud platform?  This appears to be a completely non-functional feature as it currently stands.
    Monday, May 18, 2020 5:18 PM