none
Exchange 2013 - Quota notifications problem

    Question

  • Hello,

    First of all I want to express mild disappointment with the way quota notification alerts are documented on Technet for Exchange 2013. The only reference I could find is that QuotaNotificationSchedule parameter of the Set-MailboxDatabase cmdlet no longer does anything: "This parameter has been deprecated in Exchange 2013 and it no longer does anything.".

    The only other reference I could find is this forum post:
    http://social.technet.microsoft.com/Forums/exchange/en-US/f30bb2ca-91ab-4e69-a8b6-720e6a8a5b83/exchange-2013-quota-notification-message-not-sent-during-schedule?forum=exchangesvrgeneral

    where it says: "Quota messages are generated once the user log in to mailbox in exchange 2013."

    However, Microsoft Press published a book in 2013 "Inside Out: Microsoft Exchange Server 2013: Mailbox and High Availability" where QuotaNotificationSchedule parameter is being referenced as a working parameter which controls when Quota notification are being sent.

    My experience says that the forum post is correct.

    Now onto the problem.

    While our customer was still on Exchange 2010 they were the victims of this issue:
    http://support.microsoft.com/kb/2480474/en-us which could easily be fixed with CheckWarningQuota registry key.

    Now we have migrated those mailboxes to Exchange 2013 and again, users are not receiving quota notification e-mails. Only a few users receive quota notifications e-mails and those are users that got their mailbox created on the new Exchange 2013 system. Migrated users do not receive notifications. We have tried CheckWarningQuota on Exchange 2013 but it does nothing. Our theory is that mailbox flag introduced in Exchange 2010 SP1 is migrated with the mailboxes to Exchange 2013 and is the reason why we are not receiving quota notifications again.

    I appreciate thoughts and comments.

    Regards,
    Dinko

    Friday, May 30, 2014 11:57 AM

Answers

  • Hi Dinko,

    Currently the solution is to move the mailboxes to a new database. I fully understand the inconvenience to move thousands of mailboxes, but we don’t have other solution at current stage. And since we can find the warning in Outlook taskbar, we can ask end users to pay attention to this. Meanwhile, I will discuss with my colleagues to see if we have a better fix for this issue. Thanks for your understanding and cooperation.


    Regards, Eric Zou

    Thursday, June 5, 2014 7:40 AM
    Moderator

All replies

  • Hi Dinko,

    Thank you for your post.

    This is a quick note to let you know that we are performing research on this issue.

    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com


    Simon Wu
    TechNet Community Support

    Monday, June 2, 2014 3:58 AM
    Moderator
  • Hi Dinko,

    As describled in Exchange Server 2013 article of “Set-MailboxDatabase”, the parameter “QuotaNotificationSchedule” has been deprecated in Exchange 2013 and it no longer does anything. And after the installation of Exchange 2010 Service Pack 1, users will get only one quota notification message regarding their mailbox size. This is a change in behavior from RTM versions of Exchange 2010, where a quota notification message get generated every time quota maintenance is run. And Exchange 2013 also inherits this behavior from Exchange 2010. The quota warning would only be trigged once on a database.

    For more information, please refer to this forum:

    Title: Exchange 2010 SP1 Quota Warning Messages not being sent...

    Link: http://social.technet.microsoft.com/Forums/exchange/en-US/a5eb2d04-0b41-4e82-84cb-76157d6712d3/exchange-2010-sp1-quota-warning-messages-not-being-sent

    Meanwhile, after we modify the registry key CheckWarningQuota, did we modify it on all the Exchange Servers and restart the Informaiton Store servie to verify? If so, the registry may also not available for Exchange 2013.


    Regards, Eric Zou


    Tuesday, June 3, 2014 7:25 AM
    Moderator
  • Hi Eric,

    We have modified CheckWarningQuota on all Exchange 2013 Mailbox servers and restarted the Information Store service, but still nothing.

    Regarding your comment: "And after the installation of Exchange 2010 Service Pack 1, users will get only one quota notification message regarding their mailbox size."

    I think that only applies if you have warning quota set below 50% of the prohibit send quota. But event then, when the mailbox flag is reset it is again checked for warning quota on each schedule:

    "This happens when either a message is saved in the mailbox or a message is submitted. At that point, if the mailbox size is more than 50% of the Prohibit Send quota then the flag is reset and the mailbox will be checked during the next QuotaNotificationSchedule time slice. "

    We have warning quota set at 75% of the prohibit send quota in our environment.

    What is still not clear to me is when are the quota notifications actually sent. I will again quote the forum post from my initial post:

    "http://social.technet.microsoft.com/Forums/exchange/en-US/f30bb2ca-91ab-4e69-a8b6-720e6a8a5b83/exchange-2013-quota-notification-message-not-sent-during-schedule?forum=exchangesvrgeneral

    where it says: "Quota messages are generated once the user log in to mailbox in exchange 2013.""

    We do not experience this is in our environment. In fact, users only receive OWA pop up box, but no notifications or popups in Outlook 2013.

    Regards,
    Dinko

    Tuesday, June 3, 2014 8:23 AM
  • Correction to the above post...

    Users receive OWA pop up box and Outlook 2013 warning in taskbar, but not e-mail notification.

    Tuesday, June 3, 2014 9:07 AM
  • Hi Dinko,

    Thanks for your reply.

    I know we set the warning quota at 75% of the prohibit send quota, and users receive OWA pop up box and Outlook 2013 warning in taskbar, but not e-mail notification.

    As for this, I would like to confirm does the quota is set on the database level and the mailboxes use the database default quota? If so, please try to set the quota settings directly on the mailbox level, don’t use the database quota settings.

    Moreover, after further research, I found that some other users have similar issue that only users migrated from Exchange 2010 to Exchange 2013 are affected, they can’t receive quota warning message. The solution is to move the users to a new database. Please try the solution as well.


    Regards, Eric Zou

    Wednesday, June 4, 2014 7:40 AM
    Moderator
  • Eric,

    All mailboxes use mailbox level quotas.

    Thank you for the hint. I have tried with a mailbox move from database to database and soon as I logged on to the mailbox I received a quota warning notification message.

    I'm now waiting confirmation from the customer.

    However, it is still not very feasible to move over 1 thousand mailboxes around just to get the quota warning notification working. Would love to have an easier fix...

    Regards,
    Dinko

    Wednesday, June 4, 2014 9:11 AM
  • Hi Dinko,

    Currently the solution is to move the mailboxes to a new database. I fully understand the inconvenience to move thousands of mailboxes, but we don’t have other solution at current stage. And since we can find the warning in Outlook taskbar, we can ask end users to pay attention to this. Meanwhile, I will discuss with my colleagues to see if we have a better fix for this issue. Thanks for your understanding and cooperation.


    Regards, Eric Zou

    Thursday, June 5, 2014 7:40 AM
    Moderator
  • Hi Dinko,

    After further research, we didn't find other solution to resolve this issue. Currently the workaround is to move the mailboxes to a another database. Sorry for the inconvenience.


    Regards, Eric Zou

    Thursday, June 12, 2014 8:29 AM
    Moderator
  • Please explain more thoroughly.

    Are you saying that all mailboxes migrated from 2010 to 2013 are going to experience this issue?

    And are you saying the official microsoft "fix" for this egregious bug is to, after having moved everyone to a 2013 database, to subsequently move them to another 2013 database?

    Please explain in detail.  Thank you.

    Sunday, June 22, 2014 3:51 AM
  • As I know, it will affect mailboxes that migrated from Exchange 2010 to Exchange 2013, pure Exchange 2013 mailboxes are not affected. And currently the workaround is to move them to another Exchange 2013 database.


    Regards, Eric Zou

    Tuesday, June 24, 2014 6:07 AM
    Moderator
  • Has there been any more progress on this since June?

    Monday, August 25, 2014 6:45 PM
  • Not much progress, but we have a confirmation from Microsoft that the issue is caused due to internal bug. However, we are still waiting for a fix of some kind, probably in a form of a script or something. In the meanwhile, we have solved the problem with the migration of all the mailboxes from database to database.

    Regards,
    Dinko

    Tuesday, August 26, 2014 6:55 AM
  • Is there any progress from MS on this front? Considering another CU is due in a little over a month I feel like this should be fixed by now. 
    Wednesday, October 8, 2014 2:05 PM
  • is there any fix for the issue ?
    Friday, November 7, 2014 2:16 PM
  • Eric,

    Can you update if there has been any fix or progress on this issue.  I am experiencing it too and would like to know if I have an option other than to move all my mailboxes.

    Wednesday, December 3, 2014 3:09 PM
  • Hi JRP76,

    This isssue is a bug in Exchange 2013 and product/test team is working on it currently. Once the fix is released, I will post here quickly. Thanks for your understanding.

    Thursday, December 4, 2014 10:28 AM
    Moderator
  • Hi Eric!

    Is there an ETA for the fix for this issue, and is there an official KB documenting this issue?

    /Michael


    MCP/MCTS/MCSA http://www.compugame.dk

    Tuesday, December 30, 2014 7:07 AM
  • Hi Michael,

    As I know, the bug is still under investigation and haven't got a fix yet. I will post here once the fix is released. Thanks for your understanding.

    Tuesday, December 30, 2014 10:00 AM
    Moderator
  • Hey Eric,

    My organization is experiencing the same issue as outlined above. While we wait for a fix to be released / posted, has there been an official Microsoft KB article written for this bug? I need something to provide my department outlining the issue...

    Thank you!

    Tuesday, January 6, 2015 10:50 PM
  • Hi Nathaniel,

    Product team is still working on a resolution for the issue. However currently there is no KB article which descible the issue, no fix released yet. Please rest assurred that Product team is trying their best, we appreciate your time and patience.

    Best Regards,

    Eric Zou 


    Wednesday, January 7, 2015 7:34 AM
    Moderator
  • We are experiencing the same issue too

    Is there a way to be notified by email when the fix will be out ?

    Wednesday, January 7, 2015 2:11 PM
  • Hi All,

    It's hard to email you one by one. Once there is any new development or any KB/fix released, I will post here. Thank you for your understanding.

    Thursday, January 8, 2015 3:56 AM
    Moderator
  • Hi Eric,

    please what is the state of FIX ?

    We really need it

    Thx

    Branislav


    Branislav Pastorek SEAL IT services

    Tuesday, February 10, 2015 4:07 PM
  • Dear Eric,

    but if I will move mailboxes to the other DB (what I did) how can I achieve the customization of warning messages  ?

    thx

    Branislav


    Branislav Pastorek SEAL IT services

    Tuesday, February 10, 2015 4:09 PM
  • Hi All,

    From the internal database, the bug is still under investigating without a fix yet. Thank you for your patience.

    Regarding move mailbox to a new database, please configure the same warning messgae settings on the new database.

    Best Regards,

    Eric Zou

    Wednesday, February 11, 2015 9:05 AM
    Moderator
  • Hi Eric

    When I move the user to a new db, they start having notification again. However, user that have mailbox level quota still have no notification. Please tell me that the workaround is to remove all user quota setting so they revert on the DB one, then move them and then, reassign amilbox level quotas

    Please advise


    Alexandre Contant

    Monday, February 23, 2015 9:52 PM
  • Is there already any solution?

    Rodrigo

    Wednesday, March 11, 2015 5:53 PM
  • A fix should be available with CU8 but not for already moved Mailboxes. Only for mailboxes that were moved after CU8 is installed. This info is from the German Support Team.
    Tuesday, March 17, 2015 2:59 PM
  • Wow.  Just.....Wow.  This seriously call into question how Microsoft really tests new products.  I mean seriously, how did this not turn up in testing?  Has Microsoft lowered the 'good enough for release' bar so far that they don't even look at the most relied on aspects of their products?

    I also have to agree with Dinko in that the documentation on this is piss poor.  I have been jumping through hoops for a week trying to get this fixed until I found this thread telling me I have to move hundreds of mailbox to another Exchange 2013 database after having already migrated them to an Exchange 2013 database from 2010.  This is not a solution.  This is a waste of my and everyone else's time that honestly we should bill Microsoft for.

    Very poorly handled Microsoft.  You need to do much better than this.

    Friday, March 20, 2015 2:20 PM
  • CU8 addresses this issue, however, only for mailboxes not yet moved to 2013: https://support.microsoft.com/en-us/kb/3036952

    Mailboxes already moved will have to be manually fixed. The issue is they are missing their lcid (location ID). For whatever reason, the attribute does not make it across from 2010 to 2013. However, if you move the mailbox again to another 2013 database, it fills in the lcid automatically. That is one workaround, but not necessarily a good one for people who have migrated a ton of their users already. So what do you do?

    In the KB article, it shows you how to identify the users who are missing their LCID by doing the following in the exchange management shell:

    #first load in the ManagedStoreDiagnosticFunctions, you will need this for the get-storequery cmdlet to work.

    . .\'C:\Program Files\Microsoft\Exchange Server\V15\Scripts\ManagedStoreDiagnosticFunctions.ps1'

    #then generate the list of all mailboxes with an LCID of 0.

    $mbxs = get-mailbox –resultsize unlimited| ? {$_.exchangeversion.exchangebuild.major -ge 15}
    $mbxsq = $mbxs | %{Get-StoreQuery -Database $_.database -query "select * from Mailbox where Mailboxguid = '$($_.ExchangeGuid)'"}
    $mbxsq | ? {$_.lcid -eq 0} |fl displayname, mailboxguid, lcid

    You can modify the script to dump the list to a text file if you need to.

    Now, to address this, I simply populated the lcid for all my mailboxes. All of mine were en-US or lcid 1033, so it was easy to set them all at once. I just grabbed all Exchange 2013 mailboxes and applied the language (en-US) and DateFormat (MM/dd/yyyy) to them (replace DOMAIN with your domain name) which in turn sets the lcid to 1033:

    $mailboxes = get-mailbox -resultsize unlimited| ? {$_.exchangeversion.exchangebuild.major -ge 15}

    ($mailboxes).SamAccountName| %{set-MailboxRegionalConfiguration "DOMAIN\$_" -Language en-us -DateFormat MM/dd/yyyy} | FT -a

    Incidentally, if you have already migrated all of your 2010 mailboxes, and you are on at least Exchange 2013 CU6, that script will resolve the issue whether you apply CU8 or not. CU8 fixes it for any other mailboxes that have not yet been migrated to 2013.

    Hopefully this help you out.

    Chris Allen

    Microsoft Support Escalation Engineer


    Monday, March 23, 2015 1:30 PM
  • Hi Chis,

    To confirm, for the above to work so that users that have been migrated from EX2010 to EX2013 i need to do the following:

    1. I am currently on EX2013 CU5, so upgrade to CU6 as a minimum

    2. Run the script to verify LCID values

    3. Set the correct LCID on all mailboxes

    Once all the above has been done, my users should start to receive email alerts for quota limits set at the DB level in Exchange 2013?

    Kind Regards,

    Monday, March 23, 2015 4:23 PM
  • Looks like even accounts with LCID 1033, we still do not get warning notification emails nor in the Outlook taskbar.  The only place where we do get warning notifications is in OWA with LCID 1033 accounts. 
    Friday, April 3, 2015 8:43 PM
  • We had to wait about 24 hours for accounts with LCID 1033 to start getting notifications.  It probably would have happened faster if we reset our information store service.
    Monday, April 6, 2015 5:33 PM